Linux bluetooth development
 help / color / mirror / Atom feed
From: Marcel Holtmann <marcel@holtmann.org>
To: Vinicius Gomes <vinicius.gomes@openbossa.org>
Cc: Emeltchenko Andrei <Andrei.Emeltchenko.news@gmail.com>,
	linux-bluetooth@vger.kernel.org
Subject: Re: [PATCH bluez] add get_le/get_be helpers
Date: Mon, 24 Oct 2011 13:50:16 +0200	[thread overview]
Message-ID: <1319457038.15441.230.camel@aeonflux> (raw)
In-Reply-To: <CAE6HaMkxvTPa1eTj1Og7Lvqn=PvieuKJyzugPouwiUTOsnnW_g@mail.gmail.com>

Hi Vinicius,

> Sorry if this comes too late, but here's an idea:
> 
> How about changing the name of the functions to something a little
> more high level, for example: in attrib/att.h we have
> att_{get,put}_u16() that uses the byte order defined in the ATT spec
> (little endian).
> 
> So my suggestion is to have bt_{get,put}_u*() and sdp_{get,put}_u*
> functions (perhaps also no_{get,put}_u* for cases when we use the host
> byte order). The bt_ functions will be used for everything that uses
> the Bluetooth byte order and the sdp_ ones for SDP, which is the only
> case of Big Endian defined by Bluetooth, correct me if I am wrong.

lets not try to be too smart. We want the code clearly identify what
endian is expected. Same as the kernel handles this.

Regards

Marcel



  parent reply	other threads:[~2011-10-24 11:50 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-10-24  9:20 [PATCH bluez] add get_le/get_be helpers Emeltchenko Andrei
2011-10-24 10:13 ` Vinicius Gomes
2011-10-24 10:26   ` Andrei Emeltchenko
2011-10-24 10:27   ` Szymon Janc
2011-10-24 11:50   ` Marcel Holtmann [this message]
2011-10-24 12:06     ` Vinicius Gomes
2011-10-25  8:52 ` Johan Hedberg
2011-10-25  9:34   ` Lucas De Marchi
2011-10-25  9:22     ` Johan Hedberg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1319457038.15441.230.camel@aeonflux \
    --to=marcel@holtmann.org \
    --cc=Andrei.Emeltchenko.news@gmail.com \
    --cc=linux-bluetooth@vger.kernel.org \
    --cc=vinicius.gomes@openbossa.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox