Linux bluetooth development
 help / color / mirror / Atom feed
From: Marcel Holtmann <marcel@holtmann.org>
To: Szymon Janc <szymon.janc@tieto.com>
Cc: linux-bluetooth@vger.kernel.org
Subject: Re: [RFC 03/15] sdp: Use helper functions instead of bt_get_unaligned macro
Date: Fri, 31 Aug 2012 09:14:36 -0700	[thread overview]
Message-ID: <1346429676.23377.22.camel@aeonflux> (raw)
In-Reply-To: <1346402185-9487-4-git-send-email-szymon.janc@tieto.com>

Hi Szymon,

> This fix number of compilation errors on ARM similar to one below.
> 
> lib/sdp.c: In function 'sdp_uuid_extract':
> lib/sdp.c:1019:27: error: cast increases required alignment
> 	of target type [-Werror=cast-align]
> lib/sdp.c:1019:27: error: cast increases required alignment
> 	of target type [-Werror=cast-align]
> lib/sdp.c:1026:27: error: cast increases required alignment
> 	of target type [-Werror=cast-align]
> lib/sdp.c:1026:27: error: cast increases required alignment
> 	of target type [-Werror=cast-align]
> 
> Change-Id: I587fb99328d7e5b9053af81597bd48b3a4e610ad
> ---
>  lib/sdp.c |   56 ++++++++++++++++++++++++++++----------------------------
>  1 file changed, 28 insertions(+), 28 deletions(-)
> 
> diff --git a/lib/sdp.c b/lib/sdp.c
> index 36b4d08..d40500f 100644
> --- a/lib/sdp.c
> +++ b/lib/sdp.c
> @@ -376,27 +376,27 @@ sdp_data_t *sdp_data_alloc_with_length(uint8_t dtd, const void *value,
>  		d->unitSize += sizeof(int8_t);
>  		break;
>  	case SDP_UINT16:
> -		d->val.uint16 = bt_get_unaligned((uint16_t *) value);
> +		d->val.uint16 = bt_get_16(value);
>  		d->unitSize += sizeof(uint16_t);
>  		break;

I do not like this. Either we use be16 here and store it in the native
endian converted from the protocol endian or we leave it as it is.

I want clear get_le16 and get_be16 and not another get_16. That just
makes the code hard to read.

Regards

Marcel



  parent reply	other threads:[~2012-08-31 16:14 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-08-31  8:36 [RFC 00/15] Unaligned memory access fixes Szymon Janc
2012-08-31  8:36 ` [RFC 01/15] lib: Add host order unaligned access functions Szymon Janc
2012-08-31  8:36 ` [RFC 02/15] sap-u8500: Fix compile error due to unaligned memory access Szymon Janc
2012-08-31  8:36 ` [RFC 03/15] sdp: Use helper functions instead of bt_get_unaligned macro Szymon Janc
2012-08-31 10:55   ` Anderson Lizardo
2012-08-31 11:49     ` Szymon Janc
2012-08-31 12:12       ` Anderson Lizardo
2012-08-31 16:14   ` Marcel Holtmann [this message]
2012-09-03  7:06     ` Szymon Janc
2012-09-03  9:57       ` Johan Hedberg
2012-09-03 10:28         ` Szymon Janc
2012-08-31  8:36 ` [RFC 04/15] Add helper functions for putting integers on unaligned memory address Szymon Janc
2012-08-31  8:36 ` [RFC 05/15] sdp: Fix compilation errors due to unaligned memory access Szymon Janc
2012-08-31  8:36 ` [RFC 06/15] l2test: " Szymon Janc
2012-08-31  8:36 ` [RFC 07/15] rctest: " Szymon Janc
2012-08-31  8:36 ` [RFC 08/15] monitor: " Szymon Janc
2012-08-31  8:36 ` [RFC 09/15] scotest: " Szymon Janc
2012-08-31  8:36 ` [RFC 10/15] avrcp: " Szymon Janc
2012-08-31  8:36 ` [RFC 11/15] sap: " Szymon Janc
2012-08-31  8:36 ` [RFC 12/15] adaptername: Refactor handle_inotify_cb Szymon Janc
2012-08-31  8:36 ` [RFC 13/15] sdpd-request: Fix build errors due to unaligned memory access Szymon Janc
2012-08-31  8:36 ` [RFC 14/15] sdpd-service: " Szymon Janc
2012-08-31  8:36 ` [RFC 15/15] hciemu: " Szymon Janc

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1346429676.23377.22.camel@aeonflux \
    --to=marcel@holtmann.org \
    --cc=linux-bluetooth@vger.kernel.org \
    --cc=szymon.janc@tieto.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox