From: Marcel Holtmann <marcel@holtmann.org>
To: Chan-yeol Park <chanyeol.park@gmail.com>
Cc: Luiz Augusto von Dentz <luiz.dentz@gmail.com>,
chanyeol.park@samsung.com, linux-bluetooth@vger.kernel.org
Subject: Re: [PATCH 4/4] audio: Add check for non-a2dp codec
Date: Fri, 05 Oct 2012 10:41:17 +0200 [thread overview]
Message-ID: <1349426477.27233.44.camel@aeonflux> (raw)
In-Reply-To: <506E8AA5.7090709@gmail.com>
Hi Chan-yeol,
> > #define SBC_SAMPLING_FREQ_16000 (1 << 3)
> > #define SBC_SAMPLING_FREQ_32000 (1 << 2)
> > @@ -114,3 +115,8 @@ typedef struct {
> > #else
> > #error "Unknown byte order"
> > #endif
> > +
> > +typedef struct {
> > + uint8_t vendor_id[4];
> > + uint8_t codec_id[2];
> > +} __attribute__ ((packed)) non_a2dp_vendor_codec_t;
> > We normally don't typedef this type of structs, besides
> > a2dp_vendor_codec should be enough so this should be named struct
> > a2dp_vendor_codec.
> You're right. originally I didn't use typedef.
> but in order to achieve harmony in a2dp-codecs.h like sbc,mpeg, I've
> changed it.
>
> If you make decision about this, I will raise a second patch.
hold on for a second, is this the file that is shared with PulseAudio?
Regards
Marcel
next prev parent reply other threads:[~2012-10-05 8:41 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-10-04 13:14 [PATCH 4/4] audio: Add check for non-a2dp codec chanyeol.park
2012-10-04 13:14 ` [PATCH 3/4] audio: Remove redundant procedure when a2dp connect chanyeol.park
2012-10-04 14:11 ` Luiz Augusto von Dentz
2012-10-04 13:14 ` [PATCH 2/4] audio: Remove unused function chanyeol.park
2012-10-04 13:14 ` [PATCH 1/4] mgmt: Add string for Passkey Notify Event chanyeol.park
2012-10-04 15:05 ` Johan Hedberg
2012-10-04 14:02 ` [PATCH 4/4] audio: Add check for non-a2dp codec Luiz Augusto von Dentz
2012-10-04 18:08 ` Marcel Holtmann
2012-10-04 20:22 ` Luiz Augusto von Dentz
2012-10-04 20:30 ` Marcel Holtmann
2012-10-05 2:37 ` Chan-yeol Park
2012-10-05 7:22 ` Chan-yeol Park
2012-10-05 8:41 ` Marcel Holtmann [this message]
2012-10-05 8:57 ` Chan-yeol Park
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1349426477.27233.44.camel@aeonflux \
--to=marcel@holtmann.org \
--cc=chanyeol.park@gmail.com \
--cc=chanyeol.park@samsung.com \
--cc=linux-bluetooth@vger.kernel.org \
--cc=luiz.dentz@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox