From: Marcel Holtmann <marcel@holtmann.org>
To: Andrei Emeltchenko <Andrei.Emeltchenko.news@gmail.com>
Cc: linux-bluetooth@vger.kernel.org
Subject: Re: [RFCv1 3/6] Bluetooth: AMP: Add handle to hci_chan structure
Date: Wed, 10 Oct 2012 12:07:56 +0200 [thread overview]
Message-ID: <1349863676.27233.120.camel@aeonflux> (raw)
In-Reply-To: <20121010083438.GB7620@aemeltch-MOBL1>
Hi Andrei,
> > > -
> > > +struct hci_chan *hci_chan_lookup_handle(struct hci_conn *hcon, __u16 handle);
> > > +struct hci_chan *hci_chan_lookup_handle_all(struct hci_dev *hdev,
> > > + __u16 handle);
> >
> > this naming is pretty bad. I have no idea what one function does
> > different compared to the other. Especially since none of them take a
> > hci_chan as argument, but start with that prefix.
> >
> > Would be the naming hci_conn_lookup_chan be a lot clearer? Or maybe
> > hci_chan_lookup_from_dev or similar.
>
> So are names like:
>
> hci_conn_lookup_hchan_by_handle
since this one is only internal, you better have a shortcut version as
just a static helper inside that code.
> hci_conn_lookup_hchan_from_hdev
If we follow our naming convention then hci_chan_lookup_from_dev would
come closest. However since you only need one of these, then
hci_chan_lookup_handle would be fine and in sync with how we named
everything else.
I rather not have the prefixing h everywhere that we use in variable
names. That should be really only for variable names.
Regards
Marcel
next prev parent reply other threads:[~2012-10-10 10:07 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-10-08 14:52 [RFCv1 0/6] Handle AMP_LINK Andrei Emeltchenko
2012-10-08 14:52 ` [RFCv1 1/6] Bluetooth: Allow to set flush timeout Andrei Emeltchenko
2012-10-08 14:52 ` [RFCv1 2/6] Bluetooth: AMP: Handle AMP_LINK timeout Andrei Emeltchenko
2012-10-09 14:39 ` Marcel Holtmann
2012-10-08 14:52 ` [RFCv1 3/6] Bluetooth: AMP: Add handle to hci_chan structure Andrei Emeltchenko
2012-10-09 14:46 ` Marcel Holtmann
2012-10-10 8:34 ` Andrei Emeltchenko
2012-10-10 10:07 ` Marcel Holtmann [this message]
2012-10-10 10:12 ` Andrei Emeltchenko
2012-10-08 14:52 ` [RFCv1 4/6] Bluetooth: Handle number of compl blocks for AMP_LINK Andrei Emeltchenko
2012-10-09 14:49 ` Marcel Holtmann
2012-10-10 8:22 ` Andrei Emeltchenko
2012-10-08 14:52 ` [RFCv1 5/6] Bluetooth: AMP: Handle AMP_LINK connection Andrei Emeltchenko
2012-10-08 14:52 ` [RFCv1 6/6] Bluetooth: AMP: Hanlde AMP_LINK case in conn_put Andrei Emeltchenko
2012-10-10 14:38 ` [PATCHv1 0/6] Handle AMP_LINK Andrei Emeltchenko
2012-10-10 14:38 ` [PATCHv1 1/6] Bluetooth: Allow to set flush timeout Andrei Emeltchenko
2012-10-10 14:38 ` [PATCHv1 2/6] Bluetooth: AMP: Handle AMP_LINK timeout Andrei Emeltchenko
2012-10-10 14:38 ` [PATCHv1 3/6] Bluetooth: AMP: Add handle to hci_chan structure Andrei Emeltchenko
2012-10-10 14:38 ` [PATCHv1 4/6] Bluetooth: AMP: Handle number of compl blocks for AMP_LINK Andrei Emeltchenko
2012-10-10 14:38 ` [PATCHv1 5/6] Bluetooth: AMP: Handle AMP_LINK connection Andrei Emeltchenko
2012-10-10 14:38 ` [PATCHv1 6/6] Bluetooth: AMP: Hanlde AMP_LINK case in conn_put Andrei Emeltchenko
2012-10-11 6:36 ` Gustavo Padovan
2012-10-10 15:28 ` [PATCHv1 0/6] Handle AMP_LINK Marcel Holtmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1349863676.27233.120.camel@aeonflux \
--to=marcel@holtmann.org \
--cc=Andrei.Emeltchenko.news@gmail.com \
--cc=linux-bluetooth@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox