From: Szymon Janc <szymon.janc@gmail.com>
To: linux-bluetooth@vger.kernel.org
Cc: Szymon Janc <szymon.janc@gmail.com>
Subject: [PATCH 00/13] sixaxis support
Date: Mon, 25 Nov 2013 22:15:39 +0000 [thread overview]
Message-ID: <1385417752-25664-1-git-send-email-szymon.janc@gmail.com> (raw)
Hi All,
This is yet another attempt to get PS3 controller support into BlueZ upstream.
I based my work on Fedora out-of-tree patch (hence copyright info) and tried
to take into consideration comments from previous upstreaming attempt.
I find sixaxis name short and neat so I sticked with it.
I didn't really like the idea of hardcoding SDP records so I took different
approach of doing reverse SDP search while cable associated device first
connects. This is done before authorizing incoming HID connection.
Some functions unavailable to exteral plugins were renamed with btd_ prefix
(or explicitly marked in bletooth.ver) to export them (patch 1-8).
Patch 9-10 add sixaxis external plugin that depends on udev. This plugin is
responsible for preparing newly USB connected PS3 sixaxis device and creating
btd_device with proper PNP information.
Patch 12 adds support for handling first connection of sixaxis device in input
plugin itself. This is something I would like to get comments and suggestions.
Currently this is rather sixaxis oriented, but could be made more generic (some
hooks registration) if desired.
This serie is not implemententing any LED (or other features) setting support.
I have an impression that those should not be handled by BlueZ but some other
entity (util tools or driver itself perhabs?) as this is not related to
transport itself and should be set/used on USB connection as well.
This was tested with Dualshock3 and seems to be working nicely here.
Comments are welcome.
--
BR
Szymon Janc
Szymon Janc (13):
core: Export some symbols from libbluetooth
Rename adapter_get_device to btd_adapter_get_device
Rename device_set_temporary to btd_device_set_temporary
Rename device_set_trusted to btd_device_set_trusted
Rename device_device_set_name to btd_device_device_set_name
Rename device_get_uuids to btd_device_get_uuids
Rename adapter_get_address to btd_adapter_get_address
Rename adapter_find_device to btd_adapter_find_device
plugins: Add initial code for sixaxis plugin
plugins/sixaxis: Add initial code for udev handling
plugins/sixaxis: Add support for configuring new controllers
device: Add device_discover_services function
input: Add support for handling sixaxis devices
Makefile.plugins | 8 ++
bootstrap-configure | 1 +
configure.ac | 5 +
plugins/neard.c | 10 +-
plugins/sixaxis.c | 286 ++++++++++++++++++++++++++++++++++++++++++
plugins/wiimote.c | 2 +-
profiles/audio/avctp.c | 18 +--
profiles/audio/avdtp.c | 11 +-
profiles/health/hdp.c | 10 +-
profiles/health/hdp_util.c | 6 +-
profiles/input/device.c | 4 +-
profiles/input/manager.c | 4 +-
profiles/input/server.c | 104 ++++++++++++++-
profiles/network/connection.c | 2 +-
profiles/network/server.c | 4 +-
profiles/sap/server.c | 3 +-
src/adapter.c | 74 ++++++-----
src/adapter.h | 6 +-
src/attrib-server.c | 6 +-
src/bluetooth.ver | 2 +
src/device.c | 70 +++++++----
src/device.h | 10 +-
src/profile.c | 14 +--
23 files changed, 551 insertions(+), 109 deletions(-)
create mode 100644 plugins/sixaxis.c
--
1.8.4.4
next reply other threads:[~2013-11-25 22:15 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-11-25 22:15 Szymon Janc [this message]
2013-11-25 22:12 ` [PATCH 00/13] sixaxis support Antonio Ospite
2013-11-25 22:15 ` [PATCH 01/13] core: Export some symbols from libbluetooth Szymon Janc
2013-11-25 22:15 ` [PATCH 02/13] Rename adapter_get_device to btd_adapter_get_device Szymon Janc
2013-11-25 22:15 ` [PATCH 03/13] Rename device_set_temporary to btd_device_set_temporary Szymon Janc
2013-11-25 22:15 ` [PATCH 04/13] Rename device_set_trusted to btd_device_set_trusted Szymon Janc
2013-11-25 22:15 ` [PATCH 05/13] Rename device_device_set_name to btd_device_device_set_name Szymon Janc
2013-11-25 22:15 ` [PATCH 06/13] Rename device_get_uuids to btd_device_get_uuids Szymon Janc
2013-11-25 22:15 ` [PATCH 07/13] Rename adapter_get_address to btd_adapter_get_address Szymon Janc
2013-11-25 22:15 ` [PATCH 08/13] Rename adapter_find_device to btd_adapter_find_device Szymon Janc
2013-11-25 22:15 ` [PATCH 09/13] plugins: Add initial code for sixaxis plugin Szymon Janc
2013-11-25 22:15 ` [PATCH 10/13] plugins/sixaxis: Add initial code for udev handling Szymon Janc
2013-11-25 22:15 ` [PATCH 11/13] plugins/sixaxis: Add support for configuring new controllers Szymon Janc
2013-11-25 22:15 ` [PATCH 12/13] device: Add device_discover_services function Szymon Janc
2013-11-25 22:15 ` [PATCH 13/13] input: Add support for handling sixaxis devices Szymon Janc
2013-11-27 9:34 ` [PATCH 00/13] sixaxis support Johan Hedberg
2013-11-27 10:01 ` Bastien Nocera
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1385417752-25664-1-git-send-email-szymon.janc@gmail.com \
--to=szymon.janc@gmail.com \
--cc=linux-bluetooth@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox