Linux bluetooth development
 help / color / mirror / Atom feed
From: Szymon Janc <szymon.janc@tieto.com>
To: Johan Hedberg <johan.hedberg@gmail.com>
Cc: "linux-bluetooth@vger.kernel.org" <linux-bluetooth@vger.kernel.org>
Subject: Re: [PATCH] adapter: Fix compilation on some architectures
Date: Wed, 5 Dec 2012 12:06:37 +0100	[thread overview]
Message-ID: <1564894.mIcBMGi0ah@uw000953> (raw)
In-Reply-To: <20121205102958.GA1650@x220.ger.corp.intel.com>

On Wednesday 05 of December 2012 12:29:58 Johan Hedberg wrote:
> Hi Szymon,

Hi Johan,
> 
> On Wed, Dec 05, 2012, Szymon Janc wrote:
> > plain char may be treated as signed or unsigned depending on compiler
> > (as oposite to other integer types). Use signed char explicitly when
> > signed type is needed.
> > 
> > This fix following compilation error on ARM:
> > 
> >   CC     src/bluetoothd-adapter.o
> > src/adapter.c: In function ‘convert_entry’:
> > src/adapter.c:2710:2: error: comparison is always true due to limited
> > 	range of data type [-Werror=type-limits]
> > cc1: all warnings being treated as errors
> > make[1]: *** [src/bluetoothd-adapter.o] Error 1
> > ---
> >  src/adapter.c |    2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/src/adapter.c b/src/adapter.c
> > index 3c5d277..0cbce78 100644
> > --- a/src/adapter.c
> > +++ b/src/adapter.c
> > @@ -2673,7 +2673,7 @@ static void convert_ltk_entry(GKeyFile *key_file, void *value)
> >  static void convert_entry(char *key, char *value, void *user_data)
> >  {
> >  	struct device_converter *converter = user_data;
> > -	char device_type = -1;
> > +	signed char device_type = -1;
> >  	char filename[PATH_MAX + 1];
> >  	GKeyFile *key_file;
> >  	char *data;
> 
> Couldn't we just initialize the value to BDADDR_BREDR or maybe use an
> int for it. And the naming is confusing as the value contains an address
> type and not a device type.

Initializing it to BDADDR_BREDR wouldn't fix compilation as problem is in
comparing >=0 when type is unsigned (and would change function flow as now
device_set_type is called only if device_type is >=0)...  I'm not sure what
was decided about storage changes so didn't wanted to fiddle with that.

I agree that name is a bit confusing but I guess this is just a consequence
of set_device_type() function name.

So, if it is OK to always fall back to BDADDR_BREDR I can resent V2 with that
change, else I can sent V2 with use of int if you prefer it over signed char.

-- 
BR
Szymon Janc

  reply	other threads:[~2012-12-05 11:06 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-12-05 10:02 [PATCH] adapter: Fix compilation on some architectures Szymon Janc
2012-12-05 10:29 ` Johan Hedberg
2012-12-05 11:06   ` Szymon Janc [this message]
2012-12-05 11:14     ` Johan Hedberg
2012-12-05 12:32       ` [PATCH] adapter: Always write address type when converting to new storage Szymon Janc
2012-12-05 14:28         ` Johan Hedberg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1564894.mIcBMGi0ah@uw000953 \
    --to=szymon.janc@tieto.com \
    --cc=johan.hedberg@gmail.com \
    --cc=linux-bluetooth@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox