From: patchwork-bot+bluetooth@kernel.org
To: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
Cc: marcel@holtmann.org, luiz.dentz@gmail.com, brgl@kernel.org,
linux-bluetooth@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-arm-msm@vger.kernel.org
Subject: Re: [PATCH 0/2] Bluetooth: use named initializers for acpi_device_id
Date: Mon, 27 Jul 2026 20:50:06 +0000 [thread overview]
Message-ID: <178518540639.1412337.3111585831256595939.git-patchwork-notify@kernel.org> (raw)
In-Reply-To: <20260727-acpi-bluetooth-v1-0-b5558d53e6e7@thegoodpenguin.co.uk>
Hello:
This series was applied to bluetooth/bluetooth-next.git (master)
by Luiz Augusto von Dentz <luiz.von.dentz@intel.com>:
On Mon, 27 Jul 2026 16:51:50 +0100 you wrote:
> This series is converting lists that contain the acpi_device_id
> struct, which is defined in the include/linux/device-id/acpi.h
> to makes use of named initializers (which they do not use currently).
> This work is part of the on going effort in the kernel associated
> with device-ids [1]
>
> The plan is to convert acpi_device_id::driver_data to have an anonymous
> union, similarly to what was introduced for PCI and I2C device ID tables.
> The goal is to increase type-safety (as most of the existing casts are gone),
> to improve readability and to make use intent a bit more clear:
>
> [...]
Here is the summary with links:
- [1/2] Bluetooth: use a named initializer for acpi_device_id
https://git.kernel.org/bluetooth/bluetooth-next/c/cca1639df8fb
- [2/2] Bluetooth: hci_intel: drop unused assignment of acpi_device_id::driver_data
https://git.kernel.org/bluetooth/bluetooth-next/c/1bbd8346bc3c
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
prev parent reply other threads:[~2026-07-27 20:50 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-27 15:51 [PATCH 0/2] Bluetooth: use named initializers for acpi_device_id Pawel Zalewski (The Capable Hub)
2026-07-27 15:51 ` [PATCH 1/2] Bluetooth: use a named initializer " Pawel Zalewski (The Capable Hub)
2026-07-27 16:57 ` Bluetooth: use named initializers " bluez.test.bot
2026-07-27 15:51 ` [PATCH 2/2] Bluetooth: hci_intel: drop unused assignment of acpi_device_id::driver_data Pawel Zalewski (The Capable Hub)
2026-07-27 20:50 ` patchwork-bot+bluetooth [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=178518540639.1412337.3111585831256595939.git-patchwork-notify@kernel.org \
--to=patchwork-bot+bluetooth@kernel.org \
--cc=brgl@kernel.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-bluetooth@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=luiz.dentz@gmail.com \
--cc=marcel@holtmann.org \
--cc=pzalewski@thegoodpenguin.co.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox