From: Johan Hedberg <johan.hedberg@gmail.com>
To: "Rafał Michalski" <michalski.raf@gmail.com>
Cc: linux-bluetooth@vger.kernel.org
Subject: Re: [PATCH 2/2] Add handling for more than one address in vCard
Date: Wed, 1 Sep 2010 13:48:38 +0300 [thread overview]
Message-ID: <20100901104838.GA11813@jh-x301> (raw)
In-Reply-To: <AANLkTikGen9zKWdi=J558PXOBKhreu=WJ9_KCrQ=n_sx@mail.gmail.com>
Hi Rafal,
On Wed, Sep 01, 2010, Rafał Michalski wrote:
> +static struct phonebook_address *find_address(GSList *addresses,
> + const char *address, int type)
> +{
> + GSList *l = addresses;
> +
> + for (; l; l = l->next) {
Please avoid initialization upon declaration of variables when possible.
The first part of the for-statement is where you should usually
initialize the iterator, i.e. in this case do the l = addresses there.
> +static gboolean address_fields_present(const char *address)
> +{
> + gchar **address_fields = g_strsplit(address, ";",
> + ADDR_FIELD_AMOUNT);
> + int i = 0;
> +
> + for (; i < ADDR_FIELD_AMOUNT; ++i) {
Same here for i. Additionally you could rename address_fields to simply
fields since the function is short and the context pretty obvious.
You'll also avoid the split line that way (another thing I wouldn't
object to is to move the initialization separate from the variable
declaration).
> -static gboolean address_fields_present(struct phonebook_contact *contact)
> +static gboolean address_fields_present(const char *address)
> {
> - gchar **address_fields = g_strsplit(contact->address, ";",
> + gchar **address_fields = g_strsplit(address, ";",
> ADDR_FIELD_AMOUNT);
> int i = 0;
Hmm, it seems you have the same function in vcard.c and
phonebook-tracker.c? Why not remove the phonebook-tracker.c one and
export the vcard.c version through vcard.h?
Johan
prev parent reply other threads:[~2010-09-01 10:48 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-09-01 10:23 [PATCH 2/2] Add handling for more than one address in vCard Rafał Michalski
2010-09-01 10:48 ` Johan Hedberg [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20100901104838.GA11813@jh-x301 \
--to=johan.hedberg@gmail.com \
--cc=linux-bluetooth@vger.kernel.org \
--cc=michalski.raf@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox