Linux Btrfs filesystem development
 help / color / mirror / Atom feed
From: Gui Hecheng <guihc.fnst@cn.fujitsu.com>
To: Satoru Takeuchi <takeuchi_satoru@jp.fujitsu.com>
Cc: "linux-btrfs@vger.kernel.org" <linux-btrfs@vger.kernel.org>
Subject: Re: [PATCH 1/2] Remove unnecessary placeholder in btrfs_err_code
Date: Tue, 23 Dec 2014 09:59:31 +0800	[thread overview]
Message-ID: <1419299971.2086.8.camel@localhost.localdomain> (raw)
In-Reply-To: <5497F4CD.4010301@jp.fujitsu.com>

On Mon, 2014-12-22 at 19:39 +0900, Satoru Takeuchi wrote:
> Sorry, I forgot to add Signed-off-by line.
> 
> ---
> From: Satoru Takeuchi <takeuchi_satoru@jp.fujitsu.com>
> 
> "notused" is not necessary. Set 1 to the first entry is enough.

Hi Satoru,

Actually, the struct is copied from the kernel header
include/uapi/linux/btrfs.h.
I think they should stay the same, so either change the kernel header
in another path, or just keep them in old style.

Thanks,
Gui 

> Signed-off-by: Satoru Takeuchi <takeuchi_satoru@jp.fujitsu.com>
> 
> ---
>  ioctl.h | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/ioctl.h b/ioctl.h
> index 2c2c7c1..c377b96 100644
> --- a/ioctl.h
> +++ b/ioctl.h
> @@ -474,8 +474,7 @@ struct btrfs_ioctl_qgroup_create_args {
>  
>  /* Error codes as returned by the kernel */
>  enum btrfs_err_code {
> -	notused,
> -	BTRFS_ERROR_DEV_RAID1_MIN_NOT_MET,
> +	BTRFS_ERROR_DEV_RAID1_MIN_NOT_MET = 1,
>  	BTRFS_ERROR_DEV_RAID10_MIN_NOT_MET,
>  	BTRFS_ERROR_DEV_RAID5_MIN_NOT_MET,
>  	BTRFS_ERROR_DEV_RAID6_MIN_NOT_MET,
> -- 1.8.3.1 -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html 
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html



  reply	other threads:[~2014-12-23  2:01 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-12-22 10:31 [PATCH 1/2] Remove unnecessary placeholder in btrfs_err_code Satoru Takeuchi
2014-12-22 10:37 ` [PATCH 2/2] Capitalize elements in enum for improve readability Satoru Takeuchi
2014-12-29 16:50   ` David Sterba
2014-12-22 10:39 ` [PATCH 1/2] Remove unnecessary placeholder in btrfs_err_code Satoru Takeuchi
2014-12-23  1:59   ` Gui Hecheng [this message]
2014-12-24  5:12     ` Satoru Takeuchi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1419299971.2086.8.camel@localhost.localdomain \
    --to=guihc.fnst@cn.fujitsu.com \
    --cc=linux-btrfs@vger.kernel.org \
    --cc=takeuchi_satoru@jp.fujitsu.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox