From: Qu Wenruo <quwenruo.btrfs@gmx.com>
To: Nikolay Borisov <nborisov@suse.com>, Qu Wenruo <wqu@suse.com>,
linux-btrfs@vger.kernel.org
Subject: Re: [PATCH v2] btrfs: replace BUG_ON() in btrfs_csum_one_bio() with proper error handling
Date: Tue, 17 Aug 2021 16:10:43 +0800 [thread overview]
Message-ID: <ac42cd2a-82dd-1987-4e18-e9d27e127172@gmx.com> (raw)
In-Reply-To: <8babcc1b-2456-8632-7b56-f9867d333a0d@suse.com>
On 2021/8/17 下午3:55, Nikolay Borisov wrote:
>
>
> On 17.08.21 г. 2:55, Qu Wenruo wrote:
>> There is a BUG_ON() in btrfs_csum_one_bio() to catch code logic error.
>>
>> It has indeed caught several bugs during subpage development.
>>
>> But the BUG_ON() itself will bring down the whole system which is
>> sometimes overkilled.
>>
>> Replace it with a WARN() and exit gracefully, so that it won't crash the
>> whole system while we can still catch the code logic error.
>>
>> Signed-off-by: Qu Wenruo <wqu@suse.com>
>> ---
>> Changelog:
>> v2:
>> - Re-send as an independent patch
>> - Add WARN() to catch the code logic error
>> ---
>> fs/btrfs/file-item.c | 13 ++++++++++++-
>> 1 file changed, 12 insertions(+), 1 deletion(-)
>>
>> diff --git a/fs/btrfs/file-item.c b/fs/btrfs/file-item.c
>> index 2673c6ba7a4e..7f58d80a480f 100644
>> --- a/fs/btrfs/file-item.c
>> +++ b/fs/btrfs/file-item.c
>> @@ -665,7 +665,18 @@ blk_status_t btrfs_csum_one_bio(struct btrfs_inode *inode, struct bio *bio,
>>
>> if (!ordered) {
>> ordered = btrfs_lookup_ordered_extent(inode, offset);
>> - BUG_ON(!ordered); /* Logic error */
>> + /*
>> + * The bio range is not covered by any ordered extent,
>> + * must be a code logic error.
>> + */
>> + if (unlikely(!ordered)) {
>> + WARN(1, KERN_WARNING
>> + "no ordered extent for root %llu ino %llu offset %llu\n",
>> + inode->root->root_key.objectid,
>> + btrfs_ino(inode), offset);
>> + kvfree(sums);
>> + return BLK_STS_IOERR;
>> + }
>
> nit: How about :
>
> if (WARN_ON(!ordered) {
I still remember that if (WARN_ON()) usage is not recommended by David.
Is that still the case?
> btrfs_err(foo)
> }
>
> That way you get the unlikely(!ordered) 'for free' and the code is
> somewhat cleaner IMO.
>
> While at it I also have to say the structure of the inner loop is rather
> iffy, because it's really if/else with an implicit 'else'. How about
> converting it to https://paste.ubuntu.com/p/kyWsRrkzWq/
I have no obvious preference between the existing one and the new one.
But since you mentioned it, I would prefer a third way, exactly the code
of the existing if () branch into a function, like
switch_ordered_extent(), and add a comment before the if () line.
To me, that would look easier to read.
Thanks,
Qu
>
>> }
>>
>> nr_sectors = BTRFS_BYTES_TO_BLKS(fs_info,
>>
next prev parent reply other threads:[~2021-08-17 8:10 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-08-16 23:55 [PATCH v2] btrfs: replace BUG_ON() in btrfs_csum_one_bio() with proper error handling Qu Wenruo
2021-08-17 7:55 ` Nikolay Borisov
2021-08-17 8:03 ` Nikolay Borisov
2021-08-17 8:10 ` Qu Wenruo [this message]
2021-08-18 23:00 ` David Sterba
2021-08-19 1:08 ` Qu Wenruo
2021-08-19 12:23 ` David Sterba
2021-08-19 12:34 ` Qu Wenruo
2021-09-07 14:13 ` David Sterba
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ac42cd2a-82dd-1987-4e18-e9d27e127172@gmx.com \
--to=quwenruo.btrfs@gmx.com \
--cc=linux-btrfs@vger.kernel.org \
--cc=nborisov@suse.com \
--cc=wqu@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox