From mboxrd@z Thu Jan 1 00:00:00 1970 From: Michal Hocko Subject: Re: [PATCH 2/2] fs: Don't open-code lru_to_page Date: Thu, 29 Nov 2018 10:04:50 +0100 Message-ID: <20181129090450.GR6923@dhcp22.suse.cz> References: <20181129075301.29087-1-nborisov@suse.com> <20181129075301.29087-2-nborisov@suse.com> <20181129081826.GO6923@dhcp22.suse.cz> <0921bc8f-b899-4925-51f2-a9f45d4c906a@suse.com> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 8bit Cc: linux-kernel@vger.kernel.org, David Howells , Chris Mason , Josef Bacik , David Sterba , "Yan, Zheng" , Sage Weil , Ilya Dryomov , Steve French , Theodore Ts'o , Andreas Dilger , Mark Fasheh , Joel Becker , Mike Marshall , Martin Brandenburg , Andrew Morton , Mike Rapoport , Matthew Wilcox , Randy Dunlap , YueHaibing , Shakeel Butt , Dan Willia To: Nikolay Borisov Return-path: Content-Disposition: inline In-Reply-To: <0921bc8f-b899-4925-51f2-a9f45d4c906a@suse.com> Sender: linux-kernel-owner@vger.kernel.org List-Id: linux-cifs.vger.kernel.org On Thu 29-11-18 10:50:08, Nikolay Borisov wrote: > > > On 29.11.18 г. 10:18 ч., Michal Hocko wrote: > > On Thu 29-11-18 09:52:57, Nikolay Borisov wrote: > >> There are a bunch of filesystems which essentially open-code lru_to_page > >> helper. Change them to using the helper. No functional changes. > > > > I would just squash the two into a single patch. It makes the first one > > more obvious. Or is there any reason to have them separate? > > No reason, just didn't know how people would react so that's why I chose > to send as two separate. This is a matter of taste I guess. But I usually prefer to have callers along with a new helper in a single patch. This is not a new helper per-se but doing it the same way seems reasonable to me. Not that I would insist of course. You can use my ack for both patch in case you decide to leave it as is. > If I squash them who would be the best person to take them ? Sounds like a mmotm material to me. -- Michal Hocko SUSE Labs