From: LABBE Corentin <clabbe.montjoie@gmail.com>
To: herbert@gondor.apana.org.au, davem@davemloft.net
Cc: linux-kernel@vger.kernel.org, linux-crypto@vger.kernel.org
Subject: crypto: Remove duplicate code of SG helpers functions
Date: Thu, 10 Sep 2015 15:21:35 +0200 [thread overview]
Message-ID: <1441891302-12014-1-git-send-email-clabbe.montjoie@gmail.com> (raw)
Hello
This patch series try to remove some duplicate code of some SG helpers functions.
The first three patch replace custom functions by already in-tree helper functions.
The fourth add a new functions "sg_nents_for_len2" who is the same as
sg_nents_for_len with an additionnal arguments.
Note that I do not like the name, but I do not find any good name.
The last three patch use sg_nents_for_len2 for removing custom functions.
I send those patch as RFC since I do not own any of those hardware to test.
Regards
next reply other threads:[~2015-09-10 13:21 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-09-10 13:21 LABBE Corentin [this message]
2015-09-10 13:21 ` [PATCH 1/7] crypto: bfin: replace sg_count by sg_nents LABBE Corentin
2015-09-10 13:21 ` [PATCH 2/7] crypto: amcc replace get_sg_count by sg_nents_for_len LABBE Corentin
2015-09-10 13:21 ` [PATCH 3/7] crypto: sahara replace sahara_sg_length with sg_nents_for_len LABBE Corentin
2015-09-10 13:21 ` [PATCH 4/7] lib: introduce sg_nents_for_len2 LABBE Corentin
2015-09-18 11:53 ` Herbert Xu
2015-09-18 12:20 ` LABBE Corentin
2015-09-18 12:22 ` Herbert Xu
2015-09-18 12:42 ` LABBE Corentin
2015-09-18 12:43 ` Herbert Xu
2015-09-10 13:21 ` [PATCH 5/7] crypto: talitos replace sg_count with sg_nents_for_len2 LABBE Corentin
2015-09-10 13:21 ` [PATCH 6/7] crypto: qce replace qce_countsg " LABBE Corentin
2015-09-10 13:21 ` [PATCH 7/7] crypto: caam replace __sg_count " LABBE Corentin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1441891302-12014-1-git-send-email-clabbe.montjoie@gmail.com \
--to=clabbe.montjoie@gmail.com \
--cc=davem@davemloft.net \
--cc=herbert@gondor.apana.org.au \
--cc=linux-crypto@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox