From: Dan Carpenter <dan.carpenter@oracle.com>
To: Gilad Ben-Yossef <gilad@benyossef.com>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org,
driverdev-devel@linuxdriverproject.org,
linux-crypto@vger.kernel.org, Ofir Drang <ofir.drang@arm.com>
Subject: Re: [PATCH 2/3] staging: ccree: handle limiting of DMA masks
Date: Wed, 1 Nov 2017 14:09:18 +0300 [thread overview]
Message-ID: <20171101110918.f6ra2otu22jndjcc@mwanda> (raw)
In-Reply-To: <1509450978-17784-3-git-send-email-gilad@benyossef.com>
On Tue, Oct 31, 2017 at 11:56:16AM +0000, Gilad Ben-Yossef wrote:
>
> - if (!dev->coherent_dma_mask)
> - dev->coherent_dma_mask = DMA_BIT_MASK(DMA_BIT_MASK_LEN);
> + if (rc) {
> + dev_err(dev, "Error: failed in dma_set_mask, mask=%par\n",
> + &dma_mask);
> + goto post_drvdata_err;
Also this is not the right goto. We should be turning the clk off.
I don't really care for the naming scheme, and I know you renamed it for
me already once and I feel bad for not liking it more. It's still
really a come-from label name and doesn't say what the goto does...
Instead of post_clk_err, I wish it had names like "err_clk_off:".
And in this case what it does is print a duplicative error message and
return. :/ The goto post_drvdata_err: lines should just print their
own error messages if needed and return directly. If there is no
cleanup then there is no need for a goto.
Anyway, that's not related to this patch. Just resend it with
goto post_clk_err: in the v2.
regards,
dan carpenter
next prev parent reply other threads:[~2017-11-01 11:09 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-10-31 11:56 [PATCH 0/3] staging: ccree: Fixes and cleanups Gilad Ben-Yossef
2017-10-31 11:56 ` [PATCH 1/3] staging: ccree: copy IV to DMAable memory Gilad Ben-Yossef
2017-11-01 10:58 ` Dan Carpenter
2017-10-31 11:56 ` [PATCH 2/3] staging: ccree: handle limiting of DMA masks Gilad Ben-Yossef
2017-11-01 10:59 ` Dan Carpenter
2017-11-01 11:09 ` Dan Carpenter [this message]
2017-11-02 7:28 ` Gilad Ben-Yossef
2017-10-31 11:56 ` [PATCH 3/3] staging: ccree: remove dead code Gilad Ben-Yossef
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171101110918.f6ra2otu22jndjcc@mwanda \
--to=dan.carpenter@oracle.com \
--cc=devel@driverdev.osuosl.org \
--cc=driverdev-devel@linuxdriverproject.org \
--cc=gilad@benyossef.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-crypto@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=ofir.drang@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox