Linux cryptographic layer development
 help / color / mirror / Atom feed
From: Herbert Xu <herbert@gondor.apana.org.au>
To: Giovanni Cabiddu <giovanni.cabiddu@intel.com>
Cc: linux-crypto@vger.kernel.org, qat-linux@intel.com,
	wangzhi@stu.xidian.edu.cn, byu@xidian.edu.cn,
	w15303746062@163.com, vdronov@redhat.com
Subject: Re: [PATCH v3 0/2] crypto: qat - remove unused ioctl interface
Date: Fri, 22 May 2026 20:27:10 +0800	[thread overview]
Message-ID: <ahBLnsokkkw9Futh@gondor.apana.org.au> (raw)
In-Reply-To: <20260511100854.29474-1-giovanni.cabiddu@intel.com>

On Mon, May 11, 2026 at 11:04:07AM +0100, Giovanni Cabiddu wrote:
> The QAT driver exposes a character device (qat_adf_ctl) with IOCTLs for
> device configuration, start, stop, status query and enumeration. These
> IOCTLs are not part of any public uAPI header and have no known in-tree
> or out-of-tree users.
> 
> This ioctl interface increases the attack surface and is the subject of a
> number of bug reports. Remove it entirely.
> 
> Patch 1 removes the character device, the IOCTL definitions, the related
> data structures and headers. It strips adf_ctl_drv.c down to the
> minimal module_init/module_exit hooks. This is marked for stable.
> 
> Patch 2 renames the now-minimal adf_ctl_drv.c to adf_module.c and
> adjusts function names to match the new file name. This is not marked
> for stable as it is a pure rename.
> 
> Changes since v1:
> - Addressed comments from Sashiko: cleaned up leftover dead code
>   https://sashiko.dev/#/patchset/20260508091912.206913-1-giovanni.cabiddu%40intel.com
> 
> Changes since v2:
> - Removed additional dead code: adf_devmgr_get_dev_by_id(),
>   adf_get_vf_real_id() and a few ADF_CFG unused macros
> 
> Giovanni Cabiddu (2):
>   crypto: qat - remove unused character device and IOCTLs
>   crypto: qat - rename adf_ctl_drv.c to adf_module.c
> 
>  .../userspace-api/ioctl/ioctl-number.rst      |   1 -
>  drivers/crypto/intel/qat/qat_common/Makefile  |   2 +-
>  drivers/crypto/intel/qat/qat_common/adf_cfg.c |  10 -
>  drivers/crypto/intel/qat/qat_common/adf_cfg.h |   1 -
>  .../intel/qat/qat_common/adf_cfg_common.h     |  32 --
>  .../intel/qat/qat_common/adf_cfg_user.h       |  38 --
>  .../intel/qat/qat_common/adf_common_drv.h     |   3 -
>  .../crypto/intel/qat/qat_common/adf_ctl_drv.c | 466 ------------------
>  .../crypto/intel/qat/qat_common/adf_dev_mgr.c |  70 ---
>  .../crypto/intel/qat/qat_common/adf_module.c  |  64 +++
>  10 files changed, 65 insertions(+), 622 deletions(-)
>  delete mode 100644 drivers/crypto/intel/qat/qat_common/adf_cfg_user.h
>  delete mode 100644 drivers/crypto/intel/qat/qat_common/adf_ctl_drv.c
>  create mode 100644 drivers/crypto/intel/qat/qat_common/adf_module.c
> 
> 
> base-commit: f7dd32c5179d7755de18e21d5674b08f9e5cb180
> -- 
> 2.54.0

All applied.  Thanks.
-- 
Email: Herbert Xu <herbert@gondor.apana.org.au>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt

      parent reply	other threads:[~2026-05-22 12:27 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-05-11 10:04 [PATCH v3 0/2] crypto: qat - remove unused ioctl interface Giovanni Cabiddu
2026-05-11 10:04 ` [PATCH v3 1/2] crypto: qat - remove unused character device and IOCTLs Giovanni Cabiddu
2026-05-11 10:04 ` [PATCH v3 2/2] crypto: qat - rename adf_ctl_drv.c to adf_module.c Giovanni Cabiddu
2026-05-22 12:27 ` Herbert Xu [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ahBLnsokkkw9Futh@gondor.apana.org.au \
    --to=herbert@gondor.apana.org.au \
    --cc=byu@xidian.edu.cn \
    --cc=giovanni.cabiddu@intel.com \
    --cc=linux-crypto@vger.kernel.org \
    --cc=qat-linux@intel.com \
    --cc=vdronov@redhat.com \
    --cc=w15303746062@163.com \
    --cc=wangzhi@stu.xidian.edu.cn \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox