From: Thomas Huth <thuth@redhat.com>
To: Rosen Penev <rosenp@gmail.com>
Cc: linux-crypto@vger.kernel.org,
Christian Marangi <ansuelsmth@gmail.com>,
Antoine Tenart <atenart@kernel.org>,
Herbert Xu <herbert@gondor.apana.org.au>,
"David S. Miller" <davem@davemloft.net>,
open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] crypto: eip93 - use struct_size() and flexible array for ring allocation
Date: Tue, 4 Aug 2026 09:47:53 +0200 [thread overview]
Message-ID: <b4d28139-941d-4b36-808d-5c41d370a237@redhat.com> (raw)
In-Reply-To: <CAKxU2N9=qABcpCoQSJ+LeLu0nZj-XBdhetoecwsfRGky+Vgc9w@mail.gmail.com>
On 04/08/2026 09.18, Rosen Penev wrote:
> On Tue, Aug 4, 2026 at 12:11 AM Thomas Huth <thuth@redhat.com> wrote:
>>
>> On 04/08/2026 00.40, Rosen Penev wrote:
>>> Embed the single ring as a flexible array member in eip93_device
>>> instead of allocating it separately. This simplifies the probe path
>>> and uses struct_size() for a single allocation.
>>>
>>> Assisted-by: opencode:big-pickle
>>> Signed-off-by: Rosen Penev <rosenp@gmail.com>
>>> ---
>>> .../crypto/inside-secure/eip93/eip93-main.c | 6 +----
>>> .../crypto/inside-secure/eip93/eip93-main.h | 22 +++++++++----------
>>> 2 files changed, 12 insertions(+), 16 deletions(-)
>>>
>>> diff --git a/drivers/crypto/inside-secure/eip93/eip93-main.c b/drivers/crypto/inside-secure/eip93/eip93-main.c
>>> index 1a8dabc4ada4..e62785952b0d 100644
>>> --- a/drivers/crypto/inside-secure/eip93/eip93-main.c
>>> +++ b/drivers/crypto/inside-secure/eip93/eip93-main.c
>>> @@ -415,7 +415,7 @@ static int eip93_crypto_probe(struct platform_device *pdev)
>>> u32 ver, algo_flags;
>>> int ret;
>>>
>>> - eip93 = devm_kzalloc(dev, sizeof(*eip93), GFP_KERNEL);
>>> + eip93 = devm_kzalloc(dev, struct_size(eip93, ring, 1), GFP_KERNEL);
>>> if (!eip93)
>>> return -ENOMEM;
>>>
>>> @@ -436,10 +436,6 @@ static int eip93_crypto_probe(struct platform_device *pdev)
>>> if (ret)
>>> return ret;
>>>
>>> - eip93->ring = devm_kcalloc(eip93->dev, 1, sizeof(*eip93->ring), GFP_KERNEL);
>>> - if (!eip93->ring)
>>> - return -ENOMEM;
>>> -
>>> ret = eip93_desc_init(eip93);
>>> if (ret)
>>> return ret;
>>> diff --git a/drivers/crypto/inside-secure/eip93/eip93-main.h b/drivers/crypto/inside-secure/eip93/eip93-main.h
>>> index 990c2401b7ce..5f0f51081743 100644
>>> --- a/drivers/crypto/inside-secure/eip93/eip93-main.h
>>> +++ b/drivers/crypto/inside-secure/eip93/eip93-main.h
>>> @@ -92,17 +92,6 @@
>>> EIP93_HASH_SHA224 | \
>>> EIP93_HASH_SHA256))
>>>
>>> -/**
>>> - * struct eip93_device - crypto engine device structure
>>> - */
>>> -struct eip93_device {
>>> - void __iomem *base;
>>> - struct device *dev;
>>> - struct clk *clk;
>>> - int irq;
>>> - struct eip93_ring *ring;
>>> -};
>>> -
>>> struct eip93_desc_ring {
>>> void *base;
>>> void *base_end;
>>> @@ -131,6 +120,17 @@ struct eip93_ring {
>>> struct idr crypto_async_idr;
>>> };
>>>
>>> +/**
>>> + * struct eip93_device - crypto engine device structure
>>> + */
>>> +struct eip93_device {
>>> + void __iomem *base;
>>> + struct device *dev;
>>> + struct clk *clk;
>>> + int irq;
>>> + struct eip93_ring ring[];
>>> +};
>> This looks weird, too. If there is always only one "ring", why don't you
>> embed it without the "[]" into the struct eip93_device directly?
> keeps all callers the same. -> vs .
So it's basically keeping the patch small and generating many WTFs for
future reviewers of the code vs. having a bigger patch now and better
understable code in the future. Not my decision (it's up to the
maintainers), but FWIW I'd rather go with option 2.
Anyway, if you want to keep it short, wouldn't it also be possible to
declare it as ring[1] instead and then keep the sizeof() instead of the
struct_size() ?
Thomas
next prev parent reply other threads:[~2026-08-04 7:48 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-03 22:40 [PATCH] crypto: eip93 - use struct_size() and flexible array for ring allocation Rosen Penev
2026-08-04 7:10 ` Thomas Huth
2026-08-04 7:18 ` Rosen Penev
2026-08-04 7:47 ` Thomas Huth [this message]
2026-08-04 8:47 ` Rosen Penev
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b4d28139-941d-4b36-808d-5c41d370a237@redhat.com \
--to=thuth@redhat.com \
--cc=ansuelsmth@gmail.com \
--cc=atenart@kernel.org \
--cc=davem@davemloft.net \
--cc=herbert@gondor.apana.org.au \
--cc=linux-crypto@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rosenp@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox