From: kernel test robot <lkp@intel.com>
To: Robert Richter <rrichter@amd.com>,
Alison Schofield <alison.schofield@intel.com>,
Vishal Verma <vishal.l.verma@intel.com>,
Ira Weiny <ira.weiny@intel.com>,
Dan Williams <dan.j.williams@intel.com>,
Jonathan Cameron <jonathan.cameron@huawei.com>,
Dave Jiang <dave.jiang@intel.com>,
Davidlohr Bueso <dave@stgolabs.net>
Cc: oe-kbuild-all@lists.linux.dev, linux-cxl@vger.kernel.org,
linux-kernel@vger.kernel.org, Gregory Price <gourry@gourry.net>,
"Fabio M. De Francesco" <fabio.m.de.francesco@linux.intel.com>,
Terry Bowman <terry.bowman@amd.com>,
Joshua Hahn <joshua.hahnjy@gmail.com>,
Robert Richter <rrichter@amd.com>
Subject: Re: [PATCH v8 12/13] cxl: Check if ULLONG_MAX was returned from translation functions
Date: Fri, 12 Dec 2025 03:50:22 +0800 [thread overview]
Message-ID: <202512120346.aT9GKk20-lkp@intel.com> (raw)
In-Reply-To: <20251209180659.208842-13-rrichter@amd.com>
Hi Robert,
kernel test robot noticed the following build warnings:
[auto build test WARNING on ea5514e300568cbe8f19431c3e424d4791db8291]
url: https://github.com/intel-lab-lkp/linux/commits/Robert-Richter/cxl-region-Rename-misleading-variable-name-hpa-to-hpa_range/20251210-021858
base: ea5514e300568cbe8f19431c3e424d4791db8291
patch link: https://lore.kernel.org/r/20251209180659.208842-13-rrichter%40amd.com
patch subject: [PATCH v8 12/13] cxl: Check if ULLONG_MAX was returned from translation functions
config: i386-randconfig-141-20251212 (https://download.01.org/0day-ci/archive/20251212/202512120346.aT9GKk20-lkp@intel.com/config)
compiler: gcc-12 (Debian 12.4.0-5) 12.4.0
reproduce (this is a W=1 build): (https://download.01.org/0day-ci/archive/20251212/202512120346.aT9GKk20-lkp@intel.com/reproduce)
If you fix the issue in a separate patch/commit (i.e. not just a new version of
the same patch/commit), kindly add following tags
| Reported-by: kernel test robot <lkp@intel.com>
| Closes: https://lore.kernel.org/oe-kbuild-all/202512120346.aT9GKk20-lkp@intel.com/
All warnings (new ones prefixed by >>):
In file included from include/linux/limits.h:7,
from include/linux/overflow.h:6,
from include/linux/string.h:13,
from include/linux/seq_file.h:6,
from drivers/cxl/core/hdm.c:3:
drivers/cxl/core/hdm.c: In function 'cxl_dpa_resource_start':
>> include/vdso/limits.h:16:25: warning: conversion from 'long long unsigned int' to 'resource_size_t' {aka 'unsigned int'} changes value from '18446744073709551615' to '4294967295' [-Woverflow]
16 | #define ULLONG_MAX (~0ULL)
| ^
drivers/cxl/core/hdm.c:533:32: note: in expansion of macro 'ULLONG_MAX'
533 | resource_size_t base = ULLONG_MAX;
| ^~~~~~~~~~
vim +16 include/vdso/limits.h
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 4
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 5 #define USHRT_MAX ((unsigned short)~0U)
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 6 #define SHRT_MAX ((short)(USHRT_MAX >> 1))
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 7 #define SHRT_MIN ((short)(-SHRT_MAX - 1))
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 8 #define INT_MAX ((int)(~0U >> 1))
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 9 #define INT_MIN (-INT_MAX - 1)
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 10 #define UINT_MAX (~0U)
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 11 #define LONG_MAX ((long)(~0UL >> 1))
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 12 #define LONG_MIN (-LONG_MAX - 1)
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 13 #define ULONG_MAX (~0UL)
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 14 #define LLONG_MAX ((long long)(~0ULL >> 1))
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 15 #define LLONG_MIN (-LLONG_MAX - 1)
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 @16 #define ULLONG_MAX (~0ULL)
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 17 #define UINTPTR_MAX ULONG_MAX
3e0e9f8c6e3ca9 Vincenzo Frascino 2020-03-20 18
--
0-DAY CI Kernel Test Service
https://github.com/intel/lkp-tests/wiki
next prev parent reply other threads:[~2025-12-11 19:50 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-12-09 18:06 [PATCH v8 00/13] cxl: ACPI PRM Address Translation Support and AMD Zen5 enablement Robert Richter
2025-12-09 18:06 ` [PATCH v8 01/13] cxl/region: Rename misleading variable name @hpa to @hpa_range Robert Richter
2025-12-09 18:06 ` [PATCH v8 02/13] cxl/region: Store root decoder in struct cxl_region Robert Richter
2025-12-09 18:06 ` [PATCH v8 03/13] cxl/region: Store HPA range " Robert Richter
2025-12-09 18:06 ` [PATCH v8 04/13] cxl: Simplify cxl_root_ops allocation and handling Robert Richter
2025-12-09 18:06 ` [PATCH v8 05/13] cxl/region: Separate region parameter setup and region construction Robert Richter
2025-12-09 18:06 ` [PATCH v8 06/13] cxl/region: Add @hpa_range argument to function cxl_calc_interleave_pos() Robert Richter
2025-12-09 18:06 ` [PATCH v8 07/13] cxl/region: Use region data to get the root decoder Robert Richter
2025-12-09 18:06 ` [PATCH v8 08/13] cxl: Introduce callback for HPA address ranges translation Robert Richter
2025-12-09 18:06 ` [PATCH v8 09/13] cxl/acpi: Prepare use of EFI runtime services Robert Richter
2025-12-09 18:06 ` [PATCH v8 10/13] cxl: Enable AMD Zen5 address translation using ACPI PRMT Robert Richter
2025-12-09 18:06 ` [PATCH v8 11/13] cxl/atl: Lock decoders that need address translation Robert Richter
2025-12-09 18:06 ` [PATCH v8 12/13] cxl: Check if ULLONG_MAX was returned from translation functions Robert Richter
2025-12-10 16:23 ` Dave Jiang
2025-12-11 19:50 ` kernel test robot [this message]
2025-12-14 23:40 ` kernel test robot
2025-12-16 5:26 ` Alison Schofield
2025-12-09 18:06 ` [PATCH v8 13/13] cxl: Disable HPA/SPA translation handlers for Normalized addressing Robert Richter
2025-12-10 17:44 ` Dave Jiang
2025-12-15 13:25 ` Jonathan Cameron
2025-12-16 5:21 ` Alison Schofield
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=202512120346.aT9GKk20-lkp@intel.com \
--to=lkp@intel.com \
--cc=alison.schofield@intel.com \
--cc=dan.j.williams@intel.com \
--cc=dave.jiang@intel.com \
--cc=dave@stgolabs.net \
--cc=fabio.m.de.francesco@linux.intel.com \
--cc=gourry@gourry.net \
--cc=ira.weiny@intel.com \
--cc=jonathan.cameron@huawei.com \
--cc=joshua.hahnjy@gmail.com \
--cc=linux-cxl@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=oe-kbuild-all@lists.linux.dev \
--cc=rrichter@amd.com \
--cc=terry.bowman@amd.com \
--cc=vishal.l.verma@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox