Devicetree
 help / color / mirror / Atom feed
From: Jessica Zhang <quic_jesszhan@quicinc.com>
To: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>,
	Rob Clark <robdclark@gmail.com>,
	Abhinav Kumar <quic_abhinavk@quicinc.com>,
	Sean Paul <sean@poorly.run>,
	Marijn Suijten <marijn.suijten@somainline.org>,
	"David Airlie" <airlied@gmail.com>,
	Simona Vetter <simona@ffwll.ch>,
	"Maarten Lankhorst" <maarten.lankhorst@linux.intel.com>,
	Maxime Ripard <mripard@kernel.org>,
	Thomas Zimmermann <tzimmermann@suse.de>,
	Rob Herring <robh@kernel.org>,
	Krzysztof Kozlowski <krzk+dt@kernel.org>,
	Conor Dooley <conor+dt@kernel.org>,
	Bjorn Andersson <andersson@kernel.org>,
	Konrad Dybcio <konradybcio@kernel.org>,
	Simona Vetter <simona.vetter@ffwll.ch>
Cc: <linux-arm-msm@vger.kernel.org>,
	<dri-devel@lists.freedesktop.org>,
	<freedreno@lists.freedesktop.org>, <linux-kernel@vger.kernel.org>,
	<devicetree@vger.kernel.org>
Subject: Re: [PATCH v4 03/16] drm/msm/hdmi: convert clock and regulator arrays to const arrays
Date: Thu, 24 Apr 2025 11:39:10 -0700	[thread overview]
Message-ID: <0e452bde-6182-4779-8ad1-5019703da092@quicinc.com> (raw)
In-Reply-To: <20250209-fd-hdmi-hpd-v4-3-6224568ed87f@linaro.org>


On 2/8/2025 9:04 PM, Dmitry Baryshkov wrote:
> As a preparation to the next patches convert 'static const char *'
> arrays to 'static const char * const', as required by the checkpatch.pl
>
> Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>

Reviewed-by: Jessica Zhang <quic_jesszhan@quicinc.com>


> ---
>   drivers/gpu/drm/msm/hdmi/hdmi.c | 10 +++++-----
>   drivers/gpu/drm/msm/hdmi/hdmi.h |  8 ++++----
>   2 files changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/gpu/drm/msm/hdmi/hdmi.c b/drivers/gpu/drm/msm/hdmi/hdmi.c
> index 248541ff449204c72cd444458dadb9ae4a0a53d1..9e9900882687fa2ae4a734d5cf10b5bae5af2f87 100644
> --- a/drivers/gpu/drm/msm/hdmi/hdmi.c
> +++ b/drivers/gpu/drm/msm/hdmi/hdmi.c
> @@ -224,17 +224,17 @@ int msm_hdmi_modeset_init(struct hdmi *hdmi,
>   	.item ## _names = item ##_names_ ## entry, \
>   	.item ## _cnt   = ARRAY_SIZE(item ## _names_ ## entry)
>   
> -static const char *hpd_reg_names_8960[] = {"core-vdda"};
> -static const char *hpd_clk_names_8960[] = {"core", "master_iface", "slave_iface"};
> +static const char * const hpd_reg_names_8960[] = {"core-vdda"};
> +static const char * const hpd_clk_names_8960[] = {"core", "master_iface", "slave_iface"};
>   
>   static const struct hdmi_platform_config hdmi_tx_8960_config = {
>   		HDMI_CFG(hpd_reg, 8960),
>   		HDMI_CFG(hpd_clk, 8960),
>   };
>   
> -static const char *pwr_reg_names_8x74[] = {"core-vdda", "core-vcc"};
> -static const char *pwr_clk_names_8x74[] = {"extp", "alt_iface"};
> -static const char *hpd_clk_names_8x74[] = {"iface", "core", "mdp_core"};
> +static const char * const pwr_reg_names_8x74[] = {"core-vdda", "core-vcc"};
> +static const char * const pwr_clk_names_8x74[] = {"extp", "alt_iface"};
> +static const char * const hpd_clk_names_8x74[] = {"iface", "core", "mdp_core"};
>   static unsigned long hpd_clk_freq_8x74[] = {0, 19200000, 0};
>   
>   static const struct hdmi_platform_config hdmi_tx_8974_config = {
> diff --git a/drivers/gpu/drm/msm/hdmi/hdmi.h b/drivers/gpu/drm/msm/hdmi/hdmi.h
> index a5f481c39277631b7a19d294b086d6208be26511..381f957b34305494cb4da0b7dccb73b6ac3a1377 100644
> --- a/drivers/gpu/drm/msm/hdmi/hdmi.h
> +++ b/drivers/gpu/drm/msm/hdmi/hdmi.h
> @@ -84,20 +84,20 @@ struct hdmi {
>   /* platform config data (ie. from DT, or pdata) */
>   struct hdmi_platform_config {
>   	/* regulators that need to be on for hpd: */
> -	const char **hpd_reg_names;
> +	const char * const *hpd_reg_names;
>   	int hpd_reg_cnt;
>   
>   	/* regulators that need to be on for screen pwr: */
> -	const char **pwr_reg_names;
> +	const char * const *pwr_reg_names;
>   	int pwr_reg_cnt;
>   
>   	/* clks that need to be on for hpd: */
> -	const char **hpd_clk_names;
> +	const char * const *hpd_clk_names;
>   	const long unsigned *hpd_freq;
>   	int hpd_clk_cnt;
>   
>   	/* clks that need to be on for screen pwr (ie pixel clk): */
> -	const char **pwr_clk_names;
> +	const char * const *pwr_clk_names;
>   	int pwr_clk_cnt;
>   };
>   
>

  reply	other threads:[~2025-04-24 18:39 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-09  5:04 [PATCH v4 00/16] drm/msm/hdmi: rework and fix the HPD even generation Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 01/16] dt-bindings: display/msm/hdmi: drop obsolete GPIOs from schema Dmitry Baryshkov
2025-02-11  8:24   ` Krzysztof Kozlowski
2025-02-09  5:04 ` [PATCH v4 02/16] dt-bindings: display/msm: hdmi: drop hpd-gpios Dmitry Baryshkov
2025-02-11  8:26   ` Krzysztof Kozlowski
2025-02-12  0:16     ` Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 03/16] drm/msm/hdmi: convert clock and regulator arrays to const arrays Dmitry Baryshkov
2025-04-24 18:39   ` Jessica Zhang [this message]
2025-02-09  5:04 ` [PATCH v4 04/16] drm/msm/hdmi: move the alt_iface clock to the hpd list Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 05/16] drm/msm/hdmi: simplify extp clock handling Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 06/16] drm/msm/hdmi: drop clock frequency assignment Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 07/16] drm/msm/hdmi: switch to clk_bulk API Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 08/16] drm/msm/hdmi: switch to pm_runtime_resume_and_get() Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 09/16] drm/msm/hdmi: add runtime PM calls to DDC transfer function Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 10/16] drm/msm/hdmi: implement proper runtime PM handling Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 11/16] drm/msm/hdmi: rename hpd_clks to pwr_clks Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 12/16] drm/msm/hdmi: expand the HDMI_CFG macro Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 13/16] drm/msm/hdmi: drop hpd-gpios support Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 14/16] drm/msm/hdmi: ensure that HDMI is up if HPD is requested Dmitry Baryshkov
2025-02-09  5:04 ` [PATCH v4 15/16] drm/msm/hdmi: wire in hpd_enable/hpd_disable bridge ops Dmitry Baryshkov
2025-02-09  5:05 ` [PATCH v4 16/16] ARM: dts: qcom: apq8064-ifc6410: drop HDMI HPD GPIO Dmitry Baryshkov
2025-02-10 18:06   ` Konrad Dybcio
2025-05-20  2:14 ` (subset) [PATCH v4 00/16] drm/msm/hdmi: rework and fix the HPD even generation Bjorn Andersson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0e452bde-6182-4779-8ad1-5019703da092@quicinc.com \
    --to=quic_jesszhan@quicinc.com \
    --cc=airlied@gmail.com \
    --cc=andersson@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=dmitry.baryshkov@linaro.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=freedreno@lists.freedesktop.org \
    --cc=konradybcio@kernel.org \
    --cc=krzk+dt@kernel.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=marijn.suijten@somainline.org \
    --cc=mripard@kernel.org \
    --cc=quic_abhinavk@quicinc.com \
    --cc=robdclark@gmail.com \
    --cc=robh@kernel.org \
    --cc=sean@poorly.run \
    --cc=simona.vetter@ffwll.ch \
    --cc=simona@ffwll.ch \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox