From: Ian Campbell <Ian.Campbell@citrix.com>
To: Thomas Gleixner <tglx@linutronix.de>
Cc: linux-kernel <linux-kernel@vger.kernel.org>,
Jeremy Fitzhardinge <jeremy@goop.org>,
Dmitry Torokhov <dmitry.torokhov@gmail.com>,
Benjamin Herrenschmidt <benh@kernel.crashing.org>,
Paul Mackerras <paulus@samba.org>,
Grant Likely <grant.likely@secretlab.ca>,
xen-devel@lists.xensource.com, linux-input@vger.kernel.org,
linuxppc-dev@ozlabs.org, devicetree-discuss@lists.ozlabs.org
Subject: [GIT/PATCH 0/4] Do not use IRQF_TIMER for non timer interrupts
Date: Wed, 28 Jul 2010 11:54:05 +0100 [thread overview]
Message-ID: <1280314445.24292.90.camel@zakaz.uk.xensource.com> (raw)
Hi Thomas,
A small number of users of IRQF_TIMER are using it for the implied no
suspend behaviour on interrupts which are not timer interrupts.
Therefore the following series renames the IRQF_TIMER flag to
IRQF_NO_SUSPEND and updates the users which are not timer interrupts to
use the new name. IRQF_TIMER is retained as an alias for
IRQF_NO_SUSPEND.
The final patch in the series adds a new user the flag which disables
suspend of Xen IPI IRQs.
Ian.
The following changes since commit fc0f5ac8fe693d1b05f5a928cc48135d1c8b7f2e:
Linus Torvalds (1):
Merge branch 'for-linus' of git://git.kernel.org/.../ericvh/v9fs
are available in the git repository at:
git://xenbits.xensource.com/people/ianc/linux-2.6.git for-irq/irqf-no-suspend
Ian Campbell (4):
irq: rename IRQF_TIMER to IRQF_NO_SUSPEND
ixp4xx-beeper: Use IRQF_NO_SUSPEND not IRQF_TIMER for non-timer interrupt
powerpc: Use IRQF_NO_SUSPEND not IRQF_TIMER for non-timer interrupts
xen: do not suspend IPI IRQs.
arch/powerpc/platforms/powermac/low_i2c.c | 4 ++--
drivers/input/misc/ixp4xx-beeper.c | 2 +-
drivers/macintosh/via-pmu.c | 4 ++--
drivers/xen/events.c | 1 +
include/linux/interrupt.h | 8 ++++++--
kernel/irq/manage.c | 2 +-
6 files changed, 13 insertions(+), 8 deletions(-)
next reply other threads:[~2010-07-28 10:54 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-07-28 10:54 Ian Campbell [this message]
2010-07-28 10:54 ` [PATCH 1/4] irq: rename IRQF_TIMER to IRQF_NO_SUSPEND Ian Campbell
2010-07-29 8:49 ` Thomas Gleixner
2010-07-29 9:03 ` Ian Campbell
2010-07-29 10:16 ` [GIT/PATCH 0/4] Do not use IRQF_TIMER for non timer interrupts Ian Campbell
2010-07-29 10:16 ` [PATCH 1/4] irq: Add new IRQ flag IRQF_NO_SUSPEND Ian Campbell
[not found] ` <1280398595-29708-1-git-send-email-ian.campbell-Sxgqhf6Nn4DQT0dZR+AlfA@public.gmane.org>
2010-07-30 10:29 ` Benjamin Herrenschmidt
2010-07-29 10:16 ` [PATCH 3/4] powerpc: Use IRQF_NO_SUSPEND not IRQF_TIMER for non-timer interrupts Ian Campbell
[not found] ` <1280398595-29708-3-git-send-email-ian.campbell-Sxgqhf6Nn4DQT0dZR+AlfA@public.gmane.org>
2010-07-30 10:30 ` Benjamin Herrenschmidt
2010-07-28 10:54 ` Ian Campbell
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1280314445.24292.90.camel@zakaz.uk.xensource.com \
--to=ian.campbell@citrix.com \
--cc=benh@kernel.crashing.org \
--cc=devicetree-discuss@lists.ozlabs.org \
--cc=dmitry.torokhov@gmail.com \
--cc=grant.likely@secretlab.ca \
--cc=jeremy@goop.org \
--cc=linux-input@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linuxppc-dev@ozlabs.org \
--cc=paulus@samba.org \
--cc=tglx@linutronix.de \
--cc=xen-devel@lists.xensource.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox