From mboxrd@z Thu Jan 1 00:00:00 1970 From: Lee Jones Subject: Re: [PATCH v4 0/4] pwm: add support for ChromeOS EC PWM Date: Mon, 18 Jul 2016 14:24:26 +0100 Message-ID: <20160718132426.GB17074@dell> References: <1468625324-41229-1-git-send-email-briannorris@chromium.org> <20160718084928.GA17074@dell> <20160718091029.GA32259@ulmo.ba.sec> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: QUOTED-PRINTABLE Return-path: Content-Disposition: inline In-Reply-To: <20160718091029.GA32259@ulmo.ba.sec> Sender: linux-pwm-owner@vger.kernel.org To: Thierry Reding Cc: Brian Norris , Olof Johansson , linux-kernel@vger.kernel.org, Doug Anderson , Brian Norris , linux-pwm@vger.kernel.org, devicetree@vger.kernel.org, Boris Brezillon , Stephen Barber , Javier Martinez Canillas , Benson Leung , Enric Balletbo , Randall Spangler , Shawn Nematbakhsh , Dmitry Torokhov , Todd Broch , Gwendal Grignou , Tomeu Vizoso List-Id: devicetree@vger.kernel.org On Mon, 18 Jul 2016, Thierry Reding wrote: > On Mon, Jul 18, 2016 at 09:49:28AM +0100, Lee Jones wrote: > > On Fri, 15 Jul 2016, Brian Norris wrote: > > > This is the 4th (and final?) version of my series to support the = new ChromeOS > > > EC PWM API, so we can control, e.g., a PWM backlight when its PWM= is attached > > > to the EC. It uses Boris's latest "atomic" hooks for the PWM API = (i.e., the > > > ->apply() callback), which were recently merged. > > >=20 > > > Pulled and adapted the cros_ec_cmd_xfer_status() helper from this= patch, with > > > some minor modifications: > > >=20 > > > https://lkml.org/lkml/2016/4/12/342 > > >=20 > > > Note that after some style bikeshedding, I proposed to put off re= writing the > > > entire cros_ec_commands.h header at the moment, due to the shared= nature of > > > this file. Follow up here: > > >=20 > > > https://bugs.chromium.org/p/chromium/issues/detail?id=3D621123 > > >=20 > > > As this touches MFD (sort of), drivers/platform/chrome/, and driv= ers/pwm/, I'm > > > still not sure who it should all go through: Lee, Thierry, or Olo= f? > >=20 > > I usually take this type of submission through the MFD tree, althou= gh > > it's too late in the day to make it into v4.8. > >=20 > > Which Acks are you missing? >=20 > I'm willing to take this through the PWM tree if you're okay with the > MFD changes. I can put the MFD changes into a separate branch and you > could pull that in if you needed to resolve any dependencies, which I > think would be quite unlikely if you've already closed your tree. Are you saying that you're willing to take these straight into the merge-window, with no soak in -next? --=20 Lee Jones Linaro STMicroelectronics Landing Team Lead Linaro.org =E2=94=82 Open source software for ARM SoCs =46ollow Linaro: Facebook | Twitter | Blog