From: Hanna Hawa <hhhawa@amazon.com>
To: <robh+dt@kernel.org>, <mark.rutland@arm.com>,
<tsahee@annapurnalabs.com>, <antoine.tenart@bootlin.com>,
<hhhawa@amazon.com>, <mchehab+samsung@kernel.org>,
<davem@davemloft.net>, <gregkh@linuxfoundation.org>,
<Jonathan.Cameron@huawei.com>,
<andriy.shevchenko@linux.intel.com>, <tglx@linutronix.de>
Cc: <devicetree@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
<linux-arm-kernel@lists.infradead.org>, <dwmw@amazon.co.uk>,
<benh@amazon.com>, <ronenk@amazon.com>, <talel@amazon.com>,
<jonnyc@amazon.com>, <hanochu@amazon.com>
Subject: [PATCH v5 0/6] Amazon's Annapurna Labs Alpine v3 device-tree
Date: Tue, 24 Mar 2020 12:49:12 +0200 [thread overview]
Message-ID: <20200324104918.29578-1-hhhawa@amazon.com> (raw)
This series organize the Amazon's Annapurna Labs Alpine device tree
bindings, device tree folder and adds new device tree for Alpine v3.
Changes since v4:
-----------------
- Re-order nodes in increasing order.
- Add disable to UART nodes.
- Add missing UART nodes (1,2,3)
- Add comments for GIC/UART
- Add io-fabric bus, and move uart nodes into it.
- Fix MSIx range according Alpine function spec
Changes since v3:
-----------------
- rebased and retested for tag Linux 5.6-rc2
Changes since v2:
-----------------
- Move up a level for DT node without mmio regs.
- Drop device_type from serial@fd883000 node.
- Minor change name of PCIe node to: pcie@fbd00000
Changes since v1:
-----------------
- Rename al,alpine DT binding to amazon,alpine
- Rename al folder to be amazon
- Update maintainers of amazon,alpine DT
- Add missing alpine-v2 DT binding
- Fix yaml schemas for alpine-v3-evp.dts:
- #size-cells:0:0: 0 is not one of [1, 2]
- arch-timer: interrupts: [[1, 13, 8, 1, 14, 8, 1, 11, 8, 1, 10,
8]] is too short
- Change compatible string of alpine-v3-evp to amazon,al
Hanna Hawa (5):
dt-bindings: arm: amazon: rename al,alpine DT binding to amazon,al
arm64: dts: amazon: rename al folder to be amazon
dt-bindings: arm: amazon: update maintainers of amazon,al DT bindings
dt-bindings: arm: amazon: add missing alpine-v2 DT binding
dt-bindings: arm: amazon: add Amazon Annapurna Labs Alpine V3
Ronen Krupnik (1):
arm64: dts: amazon: add Amazon's Annapurna Labs Alpine v3 support
.../devicetree/bindings/arm/al,alpine.yaml | 21 -
.../devicetree/bindings/arm/amazon,al.yaml | 33 ++
MAINTAINERS | 2 +-
arch/arm64/boot/dts/Makefile | 2 +-
arch/arm64/boot/dts/{al => amazon}/Makefile | 1 +
.../boot/dts/{al => amazon}/alpine-v2-evp.dts | 0
.../boot/dts/{al => amazon}/alpine-v2.dtsi | 0
arch/arm64/boot/dts/amazon/alpine-v3-evp.dts | 24 ++
arch/arm64/boot/dts/amazon/alpine-v3.dtsi | 408 ++++++++++++++++++
9 files changed, 468 insertions(+), 23 deletions(-)
delete mode 100644 Documentation/devicetree/bindings/arm/al,alpine.yaml
create mode 100644 Documentation/devicetree/bindings/arm/amazon,al.yaml
rename arch/arm64/boot/dts/{al => amazon}/Makefile (64%)
rename arch/arm64/boot/dts/{al => amazon}/alpine-v2-evp.dts (100%)
rename arch/arm64/boot/dts/{al => amazon}/alpine-v2.dtsi (100%)
create mode 100644 arch/arm64/boot/dts/amazon/alpine-v3-evp.dts
create mode 100644 arch/arm64/boot/dts/amazon/alpine-v3.dtsi
--
2.17.1
next reply other threads:[~2020-03-24 10:50 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-03-24 10:49 Hanna Hawa [this message]
2020-03-24 10:49 ` [PATCH v5 1/6] dt-bindings: arm: amazon: rename al,alpine DT binding to amazon,al Hanna Hawa
2020-03-24 10:49 ` [PATCH v5 2/6] arm64: dts: amazon: rename al folder to be amazon Hanna Hawa
2020-03-24 10:49 ` [PATCH v5 3/6] dt-bindings: arm: amazon: update maintainers of amazon,al DT bindings Hanna Hawa
2020-03-24 10:49 ` [PATCH v5 4/6] dt-bindings: arm: amazon: add missing alpine-v2 DT binding Hanna Hawa
2020-03-24 10:49 ` [PATCH v5 5/6] dt-bindings: arm: amazon: add Amazon Annapurna Labs Alpine V3 Hanna Hawa
2020-03-24 10:49 ` [PATCH v5 6/6] arm64: dts: amazon: add Amazon's Annapurna Labs Alpine v3 support Hanna Hawa
2020-05-14 15:22 ` [PATCH v5 0/6] Amazon's Annapurna Labs Alpine v3 device-tree Antoine Tenart
2020-07-23 10:10 ` Arnd Bergmann
2020-07-23 10:20 ` Hawa, Hanna
2020-07-23 10:34 ` Antoine Tenart
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200324104918.29578-1-hhhawa@amazon.com \
--to=hhhawa@amazon.com \
--cc=Jonathan.Cameron@huawei.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=antoine.tenart@bootlin.com \
--cc=benh@amazon.com \
--cc=davem@davemloft.net \
--cc=devicetree@vger.kernel.org \
--cc=dwmw@amazon.co.uk \
--cc=gregkh@linuxfoundation.org \
--cc=hanochu@amazon.com \
--cc=jonnyc@amazon.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=mchehab+samsung@kernel.org \
--cc=robh+dt@kernel.org \
--cc=ronenk@amazon.com \
--cc=talel@amazon.com \
--cc=tglx@linutronix.de \
--cc=tsahee@annapurnalabs.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox