Devicetree
 help / color / mirror / Atom feed
From: Conor Dooley <conor@kernel.org>
To: jean-baptiste.maneyrol@tdk.com
Cc: Jonathan Cameron <jic23@kernel.org>,
	Lars-Peter Clausen <lars@metafoo.de>,
	Rob Herring <robh@kernel.org>,
	Krzysztof Kozlowski <krzk+dt@kernel.org>,
	Conor Dooley <conor+dt@kernel.org>,
	linux-iio@vger.kernel.org, devicetree@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 1/2] dt-bindings: iio: imu: icm42600: add interrupt naming support
Date: Tue, 8 Apr 2025 17:23:51 +0100	[thread overview]
Message-ID: <20250408-dandy-rental-c76bcb4a5788@spud> (raw)
In-Reply-To: <20250407-iio-imu-inv-icm42600-rework-interrupt-using-names-v2-1-c278acf587b2@tdk.com>

[-- Attachment #1: Type: text/plain, Size: 2388 bytes --]

On Mon, Apr 07, 2025 at 09:57:16PM +0200, Jean-Baptiste Maneyrol via B4 Relay wrote:
> From: Jean-Baptiste Maneyrol <jean-baptiste.maneyrol@tdk.com>
> 
> Add interrupt-names field for specifying interrupt used. Only INT1
> is supported by the driver currently.
> 
> Add minItems 1 for interrupts since interrupt is mandatory for the driver.
> 
> Signed-off-by: Jean-Baptiste Maneyrol <jean-baptiste.maneyrol@tdk.com>
> ---
>  .../devicetree/bindings/iio/imu/invensense,icm42600.yaml    | 13 +++++++++++++
>  1 file changed, 13 insertions(+)
> 
> diff --git a/Documentation/devicetree/bindings/iio/imu/invensense,icm42600.yaml b/Documentation/devicetree/bindings/iio/imu/invensense,icm42600.yaml
> index 7e4492bbd0278a336587dc5ac04da7153453da29..707f2169ce9a3ca41d81560bed15786fe010109e 100644
> --- a/Documentation/devicetree/bindings/iio/imu/invensense,icm42600.yaml
> +++ b/Documentation/devicetree/bindings/iio/imu/invensense,icm42600.yaml
> @@ -41,6 +41,17 @@ properties:
>    interrupts:
>      maxItems: 1
>  
> +  interrupt-names:
> +    minItems: 1
> +    maxItems: 1
> +    items:
> +      enum:
> +        - INT1
> +        - INT2

I might be misremembering from looking up the datasheet, but it gave the
impression that either all interrupts can be wired to int1 or int1 and
int2 are usable. How come maxItems is set to one here, not two? Surely
someone could wire them both up, even if the driver only ever uses the
former.

> +    description: |
> +      choose chip interrupt pin to be used as interrupt input, beware that the
> +      only support interrupt pin is INT1 for the moment.

What linux supports should not be part of the hardware description.

> +
>    drive-open-drain:
>      type: boolean
>  
> @@ -76,6 +87,7 @@ examples:
>              reg = <0x68>;
>              interrupt-parent = <&gpio2>;
>              interrupts = <7 IRQ_TYPE_EDGE_FALLING>;
> +            interrupt-names = "INT1";
>              vdd-supply = <&vdd>;
>              vddio-supply = <&vddio>;
>          };
> @@ -95,6 +107,7 @@ examples:
>              spi-cpol;
>              interrupt-parent = <&gpio1>;
>              interrupts = <2 IRQ_TYPE_EDGE_FALLING>;
> +            interrupt-names = "INT1";
>              vdd-supply = <&vdd>;
>              vddio-supply = <&vddio>;
>          };
> 
> -- 
> 2.49.0
> 
> 

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]

  reply	other threads:[~2025-04-08 16:23 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-07 19:57 [PATCH v2 0/2] iio: imu: inv_icm42600: switch to use generic name irq get Jean-Baptiste Maneyrol via B4 Relay
2025-04-07 19:57 ` [PATCH v2 1/2] dt-bindings: iio: imu: icm42600: add interrupt naming support Jean-Baptiste Maneyrol via B4 Relay
2025-04-08 16:23   ` Conor Dooley [this message]
2025-04-09 15:03     ` Jean-Baptiste Maneyrol
2025-04-07 19:57 ` [PATCH v2 2/2] iio: imu: inv_icm42600: switch to use generic name irq get Jean-Baptiste Maneyrol via B4 Relay

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250408-dandy-rental-c76bcb4a5788@spud \
    --to=conor@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=jean-baptiste.maneyrol@tdk.com \
    --cc=jic23@kernel.org \
    --cc=krzk+dt@kernel.org \
    --cc=lars@metafoo.de \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robh@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox