Devicetree
 help / color / mirror / Atom feed
From: Hao-Wen Ting <haowen.ting@realtek.com>
To: <daniel.lezcano@linaro.org>, <tglx@linutronix.de>
Cc: <jinn.cheng@realtek.com>, <edwardwu@realtek.com>,
	<phelic@realtek.com>, <shawn.huang724@realtek.com>,
	<haowen.ting@realtek.com>, <cy.huang@realtek.com>,
	<james.tai@realtek.com>, <stanley_chang@realtek.com>,
	<cylee12@realtek.com>, <phinex@realtek.com>,
	<conor+dt@kernel.org>, <krzk+dt@kernel.org>, <robh@kernel.org>,
	<devicetree@vger.kernel.org>, <linux-kernel@vger.kernel.org>
Subject: [PATCH v5 0/2] Add Realtek System Timer
Date: Wed, 26 Nov 2025 14:01:08 +0800	[thread overview]
Message-ID: <20251126060110.198330-1-haowen.ting@realtek.com> (raw)

Changes v5:
PATCH 1/2
- Drop redundant description markers in binding documentation.
- Add "Reviewed-by" tag

PATCH 2/2
- Add "Acked-by" tag
---

Changes v4:
PATCH 1/2
- Adjust compatible property description to match actual DTS and validate
  it with dt_binding_check.
- Refine binding documentation descriptions.

PATCH 2/2
- Reorder variable declarations.
- Remove debug prints.
- Eliminate unnecessary line breaks.
- Switch to set_next_event() callback instead of set_next_ktime().
- Remove operations that caused build error.
- Rename the struct `timer_of` instance variable for clarity.
- Tabularize struct initializers.
- Refine descriptions.
---

Changes v3:
PATCH 1/2
- Rename binding documentation to match compatible string.
- Drop redundant "binding" from commit subject.
- Add example node and description for realtek,rtd1635-systimer.

PATCH 2/2
- Add Kconfig dependency: ARCH_REALTEK || COMPILE_TEST.
---

Changes v2:
PATCH 1/2
- Add full name 'system timer' to description.
- Remove redundant commit messages.
- Clarify compatible strings for specific verified SoCs.
- Remove redundant reg and interrupts description sentences.
- Use generic node name in example.

PATCH 2/2
- Correct MAINTAINERS to alphabetical order.
- Update Kconfig: switch dependency to ARM/ARM64.
- Remove redundant pr_info output.
---

This patch series adds support for the Realtek System Timer, a 64-bit counter
that serves as a clock event device on Realtek SoCs.

Technical details:
- Implements a 64-bit timer operating at 1MHz fixed frequency.
- Supports oneshot mode and tick broadcast functionality.
- Remains active during CPU power-down states.

Testing:
- Functionality verified for tick broadcast on both RTD1625 and RTD1635 SoCs.
- Confirmed binding documentation passes yamllint, dt_binding_check, and dtbs_check.
- Driver successfully built under COMPILE_TEST.

Patch organization:
Patch 1/2: Device Tree binding documentation
Patch 2/2: Clocksource driver implementation

Best regards,
Hao-Wen Ting

Hao-Wen Ting (2):
  dt-bindings: timer: Add Realtek SYSTIMER
  clocksource: Add Realtek system timer driver

 .../timer/realtek,rtd1625-systimer.yaml       |  47 ++++++
 MAINTAINERS                                   |   5 +
 drivers/clocksource/Kconfig                   |  11 ++
 drivers/clocksource/Makefile                  |   1 +
 drivers/clocksource/timer-realtek.c           | 150 ++++++++++++++++++
 5 files changed, 214 insertions(+)
 create mode 100644 Documentation/devicetree/bindings/timer/realtek,rtd1625-systimer.yaml
 create mode 100644 drivers/clocksource/timer-realtek.c


base-commit: 948b99877bf5a1cd58bee930e455b7574daba5c3
-- 
2.34.1


             reply	other threads:[~2025-11-26  6:01 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-11-26  6:01 Hao-Wen Ting [this message]
2025-11-26  6:01 ` [PATCH v5 1/2] dt-bindings: timer: Add Realtek SYSTIMER Hao-Wen Ting
2025-11-26  8:43   ` Krzysztof Kozlowski
2025-11-26  6:01 ` [PATCH v5 2/2] clocksource: Add Realtek system timer driver Hao-Wen Ting
2025-11-26 10:26 ` [PATCH v5 0/2] Add Realtek System Timer Daniel Lezcano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20251126060110.198330-1-haowen.ting@realtek.com \
    --to=haowen.ting@realtek.com \
    --cc=conor+dt@kernel.org \
    --cc=cy.huang@realtek.com \
    --cc=cylee12@realtek.com \
    --cc=daniel.lezcano@linaro.org \
    --cc=devicetree@vger.kernel.org \
    --cc=edwardwu@realtek.com \
    --cc=james.tai@realtek.com \
    --cc=jinn.cheng@realtek.com \
    --cc=krzk+dt@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=phelic@realtek.com \
    --cc=phinex@realtek.com \
    --cc=robh@kernel.org \
    --cc=shawn.huang724@realtek.com \
    --cc=stanley_chang@realtek.com \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox