From: sashiko-bot@kernel.org
To: "Yixun Lan" <dlan@kernel.org>
Cc: conor+dt@kernel.org, devicetree@vger.kernel.org, robh@kernel.org
Subject: Re: [PATCH 2/2] riscv: dts: spacemit: k3: Initial support for CoM260-IFX board
Date: Wed, 20 May 2026 05:56:34 +0000 [thread overview]
Message-ID: <20260520055635.5F2B61F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260520-02-k3-com260-ifx-v1-2-3e17055dd488@kernel.org>
Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider:
- [Low] The PMIC node is incorrectly named `p1@41` instead of using a generic name.
- [Low] The pinctrl node for `gmac1` defines an unused label `gmac1_base_pins:` and uses an inconsistent subnode name compared to `gmac0`.
--
commit be83cb21ec8e4b52ccd315661d69460e85196cef
Author: Yixun Lan <dlan@kernel.org>
riscv: dts: spacemit: k3: Initial support for CoM260-IFX board
This commit introduces initial device tree support for the K3 CoM260-IFX
board, which combines a 260-pin compute module with a carrier board. It
enables basic features including Serial UART, ethernet, and the onboard PMIC.
> diff --git a/arch/riscv/boot/dts/spacemit/k3-com260.dtsi b/arch/riscv/boot/dts/spacemit/k3-com260.dtsi
> new file mode 100644
> index 0000000000000..1801a44d43559
> --- /dev/null
> +++ b/arch/riscv/boot/dts/spacemit/k3-com260.dtsi
[ ... ]
> +&i2c8 {
> + pinctrl-names = "default";
> + pinctrl-0 = <&i2c8_cfg>;
> + status = "okay";
> +
> + p1@41 {
[Severity: Low]
This isn't a bug, but according to the Devicetree specification, node names
should be generic and reflect the function of the device rather than the chip
name. Could this be named pmic@41 instead of p1@41?
> + compatible = "spacemit,p1";
> + reg = <0x41>;
> + interrupts = <64 IRQ_TYPE_LEVEL_HIGH>;
[ ... ]
> diff --git a/arch/riscv/boot/dts/spacemit/k3-pinctrl.dtsi b/arch/riscv/boot/dts/spacemit/k3-pinctrl.dtsi
> index 23899d3f308a0..04efe64b8a3a2 100644
> --- a/arch/riscv/boot/dts/spacemit/k3-pinctrl.dtsi
> +++ b/arch/riscv/boot/dts/spacemit/k3-pinctrl.dtsi
[ ... ]
> @@ -45,6 +45,39 @@ gmac0-phy-0-pins {
> };
> };
>
> + gmac1_rgmii_0_cfg: gmac1-rgmii-0-cfg {
> + gmac1_base_pins: gmac1-0-pins {
[Severity: Low]
This isn't a bug, but the gmac1_base_pins label appears to be unused.
Also, is there a reason this subnode is named gmac1-0-pins instead of
following the gmac0-rgmii-0-pins naming convention seen elsewhere?
> + pinmux = <K3_PADCONF(21, 1)>, /* gmac1_rxdv */
> + <K3_PADCONF(22, 1)>, /* gmac1 rx d0 */
> + <K3_PADCONF(23, 1)>, /* gmac1 rx d1 */
> + <K3_PADCONF(24, 1)>, /* gmac1 rx_clk */
> + <K3_PADCONF(25, 1)>, /* gmac1 rx d2 */
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260520-02-k3-com260-ifx-v1-0-3e17055dd488@kernel.org?part=2
prev parent reply other threads:[~2026-05-20 5:56 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-05-20 5:40 [PATCH 0/2] spacemit: k3: Add support for CoM260-IFX board Yixun Lan
2026-05-20 5:40 ` [PATCH 1/2] dt-bindings: riscv: spacemit: Add K3 " Yixun Lan
2026-05-20 16:18 ` Conor Dooley
2026-05-20 5:40 ` [PATCH 2/2] riscv: dts: spacemit: k3: Initial support for " Yixun Lan
2026-05-20 5:56 ` sashiko-bot [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260520055635.5F2B61F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=dlan@kernel.org \
--cc=robh@kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox