Devicetree
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Vitor Soares" <ivitro@gmail.com>
Cc: conor+dt@kernel.org, robh@kernel.org, devicetree@vger.kernel.org
Subject: Re: [PATCH v2 01/11] arm64: dts: ti: k3-am62-verdin: Add Toradex DSI to LVDS adapter with 10.1" display
Date: Fri, 22 May 2026 13:52:48 +0000	[thread overview]
Message-ID: <20260522135249.2AF5D1F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260522132014.226721-14-ivitro@gmail.com>

Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider:
- [Low] Nodes use specific device or misleading names instead of the required generic class names.
- [Low] The fixed regulator node 'regulator-3v3-lvds-bridge' is missing the strictly required 'regulator-name' property.
--

commit 8eb886986d19e2608d6989dd557b140a93c31c32
Author: Vitor Soares <vitor.soares@toradex.com>

arm64: dts: ti: k3-am62-verdin: Add Toradex DSI to LVDS adapter with 10.1" display

This commit adds a device tree overlay for the Toradex DSI to LVDS Adapter
connected to a 10.1" capacitive touch display. It configures the SN65DSI84
bridge, an LVDS panel, and an Atmel MaxTouch controller on the Verdin DSI_1
interface.

Link: https://developer.toradex.com/hardware/accessories/add-ons/dsi-lvds-adapter
Link: https://developer.toradex.com/hardware/accessories/displays/capacitive-touch-display-101inch-lvds

[ ... ]
> diff --git a/arch/arm64/boot/dts/ti/k3-am625-verdin-dsi-to-lvds-panel-cap-touch-10inch.dtso b/arch/arm64/boot/dts/ti/k3-am625-verdin-dsi-to-lvds-panel-cap-touch-10inch.dtso
> new file mode 100644
> index 0000000000000..0e873f2ccf65a
> --- /dev/null
> +++ b/arch/arm64/boot/dts/ti/k3-am625-verdin-dsi-to-lvds-panel-cap-touch-10inch.dtso
> @@ -0,0 +1,123 @@
[ ... ]
> +&{/} {
> +	backlight_pwm3: backlight-pwm3 {

[Severity: Low]
Should this node use a generic name like 'backlight' instead of
'backlight-pwm3' to comply with the Devicetree Specification recommendations?

Using non-generic names might cause schema validation warnings during
dtbs_check.

> +		compatible = "pwm-backlight";
> +		pinctrl-names = "default";
> +		pinctrl-0 = <&pinctrl_i2s_2_d_out_gpio>;
> +		brightness-levels = <0 45 63 88 119 158 203 255>;
> +		default-brightness-level = <4>;
> +		/* Verdin I2S_2_D_OUT as GPIO (SODIMM 46) */
> +		enable-gpios = <&main_gpio0 34 GPIO_ACTIVE_HIGH>;
> +		power-supply = <&reg_3v3>;
> +		/* Verdin PWM_3_DSI (SODIMM 19) */
> +		pwms = <&epwm1 0 6666667 PWM_POLARITY_INVERTED>;
> +	};
> +
> +	panel-lvds-bridge {

[Severity: Low]
Does this node name deviate from the Devicetree Specification recommendations?

Using a generic name like 'panel' is usually preferred and helps avoid
schema validation warnings.

> +		compatible = "logictechno,lt170410-2whc";
> +		backlight = <&backlight_pwm3>;
> +		power-supply = <&reg_3v3_lvds_bridge>;
> +
> +		port {
> +			panel_lvds_bridge_in: endpoint {
> +				remote-endpoint = <&dsi_lvds_bridge_out>;
> +			};
> +		};
> +	};
> +
> +	reg_3v3_lvds_bridge: regulator-3v3-lvds-bridge {
> +		compatible = "regulator-fixed";
> +		regulator-max-microvolt = <3300000>;
> +		regulator-min-microvolt = <3300000>;

[Severity: Low]
Is the 'regulator-name' property missing here?

According to the fixed regulator bindings in
Documentation/devicetree/bindings/regulator/fixed-regulator.yaml, this
property is mandatory when the compatible string is "regulator-fixed".
Omitting it will cause dtbs_check errors.

> +	};
> +};
[ ... ]
> +/* Verdin I2C_1 */
> +&main_i2c1 {
> +	#address-cells = <1>;
> +	#size-cells = <0>;
> +
> +	bridge@2c {
> +		compatible = "ti,sn65dsi84";
[ ... ]
> +		};
> +	};
> +
> +	touch@4a {

[Severity: Low]
Could we use the generic class name 'touchscreen@4a' here instead of
'touch@4a' to align with standard device tree conventions?

> +		compatible = "atmel,maxtouch";
> +		reg = <0x4a>;
> +		pinctrl-names = "default";
> +		pinctrl-0 = <&pinctrl_dsi1_int>, <&pinctrl_i2s_2_bclk_gpio>;
> +		/* Verdin GPIO_9_DSI (SODIMM 17) - TOUCH_INT# */
> +		interrupt-parent = <&main_gpio1>;
> +		interrupts = <49 IRQ_TYPE_EDGE_FALLING>;
> +		/* Verdin I2S_2_BCLK (SODIMM 42) - TOUCH_RESET# */
> +		reset-gpios = <&main_gpio0 35 GPIO_ACTIVE_LOW>;
> +	};
> +};

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260522132014.226721-13-ivitro@gmail.com?part=1

  reply	other threads:[~2026-05-22 13:52 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-05-22 13:20 [PATCH v2 00/11] arm64: dts: ti: k3-am62-verdin: Add display and peripheral overlays Vitor Soares
2026-05-22 13:20 ` [PATCH v2 01/11] arm64: dts: ti: k3-am62-verdin: Add Toradex DSI to LVDS adapter with 10.1" display Vitor Soares
2026-05-22 13:52   ` sashiko-bot [this message]
2026-05-22 15:51   ` Vitor Soares
2026-05-22 13:20 ` [PATCH v2 02/11] arm64: dts: ti: k3-am62-verdin: Add Toradex Capacitive Touch Display 10.1" LVDS Vitor Soares
2026-05-22 13:20 ` [PATCH v2 03/11] dt-bindings: vendor-prefixes: Add Riverdi Vitor Soares
2026-05-22 13:20 ` [PATCH v2 04/11] dt-bindings: display: panel-lvds: Add Riverdi RVT70HSLNWCA0 and RVT101HVLNWC00 Vitor Soares
2026-05-22 13:20 ` [PATCH v2 05/11] arm64: dts: ti: k3-am62-verdin: Add Toradex Capacitive Touch Display 10.1" DSI Vitor Soares
2026-05-22 14:02   ` sashiko-bot
2026-05-22 13:20 ` [PATCH v2 06/11] arm64: dts: ti: k3-am62-verdin: Add Toradex Capacitive Touch Display 7" DSI Vitor Soares
2026-05-22 13:44   ` sashiko-bot
2026-05-22 13:20 ` [PATCH v2 07/11] arm64: dts: ti: k3-am62-verdin: Add NAU8822 Bridge Tied Load Vitor Soares
2026-05-22 13:20 ` [PATCH v2 08/11] arm64: dts: ti: k3-am62-verdin: Reserve UART_4 for Cortex-M4F Vitor Soares
2026-05-22 13:20 ` [PATCH v2 09/11] arm64: dts: ti: k3-am62-verdin: Add Toradex OV5640 CSI Cameras Vitor Soares
2026-05-22 13:20 ` [PATCH v2 10/11] arm64: dts: ti: k3-am62-verdin: Add Toradex Verdin Mezzanine CAN Vitor Soares
2026-05-22 13:20 ` [PATCH v2 11/11] arm64: dts: ti: k3-am62-verdin: Add Mezzanine with Toradex Display 10.1" LVDS Vitor Soares

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260522135249.2AF5D1F000E9@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=ivitro@gmail.com \
    --cc=robh@kernel.org \
    --cc=sashiko-reviews@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox