From: sashiko-bot@kernel.org
To: "Chen-Yu Tsai" <wenst@chromium.org>
Cc: robh@kernel.org, conor+dt@kernel.org, devicetree@vger.kernel.org
Subject: Re: [PATCH v6 02/16] device property: Add fwnode_graph_get_next_port_endpoint()
Date: Tue, 21 Jul 2026 07:09:16 +0000 [thread overview]
Message-ID: <20260721070917.0CFEA1F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260721065413.2306137-3-wenst@chromium.org>
Thank you for your contribution! Sashiko AI review found 3 potential issue(s) to consider:
New issues:
- [High] Hardcoded OF naming conventions break ACPI graph node endpoint identification.
- [Medium] `fwnode_graph_get_next_port_endpoint()` leaks the `prev` reference when called with a `NULL` `port`, violating its own docstring contract.
Pre-existing issues:
- [High] `fwnode_get_next_child_node()` causes a double-free, use-after-free, and an infinite loop when iterating over a node with both primary and secondary fwnodes.
--
--- Patch [2]: [PATCH v6 02/16] device property: Add fwnode_graph_get_next_port_endpoint() ---
commit 0b043b08c9a4c2f484d73d298735da40162c82f7
Author: Chen-Yu Tsai <wenst@chromium.org>
device property: Add fwnode_graph_get_next_port_endpoint()
This commit introduces a helper to get the next endpoint under a given
"port" firmware node. It checks if the child node name matches "endpoint"
and continues until it finds a match or exhausts all children.
> diff --git a/drivers/base/property.c b/drivers/base/property.c
> index 0bd45f8b01c14..62c6221d65d05 100644
> --- a/drivers/base/property.c
> +++ b/drivers/base/property.c
[ ... ]
> @@ -1099,6 +1099,31 @@ int fwnode_irq_get_byname(const struct fwnode_handle *fwnode, const char *name)
> }
> EXPORT_SYMBOL(fwnode_irq_get_byname);
>
> +/**
> + * fwnode_graph_get_next_port_endpoint - Get next endpoint firmware node in port
> + * @port: Pointer to the target port firmware node
> + * @prev: Previous endpoint node or %NULL to get the first
> + *
> + * The caller is responsible for calling fwnode_handle_put() on the returned
> + * fwnode pointer. Note that this function also puts a reference to @prev
> + * unconditionally.
> + *
> + * Return: an endpoint firmware node pointer or %NULL if no more endpoints
> + * are available.
> + */
> +struct fwnode_handle *fwnode_graph_get_next_port_endpoint(const struct fwnode_handle *port,
> + struct fwnode_handle *prev)
> +{
> + do {
> + prev = fwnode_get_next_child_node(port, prev);
[Severity: Medium]
Will this leak the prev reference if port is NULL?
The docstring states this function puts a reference to prev unconditionally.
However, if port is NULL, fwnode_get_next_child_node() returns NULL without
putting prev. The loop then terminates, returning NULL and silently
overwriting the original prev reference, resulting in a leak.
[Severity: High]
This isn't a bug introduced by this patch, but can the call to
fwnode_get_next_child_node() cause a double-free and a potential infinite
loop if the port node has both primary and secondary fwnodes?
Looking at fwnode_get_next_child_node(), if child is the last child of the
primary fwnode, fwnode_call_ptr_op() drops the reference and returns NULL.
The function then falls through and passes the already-freed child pointer
to the secondary backend:
fwnode_get_next_child_node() {
...
next = fwnode_call_ptr_op(fwnode, get_next_child_node, child);
if (next)
return next;
/* When no more children in primary, continue with secondary */
return fwnode_call_ptr_op(fwnode->secondary, get_next_child_node, child);
}
If the secondary backend is a software node, it unconditionally puts the
child again, causing a double-free. Furthermore, if it returns a valid
secondary child, the next iteration passes it back to the primary backend
which evaluates it to NULL, looping back to the first primary child.
> + if (fwnode_name_eq(prev, "endpoint"))
[Severity: High]
Is it safe to hardcode the "endpoint" string match here for all firmware
types, such as ACPI?
While this works for Device Tree, ACPI evaluates endpoints differently using
is_acpi_graph_node(), which allows endpoints to be identified by an
"endpoint" property or a "reg" property with an "endpoint@" prefix,
regardless of the literal node name.
By relying strictly on fwnode_name_eq(), this generic helper bypasses
the backend abstractions and might fail for ACPI endpoints that use
property-based identification or lack a 'reg' property.
> + break;
> + } while (prev);
> +
> + return prev;
> +}
> +EXPORT_SYMBOL_GPL(fwnode_graph_get_next_port_endpoint);
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260721065413.2306137-1-wenst@chromium.org?part=2
next prev parent reply other threads:[~2026-07-21 7:09 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-21 6:53 [PATCH v6 00/16] arm64: mediatek: Add M.2 E-key slot on Chromebooks Chen-Yu Tsai
2026-07-21 6:53 ` [PATCH v6 01/16] device property: Add fwnode_graph_get_port_by_id() Chen-Yu Tsai
2026-07-21 6:53 ` [PATCH v6 02/16] device property: Add fwnode_graph_get_next_port_endpoint() Chen-Yu Tsai
2026-07-21 7:09 ` sashiko-bot [this message]
2026-07-21 6:53 ` [PATCH v6 03/16] power: sequencing: Add pwrseq_power_is_on() Chen-Yu Tsai
2026-07-21 7:10 ` sashiko-bot
2026-07-21 9:08 ` Bartosz Golaszewski
2026-07-21 6:53 ` [PATCH v6 04/16] usb: hub: Use assign_bit() in usb_hub_set_port_power() Chen-Yu Tsai
2026-07-21 9:09 ` Bartosz Golaszewski
2026-07-21 6:54 ` [PATCH v6 05/16] usb: hub: Return actual error from hub_configure() in hub_probe() Chen-Yu Tsai
2026-07-21 6:54 ` [PATCH v6 06/16] usb: hub: Associate port@ fwnode with USB port device Chen-Yu Tsai
2026-07-21 6:54 ` [PATCH v6 07/16] usb: core: Move struct usb_port and related APIs to port.h Chen-Yu Tsai
2026-07-21 6:54 ` [PATCH v6 08/16] usb: hub: Pass |struct usb_port*| to usb_port_is_power_on() Chen-Yu Tsai
2026-07-21 6:54 ` [PATCH v6 09/16] usb: hub: Use usb_hub_set_port_power() to control port power everywhere Chen-Yu Tsai
2026-07-21 6:54 ` [PATCH v6 10/16] usb: hub: Power on connected M.2 E-key connectors with power sequencing API Chen-Yu Tsai
2026-07-21 7:13 ` sashiko-bot
2026-07-21 10:19 ` Andy Shevchenko
2026-07-21 6:54 ` [PATCH v6 11/16] dt-bindings: usb: mediatek,mtk-xhci: Switch to ports for USB connections Chen-Yu Tsai
2026-07-21 6:54 ` [PATCH v6 12/16] power: sequencing: pcie-m2: support matching on remote "port" node Chen-Yu Tsai
2026-07-21 6:54 ` [PATCH v6 13/16] power: sequencing: pcie-m2: Add usb and sdio targets for E-key connector Chen-Yu Tsai
2026-07-21 6:54 ` [PATCH v6 14/16] power: sequencing: pcie-m2: Split Bluetooth unit based on interface Chen-Yu Tsai
2026-07-21 7:11 ` sashiko-bot
2026-07-21 6:54 ` [PATCH v6 15/16] arm64: dts: mediatek: mt8195-cherry: Add M.2 E-key slot Chen-Yu Tsai
2026-07-21 9:09 ` Bartosz Golaszewski
2026-07-21 6:54 ` [PATCH v6 16/16] arm64: dts: mediatek: mt8188-geralt: Add WiFi/BT as " Chen-Yu Tsai
2026-07-21 9:09 ` Bartosz Golaszewski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260721070917.0CFEA1F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=robh@kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
--cc=wenst@chromium.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox