On Mon, Aug 31, 2026 at 02:36:35PM +0200, Oleksij Rempel wrote: > Document the RTL8365MB power rails as optional supplies. They are optional > because the rails are often always-on; some designs break them out for > granular hwmon monitoring and regulator control. > > They are scoped to realtek,rtl8365mb: different Realtek switch families use > different power-rail naming schemes, so these rails do not apply to other > families such as realtek,rtl8366rb (VDDA/VDD_CORE/VDDIO/...). > > Signed-off-by: Oleksij Rempel > Reviewed-by: Linus Walleij > Reviewed-by: Luiz Angelo Daros de Luca Acked-by: Conor Dooley > --- > Changes since v2: > - Move the *-supply properties to the top level; if:/then: now only forbids > them on non-rtl8365mb compatibles (Krzysztof Kozlowski). > --- > .../devicetree/bindings/net/dsa/realtek.yaml | 33 +++++++++++++++++++ > 1 file changed, 33 insertions(+) > > diff --git a/Documentation/devicetree/bindings/net/dsa/realtek.yaml b/Documentation/devicetree/bindings/net/dsa/realtek.yaml > index 473facd87a62..b7bb60af623c 100644 > --- a/Documentation/devicetree/bindings/net/dsa/realtek.yaml > +++ b/Documentation/devicetree/bindings/net/dsa/realtek.yaml > @@ -8,6 +8,20 @@ title: Realtek switches for unmanaged switches > > allOf: > - $ref: dsa.yaml#/$defs/ethernet-ports > + - if: > + not: > + properties: > + compatible: > + contains: > + const: realtek,rtl8365mb > + then: > + properties: > + avddh-supply: false > + avddl-supply: false > + dvddio-supply: false > + dvddio1-supply: false > + dvddl-supply: false > + pllvddl-supply: false > > maintainers: > - Linus Walleij > @@ -62,6 +76,24 @@ properties: > resets: > maxItems: 1 > > + avddh-supply: > + description: AVDDH high-voltage analog supply. > + > + avddl-supply: > + description: AVDDL low-voltage analog supply. > + > + dvddio-supply: > + description: DVDDIO digital I/O supply. > + > + dvddio1-supply: > + description: DVDDIO_1 secondary digital I/O supply for the RGMII bank. > + > + dvddl-supply: > + description: DVDDL digital core supply. > + > + pllvddl-supply: > + description: PLLVDDL PLL analog supply. > + > realtek,disable-leds: > type: boolean > description: | > @@ -243,6 +275,7 @@ examples: > platform { > ethernet-switch { > compatible = "realtek,rtl8365mb"; > + avddh-supply = <&avddh>; > mdc-gpios = <&gpio1 16 GPIO_ACTIVE_HIGH>; > mdio-gpios = <&gpio1 17 GPIO_ACTIVE_HIGH>; > reset-gpios = <&gpio5 0 GPIO_ACTIVE_LOW>; > -- > 2.47.3 >