From: Alex Elder <elder@riscstar.com>
To: andersson@kernel.org, konradybcio@kernel.org, robh@kernel.org,
krzk+dt@kernel.org, conor+dt@kernel.org
Cc: mani@kernel.org, krishna.chundru@oss.qualcomm.com,
dmitry.baryshkov@oss.qualcomm.com,
sushrut.trivedi@oss.qualcomm.com, umang.chheda@oss.qualcomm.com,
rosh@debian.org, jsandom@axon.com, daniel@riscstar.com,
mohd.anwar@oss.qualcomm.com, lorenzo.bianconi@oss.qualcomm.com,
devicetree@vger.kernel.org, linux-arm-msm@vger.kernel.org,
linux-kernel@vger.kernel.org,
Manivannan Sadhasivam <manivannan.sadhasivam@oss.qualcomm.com>,
Konrad Dybcio <konrad.dybcio@oss.qualcomm.com>,
Abel Vesa <abel.vesa@oss.qualcomm.com>
Subject: [PATCH v3 5/6] arm64: dts: qcom: qcs6490-thundercomm-minipc-g1iot: clean up PCI function nodes
Date: Wed, 2 Sep 2026 16:43:19 -0500 [thread overview]
Message-ID: <20260902214321.1721477-6-elder@riscstar.com> (raw)
In-Reply-To: <20260902214321.1721477-1-elder@riscstar.com>
The Thundercomm AI Mini PC G1 IoT devicetree source file defines a node
representing a TC956x chip which contains a PCIe switch and an embedded
endpoint that implements two PCIe functions.
The devicetree nodes erroneously include a "pci" device_type property
for the two PCIe functions. That property should only be used for a
PCI device "that implements a PCI bus". Remove this property for the
two function nodes.
In addition, only PCI bridge nodes should be named "pcie@" (or "pci@").
PCI endpoint nodes are typically named based on the functionality they
implement (e.g., "ethernet@"). In this case, the role of these PCI
functions is not (yet) specified, and furthermore they will be used
with PCI endpoint buses. Rename these to use "dev@", following the
convention used in of_pci_make_dev_node() for dynamically-created
devicetree nodes.
Finally, these nodes define #address-cells, #size-cells, and ranges
properties, which are not normally defined for PCIe endpoints. Remove
these properties as well; they can be added back once they are actually
needed/used.
Reviewed-by: Manivannan Sadhasivam <manivannan.sadhasivam@oss.qualcomm.com>
Reviewed-by: Konrad Dybcio <konrad.dybcio@oss.qualcomm.com>
Reviewed-by: Abel Vesa <abel.vesa@oss.qualcomm.com>
Fixes: 1cde54c54b83b ("arm64: dts: qcom: qcs6490: Add Thundercomm AI Mini PC G1 IoT")
Signed-off-by: Alex Elder <elder@riscstar.com>
---
.../dts/qcom/qcs6490-thundercomm-minipc-g1iot.dts | 12 ++----------
1 file changed, 2 insertions(+), 10 deletions(-)
diff --git a/arch/arm64/boot/dts/qcom/qcs6490-thundercomm-minipc-g1iot.dts b/arch/arm64/boot/dts/qcom/qcs6490-thundercomm-minipc-g1iot.dts
index 31bafa2cf51db..51b59a75c1e03 100644
--- a/arch/arm64/boot/dts/qcom/qcs6490-thundercomm-minipc-g1iot.dts
+++ b/arch/arm64/boot/dts/qcom/qcs6490-thundercomm-minipc-g1iot.dts
@@ -790,20 +790,12 @@ pcie@3,0 {
ranges;
bus-range = <0x5 0xff>;
- pcie@0,0 {
+ dev@0,0 {
reg = <0x50000 0x0 0x0 0x0 0x0>;
- #address-cells = <3>;
- #size-cells = <2>;
- device_type = "pci";
- ranges;
};
- pcie@0,1 {
+ dev@0,1 {
reg = <0x50100 0x0 0x0 0x0 0x0>;
- #address-cells = <3>;
- #size-cells = <2>;
- device_type = "pci";
- ranges;
};
};
};
--
2.53.0
next prev parent reply other threads:[~2026-09-02 21:43 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-02 21:43 [PATCH v3 0/6] arm64: dts: qcom: clean up PCI function nodes Alex Elder
2026-09-02 21:43 ` [PATCH v3 1/6] arm64: dts: qcom: qcs6490-rb3gen2: " Alex Elder
2026-09-02 21:43 ` [PATCH v3 2/6] arm64: dts: qcom: qcs6490-rb3gen2-industrial-mezzanine: " Alex Elder
2026-09-02 21:43 ` [PATCH v3 3/6] arm64: dts: qcom: lemans-evk-ifp-mezzanine: " Alex Elder
2026-09-02 21:43 ` [PATCH v3 4/6] arm64: dts: qcom: monaco-evk-ifp-mezzanine: " Alex Elder
2026-09-02 21:43 ` Alex Elder [this message]
2026-09-02 21:43 ` [PATCH v3 6/6] arm64: dts: qcom: qcs8550-rb5gen2: " Alex Elder
2026-09-03 17:20 ` [PATCH v3 0/6] arm64: dts: qcom: " Bjorn Andersson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260902214321.1721477-6-elder@riscstar.com \
--to=elder@riscstar.com \
--cc=abel.vesa@oss.qualcomm.com \
--cc=andersson@kernel.org \
--cc=conor+dt@kernel.org \
--cc=daniel@riscstar.com \
--cc=devicetree@vger.kernel.org \
--cc=dmitry.baryshkov@oss.qualcomm.com \
--cc=jsandom@axon.com \
--cc=konrad.dybcio@oss.qualcomm.com \
--cc=konradybcio@kernel.org \
--cc=krishna.chundru@oss.qualcomm.com \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=lorenzo.bianconi@oss.qualcomm.com \
--cc=mani@kernel.org \
--cc=manivannan.sadhasivam@oss.qualcomm.com \
--cc=mohd.anwar@oss.qualcomm.com \
--cc=robh@kernel.org \
--cc=rosh@debian.org \
--cc=sushrut.trivedi@oss.qualcomm.com \
--cc=umang.chheda@oss.qualcomm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox