From: sashiko-bot@kernel.org
To: "Colin Huang" <u8813345@gmail.com>
Cc: devicetree@vger.kernel.org, conor+dt@kernel.org, robh@kernel.org
Subject: Re: [PATCH v9 14/15] ARM: dts: aspeed: anacapa: Update EDSFF power status signals
Date: Wed, 30 Sep 2026 06:20:27 +0000 [thread overview]
Message-ID: <20260930062027.D26AF1F000FF@smtp.kernel.org> (raw)
In-Reply-To: <20260930-anacapa-devlop-phase-devicetree-v9-14-f08aa0d7182d@gmail.com>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Medium] dts: aspeed: anacapa: missing SGPIO line rename for EVT1
--
commit cde2dbf50bae37ad4a486fdf1cafec415093ffef
Author: Rex Fu <rex.fu.amd@gmail.com>
ARM: dts: aspeed: anacapa: Update EDSFF power status signals
The CPLD definition for the EDSFF power status signals has changed
from PG to FLT. Update the corresponding SGPIO line names to match
the CPLD definition.
> diff --git a/arch/arm/boot/dts/aspeed/aspeed-bmc-facebook-anacapa-evt2.dtsi b/arch/arm/boot/dts/aspeed/aspeed-bmc-facebook-anacapa-evt2.dtsi
> index 5c0d874fa24af..766aa26b6cea5 100644
> --- a/arch/arm/boot/dts/aspeed/aspeed-bmc-facebook-anacapa-evt2.dtsi
> +++ b/arch/arm/boot/dts/aspeed/aspeed-bmc-facebook-anacapa-evt2.dtsi
> @@ -370,7 +370,7 @@ &sgpiom0 {
> "L_PRSNT_EDSFF1_N", "",
> "R_PRSNT_EDSFF2_N", "",
> "R_PRSNT_EDSFF3_N", "",
> - "HPM_EDSFF_PG", "",
> + "EDSFF_BOOT_FLT", "",
[Severity: Medium]
Are we intentionally leaving the old "PG" naming scheme in EVT1 hardware?
If userspace daemons depend on the updated "FLT" SGPIO line names for EDSFF
power status monitoring, they might fail to find these lines on EVT1 hardware
and break power management or monitoring logic.
For example, arch/arm/boot/dts/aspeed/aspeed-bmc-facebook-anacapa-evt1.dtsi
still contains this legacy name under sgpiom0:
"HPM_EDSFF_PG", "",
Should this update be applied to the EVT1 devicetree as well?
> "", "",
> "", "FM_BMC_READY_PLD",
[ ... ]
> @@ -416,10 +416,10 @@ &sgpiom0 {
> "PDB_ALERT_R_N", "",
>
> /* L0-L7 line 176-191 */
> - "L_EDSFF0_PG", "",
> - "L_EDSFF1_PG", "",
> - "R_EDSFF2_PG", "",
> - "R_EDSFF3_PG", "",
> + "L_EDSFF0_FLT", "",
> + "L_EDSFF1_FLT", "",
> + "R_EDSFF2_FLT", "",
> + "R_EDSFF3_FLT", "",
[Severity: Medium]
Similarly, arch/arm/boot/dts/aspeed/aspeed-bmc-facebook-anacapa-evt1.dtsi
still contains these "PG" lines under sgpiom0:
"L_EDSFF0_PG", "", "L_EDSFF1_PG", "",
"R_EDSFF2_PG", "", "R_EDSFF3_PG", "",
Is EVT1 deprecated, or did it miss this SGPIO line rename?
> "HPM_CPLD_HEART_BIT", "",
> "RBB_CPLD_HEART_BIT", "",
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260930-anacapa-devlop-phase-devicetree-v9-0-f08aa0d7182d@gmail.com?part=14
next prev parent reply other threads:[~2026-09-30 6:20 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-30 6:10 [PATCH v9 00/15] ARM: dts: aspeed: anacapa: restructure devicetree for development-phase Colin Huang
2026-09-30 6:10 ` [PATCH v9 01/15] ARM: dts: aspeed: anacapa: Add EVT1 devicetree and point wrapper to it Colin Huang
2026-09-30 6:10 ` [PATCH v9 02/15] ARM: dts: aspeed: anacapa: Add EVT2 devicetree inheriting EVT1 Colin Huang
2026-09-30 6:10 ` [PATCH v9 03/15] ARM: dts: aspeed: anacapa: Add DVT devicetree inheriting EVT2 Colin Huang
2026-09-30 6:10 ` [PATCH v9 04/15] ARM: dts: aspeed: anacapa: Add additional EEPROM node for SCM Colin Huang
2026-09-30 6:10 ` [PATCH v9 05/15] ARM: dts: aspeed: anacapa: Add eeprom device node for NFC adaptor board Colin Huang
2026-09-30 6:10 ` [PATCH v9 06/15] ARM: dts: aspeed: anacapa: Align PDB fan GPIO numbering Colin Huang
2026-09-30 6:10 ` [PATCH v9 07/15] ARM: dts: aspeed: anacapa: Enable MCTP and FRU for NIC Colin Huang
2026-09-30 6:10 ` [PATCH v9 08/15] ARM: dts: aspeed: anacapa: evt2: Add shunt resistor values for HSC monitors Colin Huang
2026-09-30 6:10 ` [PATCH v9 09/15] ARM: dts: aspeed: anacapa: Add LPDB fuse monitor GPIO expander Colin Huang
2026-09-30 6:10 ` [PATCH v9 10/15] ARM: dts: aspeed: anacapa: Simplify leakage GPIO line names Colin Huang
2026-09-30 6:10 ` [PATCH v9 11/15] ARM: dts: aspeed: anacapa: Add SPI flash VCC supply Colin Huang
2026-09-30 6:10 ` [PATCH v9 12/15] ARM: dts: aspeed: anacapa: Add NCT7363 fan controllers Colin Huang
2026-09-30 6:10 ` [PATCH v9 13/15] ARM: dts: aspeed: anacapa: Remove LTC4287 power monitors Colin Huang
2026-09-30 6:10 ` [PATCH v9 14/15] ARM: dts: aspeed: anacapa: Update EDSFF power status signals Colin Huang
2026-09-30 6:20 ` sashiko-bot [this message]
2026-09-30 6:10 ` [PATCH v9 15/15] ARM: dts: aspeed: anacapa: Add E1.S FRU EEPROMs Colin Huang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260930062027.D26AF1F000FF@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=robh@kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
--cc=u8813345@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox