From: Matthias Brugger <matthias.bgg@gmail.com>
To: Allen-KH Cheng <allen-kh.cheng@mediatek.com>,
Rob Herring <robh+dt@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
Cc: Project_Global_Chrome_Upstream_Group@mediatek.com,
devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org, linux-mediatek@lists.infradead.org,
Chen-Yu Tsai <wenst@chromium.org>,
hsinyi@chromium.org,
Allen-kh Cheng <allen-kh.cheng@mediatek.corp-partner.google.com>
Subject: Re: [PATCH v13 0/1] Add basic node support for MediaTek MT8186 SoC
Date: Tue, 2 Aug 2022 13:15:56 +0200 [thread overview]
Message-ID: <3eb66813-14a9-8644-b2dd-588815a06079@gmail.com> (raw)
In-Reply-To: <20220802085152.31284-1-allen-kh.cheng@mediatek.com>
Hi Allen,
Below some notes for myself.
On 02/08/2022 10:51, Allen-KH Cheng wrote:
> From: Allen-kh Cheng <allen-kh.cheng@mediatek.corp-partner.google.com>
>
> MT8186 is a SoC based on 64bit ARMv8 architecture. It contains 6 CA55
> and 2 CA76 cores. MT8186 share many HW IP with MT65xx series. This
> patchset was tested on MT8186 evaluation board to shell.
>
> This series is based on tag: next-20220728, linux-next/master
> Since we have a another dts series of mt8195 [1] which is waiting for
> review from maintainers. I remove power domains controller node from
> this mt8186 series and will update in another patch.
>
> There are some corrections in mt8186 hardware bindings. We need to
> apply the below patches.
> https://patchwork.kernel.org/project/linux-mediatek/patch/20220725110702.11362-2-allen-kh.cheng@mediatek.com/
> https://patchwork.kernel.org/project/linux-mediatek/patch/20220725110702.11362-3-allen-kh.cheng@mediatek.com/
Both are already merged.
> https://patchwork.kernel.org/project/linux-mediatek/patch/20220720130604.14113-2-allen-kh.cheng@mediatek.com/
Acked but not yet merged.
> https://patchwork.kernel.org/project/linux-mediatek/patch/20220721014845.19044-2-allen-kh.cheng@mediatek.com/
We still have some discussions here.
Regards,
Matthias
>
> [1]
> https://patchwork.kernel.org/project/linux-mediatek/list/?series=663978
>
> changes since v12:
> - remove drive-strength fom i2c pins
> - use lowercase hex addresses in pinctrl node
> - correct clk order in xhci0
> - add clk26m for dma_ck
>
> changes since v11:
> - add #cooling-cells in cpu nodes
> - add pmu nodes for mt8186
> - change #interrupt-cells from 3 to 4
> - correct interrupts property in each nodes for 4 interrupt cells
> - remove power domains controller node
> - move #address-cells and #size-cells into mt8186.dts
> - remove unused ahb_cg clock in mmc0
> - add efuse node
> - add dsi node and remove dpi node
> - move i2c status position in mt8186-evb.dts
> - change i2c child nodee name in pio node to *-pins
> - change property from mediatek,drive-strength-adv to drive-strength-microamp in i2c child nodes of pio
> - change drive-strength value from MTK_DRIVE_4mA to 4 in i2c child nodes of pio
> - change i2c child nodes from pins-sda-sc1 to pins-bus
> - correct pintctrl clk names
>
> changes since v10:
> - remove merged PATCHes
> - add pmu nodes
> - add #cooling-cells
> - change #interrupt-cells number from 3 to 4
> - remove power domains controller node
> - move #address-cells/#size-cells into mt8186.dts from evb dts for i2c
> - move status = 'okay' position in i2cx
> - fix pinctrl patternproperties name in pio
> - add efuse node
> - fix dsi node
> - add #reset-cells in infracfg_ao: syscon
>
> changes since v9:
> - remove some merged PATCHs from series
> - reorder nodes in dts (cpu-map)
> - remove okay status in auxadc
> - remove unnecessary suffix node name for i2c
> - add pwm node
> - add dsi-phy node
> - add dpi node
>
> changes since v9:
> - add one space before equal sign of drive-strength-adv
> - corect compatible name for big cores (ca76)
> - use upper case of address in pinctrl
> - add pwrap node
> - add pwm node
>
> changes since v8:
> - change name from pins_bus to pins-sda-scl
> - correct email address
> - add capacity-dmips-mhz for each CPU
> - add ppi-partitions in gic node
> - change name to power-domain
> - remove status "okay" in scp node
> - update timer and pericfg compatible in series
>
> changes since v7:
> - add scp&auxadc node
>
> changes since v6:
> - remove unnecessary blank line
>
> changes since v5:
> - replace Mediatek a to MediaTek
> - use GPL-2.0-only OR BSD-2-Clause
>
> changes since v4:
> - correct driver clock of mt8186
> - add power domains controller and clock controllers
> - add pinctrl, usb host, spi and i2c nodes
> - add node status in mt8186-evb.dts
> - correct some dtbs_check warnings
>
> changes since v3:
> - remove serial, mmc and phy patch from series. (already merged)
> - remove mcusysoff node
> - move oscillator nodes at the head of dts
> - change name from usb-phy to t-phy
>
> changes since v2:
> - add soc {} in mt8186.dtsi
>
> changes since v1:
> - add dt-bindings: arm: Add compatible for MediaTek MT8186
>
> Allen-KH Cheng (1):
> arm64: dts: Add MediaTek MT8186 dts and evaluation board and Makefile
>
> arch/arm64/boot/dts/mediatek/Makefile | 1 +
> arch/arm64/boot/dts/mediatek/mt8186-evb.dts | 228 +++++
> arch/arm64/boot/dts/mediatek/mt8186.dtsi | 875 ++++++++++++++++++++
> 3 files changed, 1104 insertions(+)
> create mode 100644 arch/arm64/boot/dts/mediatek/mt8186-evb.dts
> create mode 100644 arch/arm64/boot/dts/mediatek/mt8186.dtsi
>
prev parent reply other threads:[~2022-08-02 11:16 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-08-02 8:51 [PATCH v13 0/1] Add basic node support for MediaTek MT8186 SoC Allen-KH Cheng
2022-08-02 8:51 ` [PATCH v13 1/1] arm64: dts: Add MediaTek MT8186 dts and evaluation board and Makefile Allen-KH Cheng
2022-08-08 14:26 ` Nícolas F. R. A. Prado
2022-08-02 11:15 ` Matthias Brugger [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3eb66813-14a9-8644-b2dd-588815a06079@gmail.com \
--to=matthias.bgg@gmail.com \
--cc=Project_Global_Chrome_Upstream_Group@mediatek.com \
--cc=allen-kh.cheng@mediatek.com \
--cc=allen-kh.cheng@mediatek.corp-partner.google.com \
--cc=devicetree@vger.kernel.org \
--cc=hsinyi@chromium.org \
--cc=krzysztof.kozlowski@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=robh+dt@kernel.org \
--cc=wenst@chromium.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox