Devicetree
 help / color / mirror / Atom feed
From: Vishnu Reddy <busanna.reddy@oss.qualcomm.com>
To: Dmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>
Cc: Vikash Garodia <vikash.garodia@oss.qualcomm.com>,
	Dikshita Agarwal <dikshita.agarwal@oss.qualcomm.com>,
	Abhinav Kumar <abhinav.kumar@linux.dev>,
	Bryan O'Donoghue <bod@kernel.org>,
	Mauro Carvalho Chehab <mchehab@kernel.org>,
	Joerg Roedel <joro@8bytes.org>, Will Deacon <will@kernel.org>,
	Robin Murphy <robin.murphy@arm.com>,
	Hans Verkuil <hverkuil@kernel.org>,
	Stefan Schmidt <stefan.schmidt@linaro.org>,
	Rob Herring <robh@kernel.org>,
	Krzysztof Kozlowski <krzk+dt@kernel.org>,
	Conor Dooley <conor+dt@kernel.org>,
	Stanimir Varbanov <stanimir.k.varbanov@gmail.com>,
	Bjorn Andersson <andersson@kernel.org>,
	Konrad Dybcio <konradybcio@kernel.org>,
	linux-kernel@vger.kernel.org, linux-media@vger.kernel.org,
	linux-arm-msm@vger.kernel.org, iommu@lists.linux.dev,
	devicetree@vger.kernel.org
Subject: Re: [PATCH v6 13/14] arm64: dts: qcom: glymur: Add iris video node
Date: Tue, 26 May 2026 16:52:06 +0530	[thread overview]
Message-ID: <63056c1d-a191-996e-b556-e636ca88637c@oss.qualcomm.com> (raw)
In-Reply-To: <fc2wiqf6vxob2lzp4fypekcdeuf7mcmn7znszzm5drmlkrdndh@ph5mgjaezdzo>


On 5/17/2026 11:41 PM, Dmitry Baryshkov wrote:
> On Fri, May 15, 2026 at 04:51:28PM +0530, Vishnu Reddy wrote:
>> Add iris video codec to glymur SoC, which comes with significantly
>> different powering up sequence than previous platforms, thus different
>> clocks and resets.
>>
>> Reviewed-by: Vikash Garodia <vikash.garodia@oss.qualcomm.com>
>> Signed-off-by: Vishnu Reddy <busanna.reddy@oss.qualcomm.com>
>> ---
>>  arch/arm64/boot/dts/qcom/glymur.dtsi | 118 +++++++++++++++++++++++++++++++++++
>>  1 file changed, 118 insertions(+)
>>
>> diff --git a/arch/arm64/boot/dts/qcom/glymur.dtsi b/arch/arm64/boot/dts/qcom/glymur.dtsi
>> index f23cf81ddb77..c47443174f97 100644
>> --- a/arch/arm64/boot/dts/qcom/glymur.dtsi
>> +++ b/arch/arm64/boot/dts/qcom/glymur.dtsi
>> @@ -13,6 +13,7 @@
>>  #include <dt-bindings/interconnect/qcom,glymur-rpmh.h>
>>  #include <dt-bindings/interrupt-controller/arm-gic.h>
>>  #include <dt-bindings/mailbox/qcom-ipcc.h>
>> +#include <dt-bindings/media/qcom,glymur-iris.h>
>>  #include <dt-bindings/phy/phy-qcom-qmp.h>
>>  #include <dt-bindings/power/qcom,rpmhpd.h>
>>  #include <dt-bindings/power/qcom-rpmpd.h>
>> @@ -4163,6 +4164,123 @@ usb_mp: usb@a400000 {
>>  			status = "disabled";
>>  		};
>>  
>> +		iris: video-codec@aa00000 {
>> +			compatible = "qcom,glymur-iris";
>> +			reg = <0x0 0xaa00000 0x0 0xf0000>;
>> +
>> +			clocks = <&gcc GCC_VIDEO_AXI0_CLK>,
>> +				 <&videocc VIDEO_CC_MVS0C_CLK>,
>> +				 <&videocc VIDEO_CC_MVS0_CLK>,
>> +				 <&gcc GCC_VIDEO_AXI0C_CLK>,
>> +				 <&videocc VIDEO_CC_MVS0C_FREERUN_CLK>,
>> +				 <&videocc VIDEO_CC_MVS0_FREERUN_CLK>,
>> +				 <&gcc GCC_VIDEO_AXI1_CLK>,
>> +				 <&videocc VIDEO_CC_MVS1_CLK>,
>> +				 <&videocc VIDEO_CC_MVS1_FREERUN_CLK>;
>> +			clock-names = "iface",
>> +				      "core",
>> +				      "vcodec0_core",
>> +				      "iface1",
>> +				      "core_freerun",
>> +				      "vcodec0_core_freerun",
>> +				      "iface2",
> I can only assume that it is "vcode0_iface", "core_iface" and
> "vcodec1_iface".

Agreed, the names are not self-explanatory.

Krzysztof, do you have any input on renaming these — It would break the legacy
naming convention followed on earlier platforms?

>> +				      "vcodec1_core",
>> +				      "vcodec1_core_freerun";
>> +
>> +			dma-coherent;
>> +

  reply	other threads:[~2026-05-26 11:22 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-05-15 11:21 [PATCH v6 00/14] media: iris: Add support for glymur platform Vishnu Reddy
2026-05-15 11:21 ` [PATCH v6 01/14] media: iris: Add iris vpu bus support Vishnu Reddy
2026-05-17 17:24   ` Dmitry Baryshkov
2026-05-15 11:21 ` [PATCH v6 02/14] iommu: Add iris-vpu-bus to iommu_buses Vishnu Reddy
2026-05-15 11:21 ` [PATCH v6 03/14] media: iris: Fix VM count passed to firmware Vishnu Reddy
2026-05-17 17:31   ` Dmitry Baryshkov
2026-05-15 11:21 ` [PATCH v6 04/14] dt-bindings: media: qcom,venus-common: Raise maxItems for clocks and power-domains Vishnu Reddy
2026-05-16  9:31   ` Krzysztof Kozlowski
2026-05-15 11:21 ` [PATCH v6 05/14] dt-bindings: media: qcom,glymur-iris: Add glymur video codec Vishnu Reddy
2026-05-15 11:21 ` [PATCH v6 06/14] media: iris: Add context bank hooks for platform specific initialization Vishnu Reddy
2026-05-17 17:35   ` Dmitry Baryshkov
2026-05-26 11:21     ` Vishnu Reddy
2026-05-28 10:59       ` Dmitry Baryshkov
2026-05-15 11:21 ` [PATCH v6 07/14] media: iris: Enable Secure PAS support with IOMMU managed by Linux Vishnu Reddy
2026-05-15 11:21 ` [PATCH v6 08/14] media: iris: Rename clock and power domain macros to use vcodec suffix Vishnu Reddy
2026-05-17 17:38   ` Dmitry Baryshkov
2026-05-15 11:21 ` [PATCH v6 09/14] media: iris: Use power domain type to look up pd_devs index Vishnu Reddy
2026-05-17 17:48   ` Dmitry Baryshkov
2026-05-15 11:21 ` [PATCH v6 10/14] media: iris: Add power sequence for Glymur Vishnu Reddy
2026-05-17 18:09   ` Dmitry Baryshkov
2026-05-26 11:21     ` Vishnu Reddy
2026-05-15 11:21 ` [PATCH v6 11/14] media: iris: Add support to select core for dual core platforms Vishnu Reddy
2026-05-17 18:10   ` Dmitry Baryshkov
2026-05-15 11:21 ` [PATCH v6 12/14] media: iris: Add platform data for glymur Vishnu Reddy
2026-05-15 11:21 ` [PATCH v6 13/14] arm64: dts: qcom: glymur: Add iris video node Vishnu Reddy
2026-05-17 18:11   ` Dmitry Baryshkov
2026-05-26 11:22     ` Vishnu Reddy [this message]
2026-05-15 11:21 ` [PATCH v6 14/14] arm64: dts: qcom: glymur-crd: Enable iris video codec node Vishnu Reddy
2026-05-17 18:12   ` Dmitry Baryshkov
2026-05-26 11:22     ` Vishnu Reddy
2026-05-28 10:54 ` [PATCH v6 00/14] media: iris: Add support for glymur platform Dmitry Baryshkov
2026-06-04  6:52   ` Vikash Garodia

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=63056c1d-a191-996e-b556-e636ca88637c@oss.qualcomm.com \
    --to=busanna.reddy@oss.qualcomm.com \
    --cc=abhinav.kumar@linux.dev \
    --cc=andersson@kernel.org \
    --cc=bod@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=dikshita.agarwal@oss.qualcomm.com \
    --cc=dmitry.baryshkov@oss.qualcomm.com \
    --cc=hverkuil@kernel.org \
    --cc=iommu@lists.linux.dev \
    --cc=joro@8bytes.org \
    --cc=konradybcio@kernel.org \
    --cc=krzk+dt@kernel.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=mchehab@kernel.org \
    --cc=robh@kernel.org \
    --cc=robin.murphy@arm.com \
    --cc=stanimir.k.varbanov@gmail.com \
    --cc=stefan.schmidt@linaro.org \
    --cc=vikash.garodia@oss.qualcomm.com \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox