Devicetree
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@intel.com>
To: "David Lechner (TI)" <dlechner@baylibre.com>
Cc: "Jonathan Cameron" <jic23@kernel.org>,
	"Nuno Sá" <nuno.sa@analog.com>,
	"Andy Shevchenko" <andy@kernel.org>,
	"Rob Herring" <robh@kernel.org>,
	"Krzysztof Kozlowski" <krzk+dt@kernel.org>,
	"Conor Dooley" <conor+dt@kernel.org>,
	"Chris Hall" <c-hall@ti.com>, "Patrick Edwards" <pedwards@ti.com>,
	"Kurt Borja" <kuurtb@gmail.com>,
	"Nguyen Minh Tien" <zizuzacker@gmail.com>,
	linux-iio@vger.kernel.org, devicetree@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 8/8] iio: adc: ti-ads112c14: add measurement channel support
Date: Sat, 11 Jul 2026 16:00:27 +0300	[thread overview]
Message-ID: <alI-a6nkGvXp6sDo@ashevche-desk.local> (raw)
In-Reply-To: <20260710-iio-adc-ti-ads122c14-v3-8-746d52cbf1d0@baylibre.com>

On Fri, Jul 10, 2026 at 05:50:41PM -0500, David Lechner (TI) wrote:
> Add support for parsing devicetree properties for measurement channels
> and doing direct reads on these.
> 
> There are quite a lot of conditions that have to be met for each
> measurement to be made, so quite a bit of state and algorithms are
> required to handle it.
> 
> Channels are created dynamically since the number of possibilities is
> unreasonably large.

...

> +struct ads112c14_measurement {
> +	const char *label;
> +	u32 vref_source;
> +	u8 iunit;
> +	u8 idac1_mag;
> +	u8 idac2_mag;
> +	u8 idac1_mux;
> +	u8 idac2_mux;

I would group this slightly differently:

	u8 idac1_mag;
	u8 idac2_mag;
	u8 idac1_mux;
	u8 idac2_mux;
	u8 iunit;

I haven't seen the code, but names suggest that most likely one would read
*[12] together or close enough, and less probably mixed with 'iunit' reads.
Current layout might lead to interesting code generation complications on
the unaligned-intolerable architectures.

> +	u8 iadc_count;
> +	u8 gain_val;
> +	u8 burnout;
> +	bool global_chop;
> +	bool bipolar;

> +	s64 scale_available[ARRAY_SIZE(ads112c14_pga_gains_x10)];

Also this can be moved upper, but I think it won't save any bytes in this
layout.

> +};

...

>  struct ads112c14_data {
>  	const struct ads112c14_chip_info *chip_info;
>  	struct regmap *regmap;
> +	u32 avdd_uV;
> +	u32 ext_ref_uV;

> +	bool refp_is_avdd;
> +	bool refn_is_gnd;

Here is a definite gain in memory if booleans combined with u8 below

> +	u32 ext_ref_ohms;
> +	struct ads112c14_measurement *measurements;
> +	u32 num_measurements;

Something like

	struct ads112c14_measurement *measurements;
	u32 num_measurements;
	u32 avdd_uV;
	u32 ext_ref_uV;
	u32 ext_ref_ohms;
	bool refp_is_avdd;
	bool refn_is_gnd;

? (Don't forget to run `pahole`.)

>  	u8 sys_mon_chan_short_gain_val;
>  	s64 sys_mon_chan_short_scale_available[ARRAY_SIZE(ads112c14_pga_gains_x10)];
>  };

...

> +	return regmap_update_bits(data->regmap, ADS112C14_REG_REFERENCE_CFG,
> +				  ADS112C14_REFERENCE_CFG_REFP_BUF_EN |
> +				  ADS112C14_REFERENCE_CFG_REFN_BUF_EN |
> +				  ADS112C14_REFERENCE_CFG_REF_VAL |
> +				  ADS112C14_REFERENCE_CFG_REF_SEL,
> +				  FIELD_PREP(ADS112C14_REFERENCE_CFG_REFP_BUF_EN,
> +					     refp_buf_en) |
> +				  FIELD_PREP(ADS112C14_REFERENCE_CFG_REFN_BUF_EN,
> +					     refn_buf_en) |
> +				  FIELD_PREP(ADS112C14_REFERENCE_CFG_REF_VAL,
> +					     ref_val) |
> +				  FIELD_PREP(ADS112C14_REFERENCE_CFG_REF_SEL,
> +					     ref_sel));

Personally I would go over 80 here.

				  FIELD_PREP(ADS112C14_REFERENCE_CFG_REFP_BUF_EN, refp_buf_en) |
				  FIELD_PREP(ADS112C14_REFERENCE_CFG_REFN_BUF_EN, refn_buf_en) |
				  FIELD_PREP(ADS112C14_REFERENCE_CFG_REF_VAL, ref_val) |
				  FIELD_PREP(ADS112C14_REFERENCE_CFG_REF_SEL, ref_sel));

All are less than 100.

> +}

...

> +	/* measurement channels */
> +	if (chan->channel < ADS112C14_SYS_MON_CHANNEL_BASE) {
> +		struct ads112c14_measurement *measurement;
> +
> +		measurement = &data->measurements[chan->scan_index];

> +

I would drop this blank line. It's naturally looking to have them coupled.

> +		if (!measurement->label)
> +			return -EINVAL;
> +
> +		return sysfs_emit(label, "%s\n", measurement->label);
> +	}

...

> +			if (pair[0] <= 100000 && (measurement->iadc_count == 1 || pair[1] <= 100000)) {

100 * (NANO / MICRO)

in the similar way how you done elsewhere in the code.

> +				/*
> +				 * If both values are 100uA or less, then we can
> +				 * use IUNIT = 1uA for better precision.
> +				 */
> +				ret = ads112c14_populate_idac_mag(pair[0],
> +								  &measurement->idac1_mag);
> +				if (ret)
> +					return ret;
> +
> +				if (measurement->iadc_count > 1) {
> +					ret = ads112c14_populate_idac_mag(pair[1],
> +									  &measurement->idac2_mag);
> +					if (ret)
> +						return ret;
> +				}
> +			} else {
> +				/*
> +				 * Otherwise, IUINT is 10uA (flag set) and so
> +				 * IxMAG is 1/10 of the actual current.
> +				 */
> +				measurement->iunit = 1;
> +
> +				ret = ads112c14_populate_idac_mag(pair[0] / 10,
> +								  &measurement->idac1_mag);
> +				if (ret)
> +					return ret;
> +
> +				if (measurement->iadc_count > 1) {
> +					ret = ads112c14_populate_idac_mag(pair[1] / 10,
> +									  &measurement->idac2_mag);
> +					if (ret)
> +						return ret;
> +				}
> +			}
> +		}

-- 
With Best Regards,
Andy Shevchenko



      parent reply	other threads:[~2026-07-11 13:00 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-10 22:50 [PATCH v3 0/8] iio: adc: new ti-ads112c14 driver David Lechner
2026-07-10 22:50 ` [PATCH v3 1/8] dt-bindings: iio: adc: Add reference-sources property David Lechner
2026-07-10 22:50 ` [PATCH v3 2/8] dt-bindings: iio: adc: Add excitation current sources properties David Lechner
2026-07-10 22:50 ` [PATCH v3 3/8] dt-bindings: iio: adc: Add burn-out current properties David Lechner
2026-07-10 22:50 ` [PATCH v3 4/8] dt-bindings: iio: adc: add input-chopping property David Lechner (TI)
2026-07-10 22:50 ` [PATCH v3 5/8] dt-bindings: iio: adc: add ti,ads122c14 David Lechner (TI)
2026-07-10 22:59   ` sashiko-bot
2026-07-10 23:12   ` David Lechner
2026-07-10 22:50 ` [PATCH v3 6/8] iio: adc: add ti-ads112c14 driver David Lechner (TI)
2026-07-10 23:00   ` sashiko-bot
2026-07-12  9:42   ` Andy Shevchenko
2026-07-10 22:50 ` [PATCH v3 7/8] iio: adc: ti-ads112c14: implement gain on internal short SYS_MON channel David Lechner (TI)
2026-07-10 23:04   ` sashiko-bot
2026-07-11  9:11   ` Andy Shevchenko
2026-07-10 22:50 ` [PATCH v3 8/8] iio: adc: ti-ads112c14: add measurement channel support David Lechner (TI)
2026-07-10 23:08   ` sashiko-bot
2026-07-11 13:00   ` Andy Shevchenko [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alI-a6nkGvXp6sDo@ashevche-desk.local \
    --to=andriy.shevchenko@intel.com \
    --cc=andy@kernel.org \
    --cc=c-hall@ti.com \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=dlechner@baylibre.com \
    --cc=jic23@kernel.org \
    --cc=krzk+dt@kernel.org \
    --cc=kuurtb@gmail.com \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nuno.sa@analog.com \
    --cc=pedwards@ti.com \
    --cc=robh@kernel.org \
    --cc=zizuzacker@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox