Devicetree
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@intel.com>
To: Ariana Lazar <ariana.lazar@microchip.com>
Cc: "Jonathan Cameron" <jic23@kernel.org>,
	"David Lechner" <dlechner@baylibre.com>,
	"Nuno Sá" <nuno.sa@analog.com>,
	"Andy Shevchenko" <andy@kernel.org>,
	"Rob Herring" <robh@kernel.org>,
	"Krzysztof Kozlowski" <krzk+dt@kernel.org>,
	"Conor Dooley" <conor+dt@kernel.org>,
	linux-kernel@vger.kernel.org, linux-iio@vger.kernel.org,
	devicetree@vger.kernel.org, sashiko-bot@kernel.org,
	stable@vger.kernel.org,
	"Joshua Crofts" <joshua.crofts1@gmail.com>
Subject: Re: [PATCH v6 00/11] Refactor Microchip MCP47FEB02 I2C driver in separate modules to add support for MCP48FEB02 SPI driver
Date: Wed, 16 Sep 2026 18:26:07 +0300	[thread overview]
Message-ID: <aqq1Dxeu7njVPI6R@ashevche-desk.local> (raw)
In-Reply-To: <20260916-mcp47feb02_refactor-v6-0-285464651f89@microchip.com>

On Wed, Sep 16, 2026 at 05:16:26PM +0300, Ariana Lazar wrote:
> Refactor I2C driver implementation into separate modules in order to add
> support for SPI MCP48FxBy1/2/4/8 DAC family on top of the I2C
> implementation. The I2C and SPI devices have the same memory map and
> supported functionalities.
> 
> Signed-off-by: Ariana Lazar <ariana.lazar@microchip.com>
> ---
> Changes in v6:
> - use field_get() in Gain, Vref and Power-Down registers channel formulas
> - rebase from 7.2 to 7.3-rc1
> - add fixes tags and Cc stable in the commit messages
> - add numeric constants in front of time defines for better readability
> - replaced dev_err() with dev_warn_probe() for missing label
> - if match data is not found at probe, return -ENODATA and a suitable
>     error message
> - Link to v5: https://lore.kernel.org/r/20260909-mcp47feb02_refactor-v5-0-8b67bcab93d1@microchip.com

My main comment against this version is the usage of Reported-by + Closes +
Fixes versus Suggested-by. Note, some of the changes doesn't look like a fix,
such as a typo in the comment, I dunno if Reported + Closes (no Fixes) is
legitimate approach there.

-- 
With Best Regards,
Andy Shevchenko



  parent reply	other threads:[~2026-09-16 15:26 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-16 14:16 [PATCH v6 00/11] Refactor Microchip MCP47FEB02 I2C driver in separate modules to add support for MCP48FEB02 SPI driver Ariana Lazar
2026-09-16 14:16 ` [PATCH v6 01/11] iio: dac: mcp47feb02: initialize dac_data field in channel data struct at probe Ariana Lazar
2026-09-16 14:16 ` [PATCH v6 02/11] iio: dac: mcp47feb02: Fix gain field initialization for active channels Ariana Lazar
2026-09-16 14:29   ` sashiko-bot
2026-09-16 14:16 ` [PATCH v6 03/11] iio: dac: mcp47feb02: use field_get() instead of custom dynamic macros Ariana Lazar
2026-09-16 15:22   ` Andy Shevchenko
2026-09-16 14:16 ` [PATCH v6 04/11] iio: dac: mcp47feb02: Return len when disabling EEPROM store Ariana Lazar
2026-09-16 14:16 ` [PATCH v6 05/11] iio: dac: mcp47feb02: Increase EEPROM Programming Write Cycle Time Ariana Lazar
2026-09-16 14:16 ` [PATCH v6 06/11] iio: dac: mcp47feb02: Avoid unjustified probe error on missing label Ariana Lazar
2026-09-16 14:29   ` sashiko-bot
2026-09-16 14:16 ` [PATCH v6 07/11] iio: dac: mcp47feb02: correct typo from a comment Ariana Lazar
2026-09-16 15:49   ` Joshua Crofts
2026-09-16 14:16 ` [PATCH v6 08/11] iio: dac: mcp47feb02: rename channel mask and value macros Ariana Lazar
2026-09-17  0:53   ` Jonathan Cameron
2026-09-16 14:16 ` [PATCH v6 09/11] iio: dac: mcp47feb02: refactor MCP47FEB02 I2C driver into two modules Ariana Lazar
2026-09-16 14:16 ` [PATCH v6 10/11] dt-bindings: iio: dac: add support for MCP48FEB02 SPI Ariana Lazar
2026-09-16 14:16 ` [PATCH v6 11/11] iio: dac: add support for Microchip MCP48FEB02 Ariana Lazar
2026-09-16 15:26 ` Andy Shevchenko [this message]
2026-09-17  0:55   ` [PATCH v6 00/11] Refactor Microchip MCP47FEB02 I2C driver in separate modules to add support for MCP48FEB02 SPI driver Jonathan Cameron

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aqq1Dxeu7njVPI6R@ashevche-desk.local \
    --to=andriy.shevchenko@intel.com \
    --cc=andy@kernel.org \
    --cc=ariana.lazar@microchip.com \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=dlechner@baylibre.com \
    --cc=jic23@kernel.org \
    --cc=joshua.crofts1@gmail.com \
    --cc=krzk+dt@kernel.org \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nuno.sa@analog.com \
    --cc=robh@kernel.org \
    --cc=sashiko-bot@kernel.org \
    --cc=stable@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox