Linux Documentation
 help / color / mirror / Atom feed
From: Lubomir Rintel <lkundrak@v3.sk>
To: Jonathan Corbet <corbet@lwn.net>
Cc: Maen Suleiman <maen@marvell.com>,
	Lior Amsalem <alior@marvell.com>,
	Thomas Petazzoni <thomas.petazzoni@free-electrons.com>,
	Andrew Lunn <andrew@lunn.ch>, Nicolas Pitre <nico@fluxnic.net>,
	Eric Miao <eric.y.miao@gmail.com>,
	linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/5] docs: arm: marvell: turn the automatic links into labels
Date: Sat, 30 Jan 2021 15:06:52 +0100	[thread overview]
Message-ID: <20210130140652.GA190173@demiurge.local> (raw)
In-Reply-To: <87tuqzwa0j.fsf@meer.lwn.net>

On Fri, Jan 29, 2021 at 05:20:28PM -0700, Jonathan Corbet wrote:
> Lubomir Rintel <lkundrak@v3.sk> writes:
> 
> > Lines ending with obscenely long URLs at the end don't look good.
> >
> > Even if these links are not that long at this point, they will be when
> > replaced with an archive link in a subsequent patch -- let's prepare for
> > that.
> >
> > Signed-off-by: Lubomir Rintel <lkundrak@v3.sk>
> > ---
> >  Documentation/arm/marvel.rst | 209 ++++++++++++++++++++++++-----------
> >  1 file changed, 143 insertions(+), 66 deletions(-)
> >
> > diff --git a/Documentation/arm/marvel.rst b/Documentation/arm/marvel.rst
> > index 16ab2eb085b86..716551f9b60a1 100644
> > --- a/Documentation/arm/marvel.rst
> > +++ b/Documentation/arm/marvel.rst
> > @@ -18,12 +18,12 @@ Orion family
> >          - 88F5181L
> >          - 88F5182
> >  
> > -               - Datasheet: http://www.embeddedarm.com/documentation/third-party/MV88F5182-datasheet.pdf
> > -               - Programmer's User Guide: http://www.embeddedarm.com/documentation/third-party/MV88F5182-opensource-manual.pdf
> > -               - User Manual: http://www.embeddedarm.com/documentation/third-party/MV88F5182-usermanual.pdf
> > +               - Datasheet: `MV88F5182-datasheet.pdf`_
> > +               - Programmer's User Guide: `MV88F5182-opensource-manual.pdf`_
> > +               - User Manual: `MV88F5182-usermanual.pdf`_
> >          - 88F5281
> >  
> > -               - Datasheet: http://www.ocmodshop.com/images/reviews/networking/qnap_ts409u/marvel_88f5281_data_sheet.pdf
> > +               - Datasheet: `marvel_88f5281_data_sheet.pdf`_
> >          - 88F6183
> >    Core:
> >  	Feroceon 88fr331 (88f51xx) or 88fr531-vd (88f52xx) ARMv5 compatible
> > @@ -32,37 +32,42 @@ Orion family
> >    Linux kernel plat directory:
> >  	arch/arm/plat-orion
> >  
> > +.. _MV88F5182-datasheet.pdf: http://www.embeddedarm.com/documentation/third-party/MV88F5182-datasheet.pdf
> > +.. _MV88F5182-opensource-manual.pdf: http://www.embeddedarm.com/documentation/third-party/MV88F5182-opensource-manual.pdf
> > +.. _MV88F5182-usermanual.pdf: http://www.embeddedarm.com/documentation/third-party/MV88F5182-usermanual.pdf
> > +.. _marvel_88f5281_data_sheet.pdf: http://www.ocmodshop.com/images/reviews/networking/qnap_ts409u/marvel_88f5281_data_sheet.pdf
> 
> So I see what you're trying to do, but this has the effect of prettying
> up the processed docs at the expense of making the plain-text version
> harder to read.  Somebody who wants to find one of these datasheets from
> the plain-text version has to skip further down in the file, hoping that
> they pick out the right one among a set of long, similar URLs.
> Honestly, I think we may be better off leaving them as they are.
> Failing that, the right thing to do is to keep the lines defining the
> URL labels right next to where they are referenced.
> 
> See what I'm getting at?

Yes. I've been considering the same, but concluded it's a still a better
idea to move the full URLs below because

1.) at this point the links are broken anyway and the basename is the
    only valuable part of the URL when looking for an actual document;
    and the basename stays in place
2.) the archive.org links that replace them in another patch are waaaay too
    long even for very large displays

However, even though I think this is perhaps marginally better, either
way works for me. Thus, unless you change your mind about it, I'll follow
up with a v2 that drops this patch and replaces the links in place.

Thank you
Lubo

> 
> Thanks,
> 
> jon

  reply	other threads:[~2021-01-30 14:08 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-01-29 18:39 [PATCH 0/5] docs: arm: Improvements to Marvell SoC documentation Lubomir Rintel
2021-01-29 18:39 ` [PATCH 1/5] docs: arm: marvell: turn the automatic links into labels Lubomir Rintel
2021-01-30  0:20   ` Jonathan Corbet
2021-01-30 14:06     ` Lubomir Rintel [this message]
2021-01-29 18:39 ` [PATCH 2/5] docs: arm: marvell: drop some dead links Lubomir Rintel
2021-01-29 18:39 ` [PATCH 3/5] docs: arm: marvell: replace stale links with archive links Lubomir Rintel
2021-01-29 18:39 ` [PATCH 4/5] docs: arm: marvell: clarify some unimportant Armada 6x0 details Lubomir Rintel
2021-01-29 18:39 ` [PATCH 5/5] docs: arm: marvell: rename marvel.rst to marvell.rst Lubomir Rintel

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210130140652.GA190173@demiurge.local \
    --to=lkundrak@v3.sk \
    --cc=alior@marvell.com \
    --cc=andrew@lunn.ch \
    --cc=corbet@lwn.net \
    --cc=eric.y.miao@gmail.com \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maen@marvell.com \
    --cc=nico@fluxnic.net \
    --cc=thomas.petazzoni@free-electrons.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox