Linux Documentation
 help / color / mirror / Atom feed
From: Andrew Morton <akpm@linux-foundation.org>
To: Jianyue Wu <wujianyue000@gmail.com>
Cc: Chris Li <chrisl@kernel.org>, Kairui Song <kasong@tencent.com>,
	Kemeng Shi <shikemeng@huaweicloud.com>,
	Nhat Pham <nphamcs@gmail.com>, Baoquan He <bhe@redhat.com>,
	Barry Song <baohua@kernel.org>,
	Youngjun Park <youngjun.park@lge.com>,
	Qi Zheng <qi.zheng@linux.dev>,
	Shakeel Butt <shakeel.butt@linux.dev>,
	Axel Rasmussen <axelrasmussen@google.com>,
	Yuanchu Xie <yuanchu@google.com>, Wei Xu <weixugc@google.com>,
	Johannes Weiner <hannes@cmpxchg.org>,
	David Hildenbrand <david@kernel.org>,
	Michal Hocko <mhocko@kernel.org>,
	Lorenzo Stoakes <ljs@kernel.org>,
	"Liam R. Howlett" <liam@infradead.org>,
	Vlastimil Babka <vbabka@kernel.org>,
	Mike Rapoport <rppt@kernel.org>,
	Suren Baghdasaryan <surenb@google.com>,
	Michal Hocko <mhocko@suse.com>, Hugh Dickins <hughd@google.com>,
	Baolin Wang <baolin.wang@linux.alibaba.com>,
	Jonathan Corbet <corbet@lwn.net>,
	Shuah Khan <skhan@linuxfoundation.org>,
	linux-mm@kvack.org, linux-kernel@vger.kernel.org,
	linux-doc@vger.kernel.org
Subject: Re: [PATCH v4 0/3] mm: clean up folio LRU and swap declarations
Date: Sun, 28 Jun 2026 14:03:22 -0700	[thread overview]
Message-ID: <20260628140322.c3ce1a7428d6c6d021069e7d@linux-foundation.org> (raw)
In-Reply-To: <20260603-ch-swap-series-plus-folio-lru-cleanup-v4-0-ce0219e100d9@gmail.com>

On Wed, 03 Jun 2026 21:05:31 +0800 Jianyue Wu <wujianyue000@gmail.com> wrote:

> The previous version moved the folio LRU helpers out of mm/swap.c in
> one step. Based on review feedback from Johannes, Baoquan and Barry,
> split the cleanup into smaller steps:
> 
>   - move the page-cluster sysctl next to swap readahead in mm/swap_state.c
>   - rename mm/swap.c to mm/folio_lru.c after the swap-specific bits move out
>   - move MM-internal reclaim declarations out of include/linux/swap.h
> 
> After this series, swap cache and swap-in readahead stay in mm/swap_state.c,
> folio LRU helpers live in mm/folio_lru.c, and MM-internal reclaim/workingset
> declarations move from include/linux/swap.h to mm/internal.h (public LRU
> helpers used outside mm/ remain in swap.h).
> 
> The first patch handles the swap-specific page-cluster state before the
> file rename, so the rename commit only carries folio LRU code. The last
> patch keeps the LRU helpers used outside mm/ in include/linux/swap.h and
> moves the internal reclaim/workingset declarations to mm/internal.h.
> 
> This series is based on Christoph Hellwig's swap_ops series, which
> moves swap I/O dispatch behind swap_ops and leaves mm/swap.c with less
> swap-specific state. That makes the folio LRU cleanup more natural to
> split out on top.

Patchset looks good and is well-reviewed (thanks, all).

But it's a little old and Sashiko was unable to apply it and I'm seeing
at least one (probably trivial) reject.

So please can you refresh, retest, gather the ack/review tags and
resend?

Thanks.

  parent reply	other threads:[~2026-06-28 21:03 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-06-03 13:05 [PATCH v4 0/3] mm: clean up folio LRU and swap declarations Jianyue Wu
2026-06-03 13:05 ` [PATCH v4 1/3] mm/swap: colocate page-cluster sysctl with swap readahead Jianyue Wu
2026-06-03 13:10   ` David Hildenbrand (Arm)
2026-06-03 14:55   ` Johannes Weiner
2026-06-04  0:14   ` Barry Song
2026-06-03 13:05 ` [PATCH v4 2/3] mm: rename swap.c to folio_lru.c Jianyue Wu
2026-06-03 13:09   ` David Hildenbrand (Arm)
2026-06-03 14:59   ` Johannes Weiner
2026-06-03 13:05 ` [PATCH v4 3/3] mm: move reclaim-internal declarations out of swap.h Jianyue Wu
2026-06-03 15:00   ` Johannes Weiner
2026-06-28 21:03 ` Andrew Morton [this message]
2026-06-29  0:20   ` [PATCH v4 0/3] mm: clean up folio LRU and swap declarations Jianyue Wu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260628140322.c3ce1a7428d6c6d021069e7d@linux-foundation.org \
    --to=akpm@linux-foundation.org \
    --cc=axelrasmussen@google.com \
    --cc=baohua@kernel.org \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=bhe@redhat.com \
    --cc=chrisl@kernel.org \
    --cc=corbet@lwn.net \
    --cc=david@kernel.org \
    --cc=hannes@cmpxchg.org \
    --cc=hughd@google.com \
    --cc=kasong@tencent.com \
    --cc=liam@infradead.org \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=ljs@kernel.org \
    --cc=mhocko@kernel.org \
    --cc=mhocko@suse.com \
    --cc=nphamcs@gmail.com \
    --cc=qi.zheng@linux.dev \
    --cc=rppt@kernel.org \
    --cc=shakeel.butt@linux.dev \
    --cc=shikemeng@huaweicloud.com \
    --cc=skhan@linuxfoundation.org \
    --cc=surenb@google.com \
    --cc=vbabka@kernel.org \
    --cc=weixugc@google.com \
    --cc=wujianyue000@gmail.com \
    --cc=youngjun.park@lge.com \
    --cc=yuanchu@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox