From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-alma10-1.taild15c8.ts.net [100.103.45.18]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 0123857C70E; Tue, 8 Sep 2026 15:56:49 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=100.103.45.18 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1788883010; cv=none; b=O8BftewNg2WwCklNsdPZipr7gg6wy6Wixz+Hk6/VidvqcTrfD1JFMU6kgg5i0sFJnZ45TB3/cmyWTvePsSjGLvuL+W0jqgZV7w767FIXnPnJXTD1jUsUgIrMuqnBOzSf8f+t+mWgSa4iLHPvhMchGB+9oADGpfTV+Esh9QwIojo= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1788883010; c=relaxed/simple; bh=jqomfzAPcB/YsEZ5Zl+BQ8kUXgK69YV3ld/oKwVf5+g=; h=From:To:Cc:Subject:Date:Message-ID:MIME-Version; b=Imqg2Xs4zmiviULwA0wG2SnGILYsXtAqFxQQZOFimtt1YYSBodPZ30Np3uIzZ7UzoisBRNO7BA6UagE1rjUBvnBUuWhDYkfrWUk87q4e23NfZXrodveIQ6hMvNvQsOqJhgMdMhaYaR2mquq4V4n+X3MwZ6UKvCKT+KbT632F4Dw= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=dgzqAq0R; arc=none smtp.client-ip=100.103.45.18 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="dgzqAq0R" Received: by smtp.kernel.org (Postfix) with ESMTPSA id DE3E71F00A3D; Tue, 8 Sep 2026 15:56:43 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=kernel.org; s=k20260515; t=1788883008; bh=sRrd8HW6tVkZeGdEyEtiUpIMBkv6a/57SRsi9SBmBeE=; h=From:To:Cc:Subject:Date; b=dgzqAq0Rb4t3E65A90uWXQ8od7s2sZqu5HDBqaJYS739IKSVberiqznPYaCD46X76 hg7VF2iHl6HtZqNtYIGeMQKuNy1OcnIqdyV2Npj8y99of6jDpJGQaTtRm4sV8kXBrT wZ28xpm0TQ+y8vNp9XgYu7sReJxXI2Srrf7PXc5BJKRImATk8y4scer0CX2Wdk+Ygs 7fNnOlWi69n052qHTsAJcBEsosfaF/dO113v1vD1Hs/MR9HMYD7A5rHRuc+yLNe696 iYg6m/WbEHurdr6ucmTDEdR45Zi7/yEnJJZLhMeePTkWBjoDdJMaLi/3GdTwdzmT7J YMPEMq8UVBnJA== From: Pratyush Yadav To: Jonathan Corbet , Shuah Khan , Mike Rapoport , Pasha Tatashin , Pratyush Yadav , Alexander Graf , Andrew Morton , David Hildenbrand , Lorenzo Stoakes , "Liam R. Howlett" , Vlastimil Babka , Suren Baghdasaryan , Michal Hocko , Thomas Gleixner , Ingo Molnar , Borislav Petkov , Dave Hansen , "H. Peter Anvin" , Ard Biesheuvel , Ilias Apalodimas , Rob Herring , Saravana Kannan , Arnd Bergmann , Baoquan He Cc: x86@kernel.org, linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org, kexec@lists.infradead.org, linux-mm@kvack.org, linux-efi@vger.kernel.org, devicetree@vger.kernel.org, linux-arch@vger.kernel.org Subject: [PATCH v2 0/4] kho: rename "scratch" to "bootmem" Date: Tue, 8 Sep 2026 17:56:34 +0200 Message-ID: <20260908155639.2496551-1-pratyush@kernel.org> X-Mailer: git-send-email 2.55.0.979.g7e5102b832-goog Precedence: bulk X-Mailing-List: linux-doc@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Transfer-Encoding: 8bit From: "Pratyush Yadav (Google)" The term "KHO scratch" is vague and overloaded. It does not accurately describe what the memory is for. This was discussed previously at [0]. The conclusion was to rename "KHO scratch" to "KHO bootmem", since this is memory passed by the previous kernel for early boot allocations. In addition, memblock does not care about the provenance of the memory. It cares more about how it should use it. Use MEMBLOCK_KHO_NOPRSRV, instead of MEMBLOCK_KHO_SCRATCH, to describe this memory to memblock. This series does the renames. It also gets rid of a redundant Kconfig. While the diffstat is big and scary, most of the changes are mechanical. The most interesting functional change is in patch 4. This series touches a lot of files across a lot of trees. But since all of that is purely KHO-related code, I would like to collect ACKs from the maintainers and take it via the liveupdate tree. Ideally we should queue it in liveupdate/next early in the v7.4 cycle since it will cause a lot of conflicts with other patches throughout the KHO tree. [0] https://lore.kernel.org/kexec/agHGOxSnP_VraH1M@kernel.org/T/#u Changes in v2: - Rebase on latest liveupdate/next. Pratyush Yadav (Google) (4): memblock: get rid of CONFIG_MEMBLOCK_KHO_SCRATCH memblock: rename KHO_SCRATCH to KHO_NOPRSRV kho: rename KHO scratch to KHO bootmem kho: rename kho_scratch= commandline parameter to kho_bootmem= .../admin-guide/kernel-parameters.txt | 15 +- Documentation/admin-guide/mm/kho.rst | 18 +- Documentation/core-api/kho/index.rst | 36 +- arch/x86/boot/compressed/kaslr.c | 12 +- arch/x86/include/uapi/asm/setup_data.h | 4 +- arch/x86/kernel/e820.c | 2 +- arch/x86/kernel/kexec-bzimage64.c | 6 +- arch/x86/kernel/setup.c | 2 +- arch/x86/realmode/init.c | 2 +- drivers/firmware/efi/efi-init.c | 6 +- drivers/of/kexec.c | 16 +- include/asm-generic/kexec_handover.h | 2 +- include/linux/kexec.h | 2 +- include/linux/kexec_handover.h | 16 +- include/linux/memblock.h | 30 +- kernel/liveupdate/Kconfig | 1 - kernel/liveupdate/kexec_handover.c | 340 +++++++++--------- kernel/liveupdate/kexec_handover_debugfs.c | 24 +- kernel/liveupdate/kexec_handover_internal.h | 4 +- mm/Kconfig | 4 - mm/memblock.c | 56 +-- mm/mm_init.c | 6 +- tools/testing/memblock/internal.h | 2 +- 23 files changed, 302 insertions(+), 304 deletions(-) base-commit: c65687600ed075d237a204755d99ad538db34b47 -- 2.55.0.979.g7e5102b832-goog