From: "Leizhen (ThunderTown)" <thunder.leizhen@huawei.com>
To: Borislav Petkov <bp@alien8.de>
Cc: Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, <x86@kernel.org>,
"H . Peter Anvin" <hpa@zytor.com>, <linux-kernel@vger.kernel.org>,
Dave Young <dyoung@redhat.com>, Baoquan He <bhe@redhat.com>,
Vivek Goyal <vgoyal@redhat.com>,
Eric Biederman <ebiederm@xmission.com>,
<kexec@lists.infradead.org>,
Catalin Marinas <catalin.marinas@arm.com>,
Will Deacon <will@kernel.org>,
<linux-arm-kernel@lists.infradead.org>,
Rob Herring <robh+dt@kernel.org>,
Frank Rowand <frowand.list@gmail.com>,
<devicetree@vger.kernel.org>, "Jonathan Corbet" <corbet@lwn.net>,
<linux-doc@vger.kernel.org>, Randy Dunlap <rdunlap@infradead.org>,
Feng Zhou <zhoufeng.zf@bytedance.com>,
Kefeng Wang <wangkefeng.wang@huawei.com>,
Chen Zhou <dingguo.cz@antgroup.com>,
"John Donnelly" <John.p.donnelly@oracle.com>
Subject: Re: [PATCH v18 01/17] x86/setup: Move CRASH_ALIGN and CRASH_ADDR_{LOW|HIGH}_MAX to asm/kexec.h
Date: Thu, 23 Dec 2021 10:09:25 +0800 [thread overview]
Message-ID: <c7b8ed2f-7280-faf9-66e8-ad329dbc10f6@huawei.com> (raw)
In-Reply-To: <YcON5Y7DKitiQhHu@zn.tnic>
On 2021/12/23 4:43, Borislav Petkov wrote:
> On Wed, Dec 22, 2021 at 09:08:04PM +0800, Zhen Lei wrote:
>> From: Chen Zhou <chenzhou10@huawei.com>
>>
>> We want to make function reserve_crashkernel[_low](), which is implemented
> ^^
>
> Please use passive voice in your commit message: no "we" or "I", etc,
> and describe your changes in imperative mood.
My bad language habits. I've made this mistake several times.
>
> Also, pls read section "2) Describe your changes" in
> Documentation/process/submitting-patches.rst for more details.
>
> Bottom line is: personal pronouns are ambiguous in text, especially with
> so many parties/companies/etc developing the kernel so let's avoid them
> please.
OK, I'll check the description of the other patches.
>
>> by X86, available to other architectures. It references macro CRASH_ALIGN
>
> "x86"
OK
>
>> and will be moved to public crash_core.c. But the defined values of
>> CRASH_ALIGN may be different in different architectures. So moving the
>> definition of CRASH_ALIGN to asm/kexec.h is a good choice.
>>
>> The reason for moving CRASH_ADDR_{LOW|HIGH}_MAX is the same as above.
>
> This commit message needs to say something along the lines of:
>
> "Move CRASH_ALIGN and ... to the arch-specific header in preparation
> of making reserve_crashkernel[_low]() generic, used by other
> architectures."
OK, I will use this one, thanks.
By the way, patch 0004-0006 were written based on your suggestion. Can you
take a moment to review it? I think I forgot to add "Suggested-by".
>
> or so.
>
next prev parent reply other threads:[~2021-12-23 2:09 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-12-22 13:08 [PATCH v18 00/17] support reserving crashkernel above 4G on arm64 kdump Zhen Lei
2021-12-22 13:08 ` [PATCH v18 01/17] x86/setup: Move CRASH_ALIGN and CRASH_ADDR_{LOW|HIGH}_MAX to asm/kexec.h Zhen Lei
2021-12-22 20:43 ` Borislav Petkov
2021-12-23 2:09 ` Leizhen (ThunderTown) [this message]
2021-12-22 13:08 ` [PATCH v18 02/17] x86/setup: Move xen_pv_domain() check and insert_resource() to setup_arch() Zhen Lei
2021-12-23 17:26 ` Borislav Petkov
2021-12-24 6:36 ` Leizhen (ThunderTown)
2021-12-25 1:53 ` Leizhen (ThunderTown)
2021-12-25 10:16 ` Leizhen (ThunderTown)
2022-01-07 8:13 ` Leizhen (ThunderTown)
2022-01-07 13:09 ` Leizhen (ThunderTown)
2021-12-22 13:08 ` [PATCH v18 03/17] x86/setup: Adjust the range of codes separated by CONFIG_X86_64 Zhen Lei
2021-12-22 13:08 ` [PATCH v18 04/17] x86/setup: Add helper parse_crashkernel_in_order() Zhen Lei
2021-12-25 1:58 ` Leizhen (ThunderTown)
2021-12-22 13:08 ` [PATCH v18 05/17] x86/setup: Use parse_crashkernel_in_order() to make code logic clear Zhen Lei
2021-12-22 13:08 ` [PATCH v18 06/17] x86/setup: Update comments in reserve_crashkernel() Zhen Lei
2021-12-22 13:08 ` [PATCH v18 07/17] x86/setup: Eliminate a magic number " Zhen Lei
2021-12-22 13:08 ` [PATCH v18 08/17] x86/setup: Add build option ARCH_WANT_RESERVE_CRASH_KERNEL Zhen Lei
2021-12-22 13:08 ` [PATCH v18 09/17] x86/setup: Move reserve_crashkernel[_low]() into crash_core.c Zhen Lei
2021-12-22 13:08 ` [PATCH v18 10/17] kdump: Simplify the parameters of __parse_crashkernel() Zhen Lei
2021-12-22 13:08 ` [PATCH v18 11/17] kdump: Make parse_crashkernel_{high|low} static Zhen Lei
2021-12-22 13:08 ` [PATCH v18 12/17] kdump: Reduce unused parameters of parse_crashkernel_{high|low} Zhen Lei
2021-12-22 13:08 ` [PATCH v18 13/17] arm64: kdump: introduce some macros for crash kernel reservation Zhen Lei
2021-12-22 13:08 ` [PATCH v18 14/17] arm64: kdump: reimplement crashkernel=X Zhen Lei
2021-12-22 13:08 ` [PATCH v18 15/17] of: fdt: Aggregate the processing of "linux,usable-memory-range" Zhen Lei
2021-12-23 15:48 ` Dave Kleikamp
2021-12-24 1:03 ` Leizhen (ThunderTown)
2021-12-22 13:08 ` [PATCH v18 16/17] of: fdt: Add memory for devices by DT property "linux,usable-memory-range" Zhen Lei
2021-12-22 13:08 ` [PATCH v18 17/17] kdump: update Documentation about crashkernel Zhen Lei
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c7b8ed2f-7280-faf9-66e8-ad329dbc10f6@huawei.com \
--to=thunder.leizhen@huawei.com \
--cc=John.p.donnelly@oracle.com \
--cc=bhe@redhat.com \
--cc=bp@alien8.de \
--cc=catalin.marinas@arm.com \
--cc=corbet@lwn.net \
--cc=devicetree@vger.kernel.org \
--cc=dingguo.cz@antgroup.com \
--cc=dyoung@redhat.com \
--cc=ebiederm@xmission.com \
--cc=frowand.list@gmail.com \
--cc=hpa@zytor.com \
--cc=kexec@lists.infradead.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=rdunlap@infradead.org \
--cc=robh+dt@kernel.org \
--cc=tglx@linutronix.de \
--cc=vgoyal@redhat.com \
--cc=wangkefeng.wang@huawei.com \
--cc=will@kernel.org \
--cc=x86@kernel.org \
--cc=zhoufeng.zf@bytedance.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox