From: "Pandey, Radhey Shyam" <radheys@amd.com>
To: Shubhrajyoti Datta <shubhrajyoti.datta@amd.com>,
linux-edac@vger.kernel.org
Cc: git@amd.com, shubhrajyoti.datta@gmail.com,
Michal Simek <michal.simek@amd.com>,
Borislav Petkov <bp@alien8.de>, Tony Luck <tony.luck@intel.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 9/9] EDAC/versalnet: Use designated initializer for rpmsg_channel_info
Date: Fri, 31 Jul 2026 19:56:10 +0530 [thread overview]
Message-ID: <533c4d27-7156-43d5-821e-fa45160dfe21@amd.com> (raw)
In-Reply-To: <20260724171945.2812749-10-shubhrajyoti.datta@amd.com>
On 7/24/2026 10:49 PM, Shubhrajyoti Datta wrote:
> Replace field-by-field assignment of struct rpmsg_channel_info with a
> designated initializer. This also fixes the incorrect use of strscpy
> with strlen which could lead to silent truncation of the channel name.
>
> Fixes: d5fe2fec6c40 ("EDAC: Add a driver for the AMD Versal NET DDR controller")
> Signed-off-by: Shubhrajyoti Datta <shubhrajyoti.datta@amd.com>
> ---
>
> drivers/edac/versalnet_edac.c | 10 +++++-----
> 1 file changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/edac/versalnet_edac.c b/drivers/edac/versalnet_edac.c
> index ba295714d972..88b24eec4206 100644
> --- a/drivers/edac/versalnet_edac.c
> +++ b/drivers/edac/versalnet_edac.c
> @@ -720,14 +720,14 @@ MODULE_DEVICE_TABLE(rpmsg, amd_rpmsg_id_table);
>
> static int rpmsg_probe(struct rpmsg_device *rpdev)
> {
> - struct rpmsg_channel_info chinfo;
> struct mc_priv *pg;
> + struct rpmsg_channel_info chinfo = {
> + .src = RPMSG_ADDR_ANY,
> + .dst = rpdev->dst,
> + .name = "error_ipc",
> + };
Nit - have a define for channel name and use it in both places.
Also swap above declaration order to align with reverse xmas style.
>
> pg = (struct mc_priv *)amd_rpmsg_id_table[0].driver_data;
> - chinfo.src = RPMSG_ADDR_ANY;
> - chinfo.dst = rpdev->dst;
> - strscpy(chinfo.name, amd_rpmsg_id_table[0].name,
> - strlen(amd_rpmsg_id_table[0].name));
>
> pg->ept = rpmsg_create_ept(rpdev, rpmsg_cb, NULL, chinfo);
> if (!pg->ept)
prev parent reply other threads:[~2026-07-31 14:26 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-24 17:19 [PATCH 0/9] EDAC/versalnet: Fix error handling, teardown, and robustness Shubhrajyoti Datta
2026-07-24 17:19 ` [PATCH 1/9] EDAC/versalnet: Add NULL check for mci in handle_error() Shubhrajyoti Datta
2026-07-26 23:52 ` Borislav Petkov
2026-07-27 6:48 ` Pandey, Radhey Shyam
2026-07-28 1:37 ` Borislav Petkov
2026-07-28 18:27 ` Pandey, Radhey Shyam
2026-07-28 21:33 ` Borislav Petkov
2026-07-29 16:40 ` Pandey, Radhey Shyam
2026-07-30 15:03 ` Shubhrajyoti Datta
2026-07-24 17:19 ` [PATCH 2/9] EDAC/versalnet: Add NULL check for mci in remove_one_mc() Shubhrajyoti Datta
2026-07-27 8:11 ` Pandey, Radhey Shyam
2026-07-24 17:19 ` [PATCH 3/9] EDAC/versalnet: Move platform_set_drvdata() to mc_probe() Shubhrajyoti Datta
2026-07-27 8:35 ` Pandey, Radhey Shyam
2026-07-24 17:19 ` [PATCH 4/9] EDAC/versalnet: Fix device_register() error handling in init_one_mc() Shubhrajyoti Datta
2026-07-31 11:01 ` Pandey, Radhey Shyam
2026-07-24 17:19 ` [PATCH 5/9] EDAC/versalnet: Use dev_set_name() instead of sprintf with init_name Shubhrajyoti Datta
2026-07-31 11:22 ` Pandey, Radhey Shyam
2026-07-24 17:19 ` [PATCH 6/9] EDAC/versalnet: Initialize MCDI before RPMsg registration Shubhrajyoti Datta
2026-07-31 11:41 ` Pandey, Radhey Shyam
2026-07-24 17:19 ` [PATCH 7/9] EDAC/versalnet: Add bounds validation in rpmsg_cb() Shubhrajyoti Datta
2026-07-31 13:56 ` Pandey, Radhey Shyam
2026-07-24 17:19 ` [PATCH 8/9] EDAC/versalnet: Fix use-after-free in remove_one_mc() Shubhrajyoti Datta
2026-07-31 14:06 ` Pandey, Radhey Shyam
2026-07-24 17:19 ` [PATCH 9/9] EDAC/versalnet: Use designated initializer for rpmsg_channel_info Shubhrajyoti Datta
2026-07-31 14:26 ` Pandey, Radhey Shyam [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=533c4d27-7156-43d5-821e-fa45160dfe21@amd.com \
--to=radheys@amd.com \
--cc=bp@alien8.de \
--cc=git@amd.com \
--cc=linux-edac@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=michal.simek@amd.com \
--cc=shubhrajyoti.datta@amd.com \
--cc=shubhrajyoti.datta@gmail.com \
--cc=tony.luck@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox