From: Jani Nikula <jani.nikula@linux.intel.com>
To: Thomas Zimmermann <tzimmermann@suse.de>,
javierm@redhat.com, ardb@kernel.org, ilias.apalodimas@linaro.org,
maarten.lankhorst@linux.intel.com, mripard@kernel.org,
simona@ffwll.ch, airlied@gmail.com
Cc: dri-devel@lists.freedesktop.org, linux-efi@vger.kernel.org,
sashiko-reviews@lists.linux.dev,
Thomas Zimmermann <tzimmermann@suse.de>
Subject: Re: [PATCH v3 2/3] drm/edid: Add drm_edid_detect_panel_size()
Date: Wed, 02 Sep 2026 11:45:36 +0300 [thread overview]
Message-ID: <6d2a818833af42b5d9160b7e72822b2d2b4bf04a@intel.com> (raw)
In-Reply-To: <20260901082057.37617-3-tzimmermann@suse.de>
On Tue, 01 Sep 2026, Thomas Zimmermann <tzimmermann@suse.de> wrote:
> Add drm_edid_detect_panel_size() to extract the panel's preferred
> display resolution from a given EDID. Required for setting up DRM's
> panel orientation quirks in sysfb drivers.
>
> v3:
> - mention use case in documentation (Jani)
> - use is_detailed_timing_descriptor() (Jani)
> - rename helper to drm_edid_detect_panel_size()
> v2:
> - handle EDID without pixel timing descriptor (Sashiko)
> - fix checks for width and height pointers
>
> Signed-off-by: Thomas Zimmermann <tzimmermann@suse.de>
> Acked-by: Ard Biesheuvel <ardb@kernel.org>
> ---
> drivers/gpu/drm/drm_edid.c | 47 ++++++++++++++++++++++++++++++++++++++
> include/drm/drm_edid.h | 2 ++
> 2 files changed, 49 insertions(+)
>
> diff --git a/drivers/gpu/drm/drm_edid.c b/drivers/gpu/drm/drm_edid.c
> index 9990a836d0b6..d5d9e77dc91b 100644
> --- a/drivers/gpu/drm/drm_edid.c
> +++ b/drivers/gpu/drm/drm_edid.c
> @@ -7852,3 +7852,50 @@ bool drm_edid_is_digital(const struct drm_edid *drm_edid)
> drm_edid->edid->input & DRM_EDID_INPUT_DIGITAL;
> }
> EXPORT_SYMBOL(drm_edid_is_digital);
> +
> +/**
> + * drm_edid_detect_panel_size - Get a panel's size from EDID
> + * @drm_edid: EDID of the panel.
> + * @width: Returns the panel's width in pixels per scanline, if given
> + * @height: Returns the panel's height in scanlines, if given
> + *
> + * This function detects the preferred size of a panel from the given
> + * EDID. There is no such information stored in the EDID block directly,
> + * but the preferred mode often corresponds to the panel's native geometry.
> + *
> + * This helper should only be used during initialization before the
> + * connector is available. For regular use, retrieve the available display
> + * modes with the connector functions.
> + *
> + * Return: Zero on success, or a negative errno code otherwise.
> + */
> +int drm_edid_detect_panel_size(const struct drm_edid *drm_edid,
> + unsigned int *width, unsigned int *height)
> +{
> + const struct edid *edid = drm_edid->edid;
> + const struct detailed_timing *dt;
> + const struct detailed_pixel_timing *pt;
> +
> + /*
> + * Use display mode from the Preferred Timing Descriptor. For old
> + * and obscure displays, we might need better heuristics.
> + */
> +
> + if (edid->revision < 4 && !(edid->features & DRM_EDID_FEATURE_PREFERRED_TIMING))
> + return -EINVAL; /* no Preferred Timing Descriptor */
Okay, so I should've asked this n versions ago, but should that be
s/&&/||/ instead?
> +
> + dt = &edid->detailed_timings[0];
> +
> + if (!is_detailed_timing_descriptor(dt))
> + return -EINVAL;
> +
> + pt = &dt->data.pixel_data;
> +
> + if (width)
> + *width = (pt->hactive_hblank_hi & 0xf0) << 4 | pt->hactive_lo;
> + if (height)
> + *height = (pt->vactive_vblank_hi & 0xf0) << 4 | pt->vactive_lo;
> +
> + return 0;
> +}
> +EXPORT_SYMBOL(drm_edid_detect_panel_size);
> diff --git a/include/drm/drm_edid.h b/include/drm/drm_edid.h
> index 04f7a7f1f108..a2617aa34edf 100644
> --- a/include/drm/drm_edid.h
> +++ b/include/drm/drm_edid.h
> @@ -490,5 +490,7 @@ u32 drm_edid_get_panel_id(const struct drm_edid *drm_edid);
> bool drm_edid_match(const struct drm_edid *drm_edid,
> const struct drm_edid_ident *ident);
> bool drm_edid_has_quirk(struct drm_connector *connector, enum drm_edid_quirk quirk);
> +int drm_edid_detect_panel_size(const struct drm_edid *drm_edid,
> + unsigned int *width, unsigned int *height);
>
> #endif /* __DRM_EDID_H__ */
--
Jani Nikula, Intel
next prev parent reply other threads:[~2026-09-02 8:45 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-01 8:17 [PATCH v3 0/3] sysfb: Fix display output on Lenovo D330 (and others) Thomas Zimmermann
2026-09-01 8:17 ` [PATCH v3 1/3] firmware/sysfb: Remove rotation quirk for Lenovo D330 Thomas Zimmermann
2026-09-01 8:17 ` [PATCH v3 2/3] drm/edid: Add drm_edid_detect_panel_size() Thomas Zimmermann
2026-09-02 8:45 ` Jani Nikula [this message]
2026-09-02 11:06 ` Thomas Zimmermann
2026-09-01 8:17 ` [PATCH v3 3/3] drm/sysfb: Use preferred panel size for panel orientation quirks Thomas Zimmermann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6d2a818833af42b5d9160b7e72822b2d2b4bf04a@intel.com \
--to=jani.nikula@linux.intel.com \
--cc=airlied@gmail.com \
--cc=ardb@kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=ilias.apalodimas@linaro.org \
--cc=javierm@redhat.com \
--cc=linux-efi@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox