Linux EFI development
 help / color / mirror / Atom feed
 messages from 2026-09-21 12:23:06 to 2026-09-28 20:37:09 UTC [more...]

[PATCH v4] efivarfs: add nostatfs mount option to skip QueryVariableInfo()
 2026-09-28 20:34 UTC 

[PATCH v3] efivarfs: add nostatfs mount option to skip QueryVariableInfo()
 2026-09-28 20:21 UTC  (3+ messages)

[PATCH v2 00/10] efi/libstub: Avoid UTF-16 conversion busywork
 2026-09-28 10:27 UTC  (14+ messages)
` [PATCH v2 01/10] x86/boot: Drop pointless re-implementation of panic()

[PATCH] efistub/x86: Fix the size type of the Apple properties protocol
 2026-09-28  7:28 UTC 

[PATCH v5 0/5] LoongArch: add KHO support and selftests
 2026-09-28  2:30 UTC  (2+ messages)

[PATCH v2 0/9] arm64: ftrace: support CALL_OPS on kernels built with kCFI
 2026-09-27 14:05 UTC  (14+ messages)
` [PATCH v2 1/9] ftrace: Do not leak a module's empty page group
` [PATCH v2 2/9] ftrace: Let ftrace_call_adjust() reject a patch site
` [PATCH v2 3/9] scripts/sorttable: Make the arm64 before_func offset configurable
` [PATCH v2 4/9] compiler_types: Let notrace keep the function prefix NOPs
` [PATCH v2 5/9] arm64: ftrace: Make the CALL_OPS prefix layout configurable
` [PATCH v2 6/9] arm64: cfi: Use CONFIG_ARM64_FUNCTION_PREFIX_NOPS for the type hash offset
` [PATCH v2 7/9] arm64: ftrace: Support CALL_OPS on kernels built with kCFI
` [PATCH v2 8/9] arm64: ftrace: Use five prefix NOPs on ThinLTO kernels with BTI
` [PATCH v2 9/9] arm64: ftrace: Allow CALL_OPS on kCFI kernels built with Rust

[PATCH 00/16] arm64: DRTM, boot portion
 2026-09-26 18:45 UTC  (31+ messages)
` [PATCH 01/16] efi/libstub: Fix error unwind freeing fdt in allocate_new_fdt_and_exit_boot()
` [PATCH 02/16] efi/riscv: libstub: Don't set image_size in handle_kernel_image()
` [PATCH 03/16] efi/libstub: Free cmdline_ptr in efi_pe_entry
` [PATCH 04/16] vmlinux.lds: Move DATA_LE32() from arm64 to the common linker script
` [PATCH 05/16] efi/libstub: Add a general way to get symbols from the vmlinux into zboot
` [PATCH 06/16] arm64/efi: Use CONFIG_EFI_STUB_IMAGE_INFO for code_size
` [PATCH 07/16] efi/zboot: Lift efi_cache_sync_image() from efi_zboot_decompress()
` [PATCH 08/16] efi/libstub: Add generic arch callbacks for DRTM
` [PATCH 09/16] efi/libstub: Have efi_kaslr_relocate_kernel() handle extra_size
` [PATCH 10/16] efi: Add a __efi_data_handoff section annotation
` [PATCH 11/16] efi/libstub: Put the stub's writable data in unique sections for DRTM
` [PATCH 12/16] arm64: drtm: Add macro definitions for DEN0113
` [PATCH 13/16] arm64: drtm: Update the linker script for EFI_STUB_DRTM
` [PATCH 14/16] arm64: drtm: Add drtm_entry point to head.S
` [PATCH 15/16] arm64: drtm: Call UNPROTECT_MEMORY
` [PATCH 16/16] efi/arm64: Implement ARM64 DRTM in the stub

[PATCH 00/16] arm64: DRTM, boot portion
 2026-09-26 12:46 UTC 

[PATCH] security: Fix the Capsule-Loader with Lock Mutex, Verifications, factory default initialization and return
 2026-09-26 10:51 UTC 

[PATCH v2 6/9] arm64: cfi: Use CONFIG_ARM64_FUNCTION_PREFIX_NOPS for the type hash offset
 2026-09-26  9:33 UTC 

[PATCH v2 0/3] Move memory acceptance x86 arch code into EFI stub
 2026-09-25 11:59 UTC  (6+ messages)
` [PATCH v2 1/3] x86/tdx: Share tdx_panic() with the "
` [PATCH v2 2/3] x86/boot: Move unaccepted memory handling out of the decompressor
` [PATCH v2 3/3] x86/boot: Drop unused implementation of panic()

[efi:next] BUILD SUCCESS fa6266d3e33f631534e9f8097948780747aac04f
 2026-09-25 11:07 UTC 

[PATCH 0/3] Move memory acceptance x86 arch code into EFI stub
 2026-09-25  7:50 UTC  (11+ messages)

[PATCH v2] efivarfs: add nostatfs mount option to skip QueryVariableInfo()
 2026-09-25  6:14 UTC  (10+ messages)

[PATCH v4 00/22] kbuild: significantly speed up kernel builds
 2026-09-24 13:44 UTC  (25+ messages)
` [PATCH v4 01/22] kbuild: do not allocate .modinfo in vmlinux
` [PATCH v4 02/22] kallsyms: index symbols by token to speed up table compression
` [PATCH v4 03/22] kallsyms: output binary data to speed output and kallsyms assembly
` [PATCH v4 04/22] sorttable: parse nm output correctly
` [PATCH v4 05/22] kbuild: do not sort nm output where the order is irrelevant
` [PATCH v4 06/22] kbuild: only emit vmlinux relocations when required
` [PATCH v4 07/22] elf-parse: add section flags, symbol binding and mapping helpers
` [PATCH v4 08/22] kallsyms: reimplement mksysmap in C
` [PATCH v4 09/22] kbuild: calculate list, composite object state per object
` [PATCH v4 10/22] kbuild: implement and use depcheck to check dependency timestamps
` [PATCH v4 11/22] kbuild: move the toolchain checks into scripts/Kconfig.toolchain
` [PATCH v4 12/22] kbuild: avoid re-running compiler and linker probes
` [PATCH v4 13/22] modpost: cache section relocation mismatch state
` [PATCH v4 14/22] modpost: emit module descriptors as assembly
` [PATCH v4 15/22] kbuild: batch module finalisation
` [PATCH v4 16/22] objtool: do not hash DWARF relocations
` [PATCH v4 17/22] objtool: cache relocations, do less work, eliminate relocation hash
` [PATCH v4 18/22] objtool: size the instruction hash to the text
` [PATCH v4 19/22] objtool: decode instructions and resolve branch targets in parallel
` [PATCH v4 20/22] rust: make exports.o depend on the headers generated for it
` [PATCH v4 21/22] kbuild: build rust crates in parallel with the rest of the build
` [PATCH v4 22/22] kbuild: compress the kernel with pigz if available

[PATCH v2 0/6] arm64: distinguish HW PTE pointers from SW PTE value pointers
 2026-09-24 12:29 UTC  (11+ messages)
` [PATCH v2 1/6] arm64: use hw_pte_t for HW PTE pointers
` [PATCH v2 2/6] arm64: use hw_pte_val for HW PTE atomics
` [PATCH v2 3/6] arm64: use hw_pte_val for HW PTE loads and stores
` [PATCH v2 4/6] arm64: use hw_pte_t for fixmap HW PTEs
` [PATCH v2 5/6] arm64: use HW PTE accessors in early map_range()
` [PATCH v2 6/6] arm64: enable a distinct type for HW PTEs

[PATCH v5 0/9] mm/memory-failure: keep hardware-poisoned pages out of the next kexec
 2026-09-24 11:22 UTC  (23+ messages)
` [PATCH v5 7/9] drivers/base/memory: count inherited poisoned frames into the block
` [PATCH v5 8/9] mm/memory-failure: add hwpoison_boot_page() to flag an inherited frame

[PATCH] efi: capsule: publish capsule_pending after efi_reset_type
 2026-09-24 11:06 UTC  (2+ messages)

[PATCH v3 0/4] kho: rename "scratch" to "bootmem"
 2026-09-24  8:35 UTC  (10+ messages)
` [PATCH v3 1/4] memblock: get rid of CONFIG_MEMBLOCK_KHO_SCRATCH
` [PATCH v3 2/4] memblock: rename KHO_SCRATCH to KHO_NOPRSRV
` [PATCH v3 3/4] kho: rename KHO scratch to KHO bootmem
` [PATCH v3 4/4] kho: rename kho_scratch= commandline parameter to kho_bootmem=

[PATCH v5 0/9] Add RAS support for RISC-V architecture
 2026-09-24  7:37 UTC  (10+ messages)
` [PATCH v5 1/9] riscv: Define ioremap_cache for RISC-V
` [PATCH v5 2/9] riscv: Define arch_apei_get_mem_attribute "
` [PATCH v5 3/9] Introduce a new HEST notification type for RISC-V SSE events
` [PATCH v5 4/9] riscv: Add fixmap indices for GHES IRQ and SSE contexts
` [PATCH v5 5/9] riscv: Add functions to register ghes having SSE notification
` [PATCH v5 6/9] riscv: Add RISC-V entries in processor type and ISA strings
` [PATCH v5 7/9] riscv: Introduce HEST SSE notification handlers
` [PATCH v5 8/9] riscv: Select HAVE_ACPI_APEI required for RAS
` [PATCH v5 9/9] riscv: Enable APEI GHES driver in defconfig

[efi:bootloader-info] BUILD REGRESSION 9925e4ce78365f6378ae7facdc987b0b4ef67d37
 2026-09-22 19:25 UTC 

[PATCH v1 00/17] ACPI: Replace acpi_get_first_physical_node() with acpi_bus_get_primary_device()
 2026-09-22 16:59 UTC  (38+ messages)
` [PATCH v1 01/17] ACPI: bus: Use acpi/acpi_bus.h without CONFIG_ACPI
` [PATCH v1 02/17] ACPI: amba: Switch to use acpi_bus_get_primary_device()
` [PATCH v1 03/17] efi/dev-path-parser: "
` [PATCH v1 04/17] iommu/arm-smmu-v3: "
` [PATCH v1 05/17] platform/x86: yogabook: "
` [PATCH v1 06/17] platform/x86: serdev_helpers: "
` [PATCH v1 07/17] platform/x86: apple-gmux: "
` [PATCH v1 08/17] platform/x86: x86-android-tablets: Use acpi_bus_get_primary_device()
` [PATCH v1 09/17] thunderbolt: Switch to use acpi_bus_get_primary_device()
` [PATCH v1 10/17] ALSA: hda: cs35l41: "
` [PATCH v1 11/17] ALSA: hda: aw88399: "
` [PATCH v1 12/17] ALSA: hda: tas2781: "
` [PATCH v1 13/17] ASoC: amd: acp-es8336: "
` [PATCH v1 14/17] ASoC: amd: acp3x-es83xx: "
` [PATCH v1 15/17] ASoC: intel: boards: "
` [PATCH v1 16/17] ASoC: loongson: "
` [PATCH v1 17/17] ACPI: bus: Drop acpi_get_first_physical_node()

[PATCH v2 00/21] kbuild: significantly speed up kernel builds
 2026-09-22 13:09 UTC  (9+ messages)
` [PATCH v2 13/21] modpost: emit module descriptors as assembly

[PATCH v5 0/5] LoongArch: add KHO support and selftests
 2026-09-22 12:48 UTC  (7+ messages)
` [PATCH v5 1/5] efi: add a KHO configuration table channel
` [PATCH v5 2/5] liveupdate: synchronize EFI KHO channel at execution
` [PATCH v5 3/5] liveupdate: kho_block: include linux/mm.h for virt/phys translation

[PATCH v3 00/20] kbuild: significantly speed up kernel builds
 2026-09-22  9:43 UTC  (9+ messages)
` [PATCH v3 14/20] kbuild: batch module finalisation
` [PATCH v3 15/20] objtool: cache relocations, do less work, eliminate relocation hash
` [PATCH v3 17/20] objtool: decode instructions and resolve branch targets in parallel

[PATCH v3] rtc: efi: restore alarm support with runtime capability probe
 2026-09-21 19:14 UTC  (2+ messages)

[PATCH] efi/efi_test: bound capsule_count to what the int loop index can hold
 2026-09-21 13:33 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox