From mboxrd@z Thu Jan 1 00:00:00 1970 From: Tom Lendacky Subject: Re: [RFC Part1 PATCH v3 09/17] resource: Consolidate resource walking code Date: Thu, 17 Aug 2017 13:55:18 -0500 Message-ID: References: <20170724190757.11278-1-brijesh.singh@amd.com> <20170724190757.11278-10-brijesh.singh@amd.com> <20170728152342.GB11564@nazgul.tnic> Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <20170728152342.GB11564-K5JNixvcfoxupOikMc4+xw@public.gmane.org> Content-Language: en-US Sender: linux-efi-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org To: Borislav Petkov , Brijesh Singh Cc: linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, x86-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org, linux-efi-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, linuxppc-dev-uLR06cmDAlY/bJ5BZ2RsiQ@public.gmane.org, kvm-u79uwXL29TY76Z2rM5mHXA@public.gmane.org, Thomas Gleixner , Ingo Molnar , "H . Peter Anvin" , Andy Lutomirski , Tony Luck , Piotr Luc , Fenghua Yu , Lu Baolu , Reza Arbab , David Howells , Matt Fleming , "Kirill A . Shutemov" , Laura Abbott , Ard Biesheuvel , Andrew Morton , Eric Biederman , Benjamin List-Id: linux-efi@vger.kernel.org On 7/28/2017 10:23 AM, Borislav Petkov wrote: > On Mon, Jul 24, 2017 at 02:07:49PM -0500, Brijesh Singh wrote: >> From: Tom Lendacky >> >> The walk_iomem_res_desc(), walk_system_ram_res() and walk_system_ram_range() >> functions each have much of the same code. Create a new function that >> consolidates the common code from these functions in one place to reduce >> the amount of duplicated code. >> >> Signed-off-by: Tom Lendacky >> Signed-off-by: Brijesh Singh >> --- >> kernel/resource.c | 53 ++++++++++++++++++++++++++--------------------------- >> 1 file changed, 26 insertions(+), 27 deletions(-) >> >> diff --git a/kernel/resource.c b/kernel/resource.c >> index 9b5f044..7b20b3e 100644 >> --- a/kernel/resource.c >> +++ b/kernel/resource.c >> @@ -397,9 +397,30 @@ static int find_next_iomem_res(struct resource *res, unsigned long desc, >> res->start = p->start; >> if (res->end > p->end) >> res->end = p->end; >> + res->desc = p->desc; >> return 0; > > I must be going blind: where are we using that res->desc? I think that was left-over from the initial consolidation work I was doing. I'll remove it. > >> +static int __walk_iomem_res_desc(struct resource *res, unsigned long desc, >> + bool first_level_children_only, > > Btw, that variable name is insanely long. I know, but I'm maintaining consistency with the name that was already present vs. changing it. > > The rest looks ok to me, thanks for the cleanup! Thanks, Tom >