From: Guennadi Liakhovetski <g.liakhovetski@gmx.de>
To: Tomi Valkeinen <tomi.valkeinen@nokia.com>
Cc: "linux-sh@vger.kernel.org" <linux-sh@vger.kernel.org>,
Magnus Damm <magnus.damm@gmail.com>,
"linux-fbdev@vger.kernel.org" <linux-fbdev@vger.kernel.org>,
"linux-omap@vger.kernel.org" <linux-omap@vger.kernel.org>,
"Syrjala Ville (Nokia-D/Helsinki)" <ville.syrjala@nokia.com>
Subject: Re: [PATCH 1/4] fbdev: add a MIPI DSI header
Date: Thu, 20 May 2010 11:03:45 +0000 [thread overview]
Message-ID: <Pine.LNX.4.64.1005201251350.26000@axis700.grange> (raw)
In-Reply-To: <1274344369.4246.28.camel@tubuntu.research.nokia.com>
On Thu, 20 May 2010, Tomi Valkeinen wrote:
> On Thu, 2010-05-20 at 10:07 +0200, ext Guennadi Liakhovetski wrote:
>
> > Yes, right, I should have said "they are related";) How about calling the
> > header mipi_display.h? This would then unite DSI, DCS, DBI and DPI?
> > Creating a separate header for each of these standards seems like an
> > overkill to me. We could then put MIPI CSI and CPI standards in an
> > include/media/mipi_camera.h. Not sure where to put various other MIPI
> > standards, I guess, we'll have to think about it as a need arises.
>
> mipi_display.h sounds good to me.
>
> > > Well, true, this is not a clear thing. MIPI DSI spec talks about "turn
> > > on peripheral command". But the numbers are DSI data types, according to
> > > the spec, and not all of them are commands.
> >
> > Ok, how about "telegram types" then?
>
> I wouldn't invent a new word for this =). The DSI spec talks about
> commands, data types and transactions, I think we should pick one of
> them.
>
> Perhaps this is already approaching nitpicking, but:
>
> As only some of the commands/datatypes/transactions are commands, I
> think that's not proper word. All of them have a data type number, and I
> guess they all are transactions. So "Turn On Peripheral Command" is a
> transaction, and its data type is 0x32.
Yes, transaction looks good to me.
> I guess if the enum is named, it should then be mipi_dsi_transaction.
>
> But then, which one of these would be more correct:
>
> dsi_send(enum mipi_dsi_transaction transaction)
> dsi_send(u8 datatype)
>
> As I said previously, I haven't seen any panel using custom datatypes,
> but I wouldn't be surprised if some panel does. In that sense I would go
> for using u8, and then perhaps leaving the enum unnamed.
>
> What do you think?
Yes, I'd use u8 too, because the specs define "transaction types" to take
6 bits and "DCS commands" to be 8-bit ints. But, you know, doesn't our
case fall under case (b) of Chapter 5 "Typedefs" of CodingStyle?:) I mean,
wouldn't it make sense to create two typedefs for these to add some
type-safety? In fact, transaction types cannot be user-defined /
proprietary, right? So, for that an enum would work. It's only DCS
commands that allow extensions. But making transaction type an enum and
command a typedef would be ugly, and making a typedef for an enum is
frowned upon too...
> > As others voted for unnamed enums, how about using them?
>
> Sounds good.
>
> > Concerning omap2 display drivers, AFAICS the only thing we want to change
> > there is to switch them too to using the common header and telegram type
>
> Yep, I think that's the only change for now.
>
> > and command names? So far I don't see a need for a generic MIPI (display)
> > subsystem in the kernel with an own bus type, API etc. We could of course
> > create a simpe bus with callbacks for sending short and long packets and
> > reading data back, but do we really need it ATM?
>
> This is something I've been thinking about for some time. I even made
> some prototypes for it, but I didn't have time to go forward with it.
>
> It would of course be nice to use the same panel driver on different
> boards, so I think this is definitely something to think about in the
> future.
But you only need specific panel drivers if you want to support their
proprietary commands? Otherwise you only need a set of parameters -
timeing requirements etc. - which you can perfectly just pass in platform
data?
Thanks
Guennadi
---
Guennadi Liakhovetski, Ph.D.
Freelance Open-Source Software Developer
http://www.open-technology.de/
next prev parent reply other threads:[~2010-05-20 11:03 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-05-07 9:07 [PATCH 0/4] MIPI DSI support for SH-mobile, common header, switch Guennadi Liakhovetski
2010-05-07 9:07 ` [PATCH 1/4] fbdev: add a MIPI DSI header Guennadi Liakhovetski
2010-05-19 4:42 ` Damian
2010-05-19 7:49 ` Tomi Valkeinen
2010-05-19 8:08 ` Guennadi Liakhovetski
2010-05-19 8:21 ` Tomi Valkeinen
2010-05-19 14:27 ` Ville Syrjälä
2010-05-19 15:00 ` Paul Mundt
2010-05-19 15:39 ` Ville Syrjälä
2010-05-20 8:07 ` Guennadi Liakhovetski
2010-05-20 8:32 ` Tomi Valkeinen
2010-05-20 8:54 ` Felipe Balbi
2010-05-20 9:02 ` Guennadi Liakhovetski
2010-05-20 11:03 ` Guennadi Liakhovetski [this message]
2010-05-20 14:20 ` Tomi Valkeinen
2010-05-07 9:07 ` [PATCH 2/4] sh-mobile: add support for displays, connected over the Guennadi Liakhovetski
2010-05-19 4:43 ` [PATCH 2/4] sh-mobile: add support for displays, connected over Damian
2010-05-07 9:07 ` [PATCH 3/4] ARM: add framebuffer support for ap4evb Guennadi Liakhovetski
2010-05-07 14:45 ` [PATCH 3/4 v2] " Guennadi Liakhovetski
2010-05-10 0:11 ` Kuninori Morimoto
2010-05-10 6:12 ` Guennadi Liakhovetski
2010-05-10 9:37 ` Kuninori Morimoto
2010-05-19 4:36 ` Damian
2010-05-19 4:47 ` [PATCH 3/4] " Damian
2010-05-07 9:07 ` [PATCH 4/4] video: switch OMAP LCD MIPI driver to use the common Guennadi Liakhovetski
2010-05-07 10:05 ` [PATCH 2.5/4] ARM: add LCDC and MIPI DSI-Tx clock definitions to Guennadi Liakhovetski
2010-05-07 10:49 ` [PATCH 1.5/4] sh: add a YUV422 output data format, that is also Guennadi Liakhovetski
2010-05-19 4:44 ` Damian
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Pine.LNX.4.64.1005201251350.26000@axis700.grange \
--to=g.liakhovetski@gmx.de \
--cc=linux-fbdev@vger.kernel.org \
--cc=linux-omap@vger.kernel.org \
--cc=linux-sh@vger.kernel.org \
--cc=magnus.damm@gmail.com \
--cc=tomi.valkeinen@nokia.com \
--cc=ville.syrjala@nokia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox