From: Guennadi Liakhovetski <g.liakhovetski@gmx.de>
To: Hans Verkuil <hverkuil@xs4all.nl>
Cc: Rob Herring <robherring2@gmail.com>,
Linux Media Mailing List <linux-media@vger.kernel.org>,
linux-sh@vger.kernel.org, devicetree-discuss@lists.ozlabs.org,
Mark Brown <broonie@opensource.wolfsonmicro.com>,
Magnus Damm <magnus.damm@gmail.com>,
Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
Sylwester Nawrocki <sylvester.nawrocki@gmail.com>,
linux-fbdev@vger.kernel.org, dri-devel@lists.freedesktop.org,
Steffen Trumtrar <s.trumtrar@pengutronix.de>,
Robert Schwebel <r.schwebel@pengutronix.de>,
Philipp Zabel <pza@pengutronix.de>
Subject: Re: [PATCH 04/14] media: add V4L2 DT binding documentation
Date: Fri, 05 Oct 2012 11:37:43 +0000 [thread overview]
Message-ID: <Pine.LNX.4.64.1210051335390.13761@axis700.grange> (raw)
In-Reply-To: <201210051331.18586.hverkuil@xs4all.nl>
On Fri, 5 Oct 2012, Hans Verkuil wrote:
> On Fri October 5 2012 11:43:27 Guennadi Liakhovetski wrote:
> > On Wed, 3 Oct 2012, Rob Herring wrote:
> >
> > > On 10/02/2012 09:33 AM, Guennadi Liakhovetski wrote:
> > > > Hi Rob
> > > >
> > > > On Tue, 2 Oct 2012, Rob Herring wrote:
> > > >
> > > >> On 09/27/2012 09:07 AM, Guennadi Liakhovetski wrote:
[snip]
> > > >>> +Optional link properties:
> > > >>> +- remote: phandle to the other endpoint link DT node.
> > > >>
> > > >> This name is a little vague. Perhaps "endpoint" would be better.
> > > >
> > > > "endpoint" can also refer to something local like in USB case. Maybe
> > > > rather the description of the "remote" property should be improved?
> > >
> > > remote-endpoint?
> >
> > Sorry, I really don't want to pull in yet another term here. We've got
> > ports and links already, now you're proposing to also use "endpoind."
> > Until now everyone was happy with "remote," any more opinions on this?
>
> Actually, when I was reviewing the patch series today I got confused as
> well by 'remote'. What about 'remote-link'?
Yes, I was thinking about this one too, it looks a bit clumsy, but it does
make it clearer, what is meant.
> And v4l2_of_get_remote() can be renamed to v4l2_of_get_remote_link() which
> I think is a lot clearer.
>
> The text can be improved as well since this:
>
> - remote: phandle to the other endpoint link DT node.
>
> is a bit vague. How about:
>
> - remote-link: phandle to the remote end of this link.
Looks good to me.
Thanks
Guennadi
---
Guennadi Liakhovetski, Ph.D.
Freelance Open-Source Software Developer
http://www.open-technology.de/
prev parent reply other threads:[~2012-10-05 11:37 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <1348754853-28619-1-git-send-email-g.liakhovetski@gmx.de>
[not found] ` <1348754853-28619-5-git-send-email-g.liakhovetski@gmx.de>
[not found] ` <506AF706.3090003@gmail.com>
[not found] ` <Pine.LNX.4.64.1210021626220.15778@axis700.grange>
[not found] ` <506CA5F7.3060807@gmail.com>
2012-10-05 9:43 ` [PATCH 04/14] media: add V4L2 DT binding documentation Guennadi Liakhovetski
2012-10-05 11:31 ` Hans Verkuil
2012-10-05 11:37 ` Guennadi Liakhovetski [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Pine.LNX.4.64.1210051335390.13761@axis700.grange \
--to=g.liakhovetski@gmx.de \
--cc=broonie@opensource.wolfsonmicro.com \
--cc=devicetree-discuss@lists.ozlabs.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=hverkuil@xs4all.nl \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-fbdev@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-sh@vger.kernel.org \
--cc=magnus.damm@gmail.com \
--cc=pza@pengutronix.de \
--cc=r.schwebel@pengutronix.de \
--cc=robherring2@gmail.com \
--cc=s.trumtrar@pengutronix.de \
--cc=sylvester.nawrocki@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox