From mboxrd@z Thu Jan 1 00:00:00 1970 From: Johannes Weiner Subject: Re: [PATCH 03/10] vmscan: simplify shrink_inactive_list() Date: Sat, 17 Apr 2010 00:54:05 +0200 Message-ID: <20100416225405.GF20640@cmpxchg.org> References: <1271352103-2280-1-git-send-email-mel@csn.ul.ie> <1271352103-2280-4-git-send-email-mel@csn.ul.ie> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: linux-mm@kvack.org, linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org, Chris Mason , Dave Chinner , KOSAKI Motohiro , Andi Kleen To: Mel Gorman Return-path: Content-Disposition: inline In-Reply-To: <1271352103-2280-4-git-send-email-mel@csn.ul.ie> Sender: owner-linux-mm@kvack.org List-Id: linux-fsdevel.vger.kernel.org On Thu, Apr 15, 2010 at 06:21:36PM +0100, Mel Gorman wrote: > From: KOSAKI Motohiro > > Now, max_scan of shrink_inactive_list() is always passed less than > SWAP_CLUSTER_MAX. then, we can remove scanning pages loop in it. > This patch also help stack diet. > > detail > - remove "while (nr_scanned < max_scan)" loop > - remove nr_freed (now, we use nr_reclaimed directly) > - remove nr_scan (now, we use nr_scanned directly) > - rename max_scan to nr_to_scan > - pass nr_to_scan into isolate_pages() directly instead > using SWAP_CLUSTER_MAX > > Signed-off-by: KOSAKI Motohiro Reviewed-by: Johannes Weiner -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: email@kvack.org