From: Dave Chinner <david@fromorbit.com>
To: Sage Weil <sage@newdream.net>
Cc: Christoph Hellwig <hch@infradead.org>,
linux-fsdevel@vger.kernel.org, viro@ZenIV.linux.org.uk,
ceph-devel@vger.kernel.org, rwheeler@redhat.com,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] vfs: add d_prune dentry operation
Date: Wed, 12 Oct 2011 08:56:49 +1100 [thread overview]
Message-ID: <20111011215649.GB3159@dastard> (raw)
In-Reply-To: <Pine.LNX.4.64.1110110838500.32350@cobra.newdream.net>
On Tue, Oct 11, 2011 at 08:39:24AM -0700, Sage Weil wrote:
> On Mon, 10 Oct 2011, Christoph Hellwig wrote:
> > On Mon, Oct 10, 2011 at 09:19:43AM -0700, Sage Weil wrote:
> > > Let me know if the below is clearer. The requirement is that ->d_prune be
> > > called prior to unhashing (and then destroying) a victim dentry. I'm a
> > > little worried about mixing that in with the lru helpers because it is
> > > only indirectly related to whether the dentry is on the LRU, and that may
> > > confuse people. A cleaned up opencoded patch is here:
> > >
> > > https://github.com/NewDreamNetwork/ceph-client/commit/784a6aa6dc7baf2069c40988d79130dba17c7068
> > >
> > > and the updated dentry_lru_prune() wrapper version is below.
> >
> > Long term what I really want is a helper for doing more of the real
> > removal in single place. This is one step towards it, and the series
> > from Dave is another.
>
> Ah, makes sense.
>
> Dave, is the revised patch more clear?
Yeah, I kind of understand what it is doing now, and the comments
will remind me when I start digging in this code again. Thanks.
Cheers,
Dave.
--
Dave Chinner
david@fromorbit.com
next prev parent reply other threads:[~2011-10-11 21:56 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-10-06 4:26 [PATCH] d_prune dentry_operation Sage Weil
2011-10-06 4:26 ` [PATCH] vfs: add d_prune dentry operation Sage Weil
2011-10-06 21:21 ` Christoph Hellwig
2011-10-06 22:20 ` Sage Weil
2011-10-09 13:21 ` Christoph Hellwig
2011-10-10 5:11 ` Dave Chinner
2011-10-10 11:23 ` Christoph Hellwig
2011-10-10 16:19 ` Sage Weil
2011-10-10 16:21 ` Christoph Hellwig
2011-10-11 15:39 ` Sage Weil
2011-10-11 21:56 ` Dave Chinner [this message]
2011-10-28 12:16 ` Christoph Hellwig
2011-10-28 17:02 ` Sage Weil
-- strict thread matches above, loose matches on Subject: below --
2011-07-08 21:10 Sage Weil
2011-07-26 23:24 ` Sage Weil
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20111011215649.GB3159@dastard \
--to=david@fromorbit.com \
--cc=ceph-devel@vger.kernel.org \
--cc=hch@infradead.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rwheeler@redhat.com \
--cc=sage@newdream.net \
--cc=viro@ZenIV.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox