From: "Darrick J. Wong" <djwong@kernel.org>
To: Ritesh Harjani <ritesh.list@gmail.com>
Cc: Matthew Wilcox <willy@infradead.org>,
linux-xfs@vger.kernel.org, linux-fsdevel@vger.kernel.org,
Dave Chinner <david@fromorbit.com>,
Brian Foster <bfoster@redhat.com>,
Christoph Hellwig <hch@infradead.org>,
Andreas Gruenbacher <agruenba@redhat.com>,
Ojaswin Mujoo <ojaswin@linux.ibm.com>,
Disha Goel <disgoel@linux.ibm.com>
Subject: Re: [PATCHv8 0/5] iomap: Add support for per-block dirty state to improve write performance
Date: Tue, 6 Jun 2023 08:16:46 -0700 [thread overview]
Message-ID: <20230606151646.GN1325469@frogsfrogsfrogs> (raw)
In-Reply-To: <87bkhskaoc.fsf@doe.com>
On Tue, Jun 06, 2023 at 06:30:35PM +0530, Ritesh Harjani wrote:
> Matthew Wilcox <willy@infradead.org> writes:
>
> > On Tue, Jun 06, 2023 at 05:13:47PM +0530, Ritesh Harjani (IBM) wrote:
> >> Hello All,
> >>
> >> Please find PATCHv8 which adds per-block dirty tracking to iomap.
> >> As discussed earlier this is required to improve write performance and reduce
> >> write amplification for cases where either blocksize is less than pagesize (such
> >> as Power platform with 64k pagesize) or when we have a large folio (such as xfs
> >> which currently supports large folio).
> >
> > You're moving too fast. Please, allow at least a few hours between
> > getting review comments and sending a new version.
> >
>
> Sorry about that. I felt those were mainly only mechanical conversion
> changes. Will keep in mind.
>
> >> v7 -> v8
> >> ==========
> >> 1. Renamed iomap_page -> iomap_folio & iop -> iof in Patch-1 itself.
> >
> > I don't think iomap_folio is the right name. Indeed, I did not believe
> > that iomap_page was the right name. As I said on #xfs recently ...
> >
> > <willy> i'm still not crazy about iomap_page as the name of that
> > data structure. and calling the variable 'iop' just seems doomed
> > to be trouble. how do people feel about either iomap_block_state or
> > folio_block_state ... or even just calling it block_state since it's
> > local to iomap/buffered-io.c
> > <willy> we'd then call the variable either ibs or fbs, both of which
> > have some collisions in the kernel, but none in filesystems
> > <dchinner> willy - sounds reasonable
>
> Both seems equally reasonable to me. If others are equally ok with both,
> then shall we go with iomap_block_state and ibs?
I've a slight preference for struct folio_block_state/folio_bs/fbs.
Or even struct iomap_folio_state/iofs/ifs.
IBS is an acronym for a rather uncomfortable medical condition... ;)
--D
> I see that as "iomap_block_state" which is local to iomap buffered-io
> layer to track per-block state within a folio and gets attached to
> folio->private.
>
> -ritesh
next prev parent reply other threads:[~2023-06-06 15:16 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-06-06 11:43 [PATCHv8 0/5] iomap: Add support for per-block dirty state to improve write performance Ritesh Harjani (IBM)
2023-06-06 11:43 ` [PATCHv8 1/5] iomap: Rename iomap_page to iomap_folio and others Ritesh Harjani (IBM)
2023-06-07 6:49 ` Christoph Hellwig
2023-06-07 10:28 ` Ritesh Harjani
2023-06-06 11:43 ` [PATCHv8 2/5] iomap: Renames and refactor iomap_folio state bitmap handling Ritesh Harjani (IBM)
2023-06-06 15:13 ` Darrick J. Wong
2023-06-07 6:50 ` Christoph Hellwig
2023-06-07 10:44 ` Ritesh Harjani
2023-06-07 13:29 ` Christoph Hellwig
2023-06-06 11:43 ` [PATCHv8 3/5] iomap: Refactor iomap_write_delalloc_punch() function out Ritesh Harjani (IBM)
2023-06-07 6:52 ` Christoph Hellwig
2023-06-07 10:55 ` Ritesh Harjani
2023-06-06 11:43 ` [PATCHv8 4/5] iomap: Allocate iof in ->write_begin() early Ritesh Harjani (IBM)
2023-06-07 6:53 ` Christoph Hellwig
2023-06-06 11:43 ` [PATCHv8 5/5] iomap: Add per-block dirty state tracking to improve performance Ritesh Harjani (IBM)
2023-06-06 15:06 ` Darrick J. Wong
2023-06-07 10:27 ` Ritesh Harjani
2023-06-07 7:04 ` Christoph Hellwig
2023-06-07 15:37 ` Ritesh Harjani
2023-06-08 5:33 ` Christoph Hellwig
2023-06-08 14:45 ` Darrick J. Wong
2023-06-06 12:37 ` [PATCHv8 0/5] iomap: Add support for per-block dirty state to improve write performance Matthew Wilcox
2023-06-06 13:00 ` Ritesh Harjani
2023-06-06 15:16 ` Darrick J. Wong [this message]
2023-06-07 6:54 ` Christoph Hellwig
2023-06-07 6:48 ` Christoph Hellwig
2023-06-07 10:22 ` Ritesh Harjani
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230606151646.GN1325469@frogsfrogsfrogs \
--to=djwong@kernel.org \
--cc=agruenba@redhat.com \
--cc=bfoster@redhat.com \
--cc=david@fromorbit.com \
--cc=disgoel@linux.ibm.com \
--cc=hch@infradead.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-xfs@vger.kernel.org \
--cc=ojaswin@linux.ibm.com \
--cc=ritesh.list@gmail.com \
--cc=willy@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox