From: Jan Kara <jack@suse.cz>
To: Eric Sandeen <sandeen@redhat.com>
Cc: linux-fsdevel@vger.kernel.org, Jan Kara <jack@suse.cz>,
Bill O'Donnell <billodo@redhat.com>
Subject: Re: [PATCH] isofs: convert isofs to use the new mount API
Date: Thu, 7 Mar 2024 13:42:25 +0100 [thread overview]
Message-ID: <20240307124225.gm2d4dkscbcg4kt2@quack3> (raw)
In-Reply-To: <f15910da-b39e-44ff-8a2f-df7ce8c52057@redhat.com>
Hi Eric!
Thanks for the conversion!
On Fri 01-03-24 16:56:41, Eric Sandeen wrote:
> -static int isofs_remount(struct super_block *sb, int *flags, char *data)
> +static int iso9660_reconfigure(struct fs_context *fc)
^^^ Why this renaming? Practically all the function have
isofs prefix, not iso9660 so I'd prefer to keep it. Similarly with other
vars defined below. If anything, I'd rename struct iso9660_options to
struct isofs_options...
> {
> - sync_filesystem(sb);
> - if (!(*flags & SB_RDONLY))
> + sync_filesystem(fc->root->d_sb);
> + if (!(fc->sb_flags & SB_RDONLY) & SB_RDONLY)
^^^ What's this about?
Otherwise the patch looks good to me!
Honza
--
Jan Kara <jack@suse.com>
SUSE Labs, CR
next prev parent reply other threads:[~2024-03-07 14:23 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-03-01 22:56 [PATCH] isofs: convert isofs to use the new mount API Eric Sandeen
2024-03-07 12:42 ` Jan Kara [this message]
2024-03-07 14:58 ` Eric Sandeen
2024-03-07 18:56 ` [PATCH V2] " Eric Sandeen
2024-03-13 18:03 ` Jan Kara
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20240307124225.gm2d4dkscbcg4kt2@quack3 \
--to=jack@suse.cz \
--cc=billodo@redhat.com \
--cc=linux-fsdevel@vger.kernel.org \
--cc=sandeen@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox