messages from 2024-08-13 21:22:24 to 2024-08-15 06:00:23 UTC [more...]
[PATCH v2 0/6] iomap: some minor non-critical fixes and improvements when block size < folio size
2024-08-15 6:00 UTC (20+ messages)
` [PATCH v2 1/6] iomap: correct the range of a partial dirty clear
` [PATCH v2 3/6] iomap: advance the ifs allocation if we have more than one blocks per folio
` [PATCH v2 4/6] iomap: correct the dirty length in page mkwrite
` [PATCH v2 5/6] iomap: don't mark blocks uptodate after partial zeroing
[PATCH 0/3] fs/file.c: optimize the critical section of
2024-08-15 3:45 UTC (6+ messages)
` [PATCH v5 0/3] fs/file.c: optimize the critical section of file_lock in
` [PATCH v5 1/3] fs/file.c: remove sanity_check and add likely/unlikely in alloc_fd()
[PATCH 0/2] mm: Add readahead support for IOCB_NOWAIT
2024-08-15 3:38 UTC (20+ messages)
` [PATCH 1/2] mm: Add memalloc_nowait_{save,restore}
[PATCH v2] autofs: add per dentry expire timeout
2024-08-15 3:33 UTC (4+ messages)
[ANNOUNCE] xfs-linux: for-next updated to 8d16762047c6
2024-08-15 3:11 UTC
[PATCH bpf-next 0/8] BPF follow ups to struct fd refactorings
2024-08-14 23:17 UTC (11+ messages)
` [PATCH bpf-next 1/8] bpf: convert __bpf_prog_get() to CLASS(fd, ...)
` [PATCH bpf-next 2/8] bpf: switch fdget_raw() uses to CLASS(fd_raw, ...)
` [PATCH bpf-next 3/8] bpf: factor out fetching bpf_map from FD and adding it to used_maps list
` [PATCH bpf-next 4/8] bpf: switch maps to CLASS(fd, ...)
` [PATCH bpf-next 5/8] bpf: trivial conversions for fdget()
` [PATCH bpf-next 6/8] bpf: more trivial fdget() conversions
` [PATCH bpf-next 7/8] security,bpf: constify struct path in bpf_token_create() LSM hook
` [PATCH bpf-next 8/8] bpf: convert bpf_token_create() to CLASS(fd, ...)
[PATCHES] [drm] file descriptor fixes
2024-08-14 22:15 UTC (4+ messages)
` [PATCH 1/4] new helper: drm_gem_prime_handle_to_dmabuf()
` [PATCH 2/4] amdgpu: fix a race in kfd_mem_export_dmabuf()
[ANNOUNCE] xfs-linux: for-next updated to 4813305c621d
2024-08-14 22:08 UTC (2+ messages)
[PATCH v4 00/16] fanotify: add pre-content hooks
2024-08-14 21:25 UTC (17+ messages)
` [PATCH v4 01/16] fanotify: don't skip extra event info if no info_mode is set
` [PATCH v4 02/16] fsnotify: introduce pre-content permission event
` [PATCH v4 03/16] fsnotify: generate pre-content permission event on open
` [PATCH v4 04/16] fanotify: introduce FAN_PRE_ACCESS permission event
` [PATCH v4 05/16] fanotify: introduce FAN_PRE_MODIFY "
` [PATCH v4 06/16] fanotify: pass optional file access range in pre-content event
` [PATCH v4 07/16] fanotify: rename a misnamed constant
` [PATCH v4 08/16] fanotify: report file range info with pre-content events
` [PATCH v4 09/16] fanotify: allow to set errno in FAN_DENY permission response
` [PATCH v4 10/16] fanotify: add a helper to check for pre content events
` [PATCH v4 11/16] fanotify: disable readahead if we have pre-content watches
` [PATCH v4 12/16] mm: don't allow huge faults for files with pre content watches
` [PATCH v4 13/16] fsnotify: generate pre-content permission event on page fault
` [PATCH v4 14/16] bcachefs: add pre-content fsnotify hook to fault
` [PATCH v4 15/16] gfs2: "
` [PATCH v4 16/16] xfs: add pre-content fsnotify hook for write faults
[RESEND PATCH v2] eventfd: introduce ratelimited wakeup for non-semaphore eventfd
2024-08-14 20:58 UTC (5+ messages)
Enquiry
2024-08-14 20:53 UTC
[RFC net-next 0/5] Suspend IRQs during preferred busy poll
2024-08-14 20:42 UTC (17+ messages)
[PATCH v2 00/25] netfs: Read/write improvements
2024-08-14 20:38 UTC (26+ messages)
` [PATCH v2 01/25] netfs, ceph: Partially revert "netfs: Replace PG_fscache by setting folio->private and marking dirty"
` [PATCH v2 02/25] cachefiles: Fix non-taking of sb_writers around set/removexattr
` [PATCH v2 03/25] netfs: Adjust labels in /proc/fs/netfs/stats
` [PATCH v2 04/25] netfs: Record contention stats for writeback lock
` [PATCH v2 05/25] netfs: Reduce number of conditional branches in netfs_perform_write()
` [PATCH v2 06/25] netfs, cifs: Move CIFS_INO_MODIFIED_ATTR to netfs_inode
` [PATCH v2 07/25] netfs: Move max_len/max_nr_segs from netfs_io_subrequest to netfs_io_stream
` [PATCH v2 08/25] netfs: Reserve netfs_sreq_source 0 as unset/unknown
` [PATCH v2 09/25] netfs: Remove NETFS_COPY_TO_CACHE
` [PATCH v2 10/25] netfs: Set the request work function upon allocation
` [PATCH v2 11/25] netfs: Use bh-disabling spinlocks for rreq->lock
` [PATCH v2 12/25] mm: Define struct folio_queue and ITER_FOLIOQ to handle a sequence of folios
` [PATCH v2 13/25] iov_iter: Provide copy_folio_from_iter()
` [PATCH v2 14/25] cifs: Provide the capability to extract from ITER_FOLIOQ to RDMA SGEs
` [PATCH v2 15/25] netfs: Use new folio_queue data type and iterator instead of xarray iter
` [PATCH v2 16/25] netfs: Provide an iterator-reset function
` [PATCH v2 17/25] netfs: Simplify the writeback code
` [PATCH v2 18/25] afs: Make read subreqs async
` [PATCH v2 19/25] netfs: Speed up buffered reading
` [PATCH v2 20/25] netfs: Remove fs/netfs/io.c
` [PATCH v2 21/25] cachefiles, netfs: Fix write to partial block at EOF
` [PATCH v2 22/25] netfs: Cancel dirty folios that have no storage destination
` [PATCH v2 23/25] cifs: Use iterate_and_advance*() routines directly for hashing
` [PATCH v2 24/25] cifs: Switch crypto buffer to use a folio_queue rather than an xarray
` [PATCH v2 25/25] cifs: Don't support ITER_XARRAY
[PATCH 0/2] Finish converting jffs2 to folios
2024-08-14 19:59 UTC (3+ messages)
` [PATCH 1/2] jffs2: Convert jffs2_do_readpage_nolock to take a folio
` [PATCH 2/2] jffs2: Use a folio in jffs2_garbage_collect_dnode()
[PATCH] netfs, ceph: Partially revert "netfs: Replace PG_fscache by setting folio->private and marking dirty"
2024-08-14 19:50 UTC
[PATCH 00/16] Prepare to remove PG_error
2024-08-14 19:32 UTC (6+ messages)
` [PATCH 12/16] romfs: Convert romfs_read_folio() to use a folio
[PATCH v6 bpf-next 00/10] Harden and extend ELF build ID parsing logic
2024-08-14 18:54 UTC (11+ messages)
` [PATCH v6 bpf-next 01/10] lib/buildid: harden "
` [PATCH v6 bpf-next 02/10] lib/buildid: add single folio-based file reader abstraction
` [PATCH v6 bpf-next 03/10] lib/buildid: take into account e_phoff when fetching program headers
` [PATCH v6 bpf-next 04/10] lib/buildid: remove single-page limit for PHDR search
` [PATCH v6 bpf-next 05/10] lib/buildid: rename build_id_parse() into build_id_parse_nofault()
` [PATCH v6 bpf-next 06/10] lib/buildid: implement sleepable build_id_parse() API
` [PATCH v6 bpf-next 07/10] lib/buildid: don't limit .note.gnu.build-id to the first page in ELF
` [PATCH v6 bpf-next 08/10] bpf: decouple stack_map_get_build_id_offset() from perf_callchain_entry
` [PATCH v6 bpf-next 09/10] bpf: wire up sleepable bpf_get_stack() and bpf_get_task_stack() helpers
` [PATCH v6 bpf-next 10/10] selftests/bpf: add build ID tests
[PATCH] fuse: add FOPEN_FETCH_ATTR flag for fetching attributes after open
2024-08-14 18:06 UTC (10+ messages)
[RFC] Merge PG_private_2 and PG_mappedtodisk
2024-08-14 17:36 UTC
[PATCH v5 bpf-next 00/10] Harden and extend ELF build ID parsing logic
2024-08-14 17:06 UTC (6+ messages)
` [PATCH v5 bpf-next 01/10] lib/buildid: harden "
[PATCH] fuse: use GFP_KERNEL_ACCOUNT for allocations in fuse_dev_alloc
2024-08-14 16:54 UTC (2+ messages)
[PATCH v2] fs: try an opportunistic lookup for O_CREAT opens too
2024-08-14 16:46 UTC (9+ messages)
[GIT PULL] vfs fixes
2024-08-14 16:28 UTC (2+ messages)
[PATCH v10 00/40] arm64/gcs: Provide support for GCS in userspace
2024-08-14 16:21 UTC (7+ messages)
` [PATCH v10 23/40] arm64/signal: Set up and restore the GCS context for signal handlers
` [PATCH v10 24/40] arm64/signal: Expose GCS state in signal frames
[PATCH v3] fuse: Allow page aligned writes
2024-08-14 16:02 UTC (3+ messages)
[PATCH v2] fs,security: Fix file_set_fowner LSM hook inconsistencies
2024-08-14 15:13 UTC (9+ messages)
[PATCH v4 00/29] arm64: Permission Overlay Extension
2024-08-14 15:03 UTC (8+ messages)
` [PATCH v4 18/29] arm64: add POE signal support
[PATCH v2 0/9] fuse: basic support for idmapped mounts
2024-08-14 14:19 UTC (11+ messages)
` [PATCH v2 1/9] fs/fuse: add FUSE_OWNER_UID_GID_EXT extension
` [PATCH v2 2/9] fs/fuse: support idmap for mkdir/mknod/symlink/create
` [PATCH v2 3/9] fs/fuse: support idmapped getattr inode op
` [PATCH v2 4/9] fs/fuse: support idmapped ->permission "
` [PATCH v2 5/9] fs/fuse: support idmapped ->setattr op
` [PATCH v2 6/9] fs/fuse: drop idmap argument from __fuse_get_acl
` [PATCH v2 7/9] fs/fuse: support idmapped ->set_acl
` [PATCH v2 8/9] fs/fuse: properly handle idmapped ->rename op
` [PATCH v2 9/9] fs/fuse: allow idmapped mounts
[syzbot] [xfs?] possible deadlock in xfs_icwalk_ag (2)
2024-08-14 14:12 UTC (2+ messages)
[PATCH] vfs: drop one lock trip in evict()
2024-08-14 12:43 UTC (4+ messages)
[PATCH] fuse: add fast path for fuse_range_is_writeback
2024-08-14 9:56 UTC (2+ messages)
[PATCH] autofs: add per dentry expire timeout
2024-08-14 8:00 UTC (3+ messages)
[PATCH v3 0/2] virtiofs: fix the warning for kernel direct IO
2024-08-14 7:49 UTC (4+ messages)
[PATCH 03/11] close_files(): don't bother with xchg()
2024-08-14 5:34 UTC (4+ messages)
` [PATCH] close_files(): reimplement based on do_close_on_exec()
conver XFS perag lookup to xarrays
2024-08-14 5:21 UTC (4+ messages)
` [PATCH 2/3] xfs: convert perag lookup to xarray
[PATCH v6 0/9] Improve the copy of task comm
2024-08-14 2:34 UTC (5+ messages)
` [PATCH v6 7/9] tracing: Replace strncpy() with strscpy()
[PATCH 0/9] f2fs: new mount API conversion
2024-08-14 2:39 UTC (10+ messages)
` [PATCH 1/9] f2fs: Add fs parameter specifications for mount options
` [PATCH 2/9] f2fs: move the option parser into handle_mount_opt
` [PATCH 3/9] f2fs: move option validation into a separate helper
` [PATCH 4/9] f2fs: Allow sbi to be NULL in f2fs_printk
` [PATCH 5/9] f2fs: Add f2fs_fs_context to record the mount options
` [PATCH 6/9] f2fs: separate the options parsing and options checking
` [PATCH 7/9] f2fs: introduce fs_context_operation structure
` [PATCH 8/9] f2fs: switch to the new mount api
` [PATCH 9/9] f2fs: remove unused structure and functions
[viro-vfs:work.fdtable 13/13] kernel/fork.c:3242 unshare_fd() warn: passing a valid pointer to 'PTR_ERR'
2024-08-14 1:03 UTC (3+ messages)
[PATCH RFC 0/13] fs: generic filesystem shutdown handling
2024-08-14 0:09 UTC (4+ messages)
[PATCH v4 0/2] fuse: add timeout option for requests
2024-08-13 23:22 UTC (3+ messages)
` [PATCH v4 1/2] fuse: add optional kernel-enforced timeout "
` [PATCH v4 2/2] fuse: add default_request_timeout and max_request_timeout sysctls
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox