messages from 2025-03-13 23:34:01 to 2025-03-16 19:20:01 UTC [more...]
apparmor NULL pointer dereference on resume [efivarfs]
2025-03-16 19:19 UTC (10+ messages)
` [RFC 1/1] fix NULL mnt [was Re: apparmor NULL pointer dereference on resume [efivarfs]]
[RFC PATCH 0/8] staging: apfs: init APFS module
2025-03-16 15:48 UTC (27+ messages)
` [PATCH RFC 1/8] staging: apfs: init lzfse compression library for APFS
` [PATCH RFC 2/8] staging: apfs: init unicode.{c,h}
` [PATCH RFC 3/8] staging: apfs: init apfs_raw.h to handle on-disk structures
` [PATCH RFC 4/8] staging: apfs: init libzbitmap.{c,h} for decompression
` [PATCH RFC 5/8] staging: apfs: init APFS
` [PATCH RFC 6/8] staging: apfs: init build support for APFS
` [PATCH RFC 7/8] staging: apfs: init TODO and README.rst
` [PATCH RFC 8/8] MAINTAINERS: apfs: add entry and relevant information
[PATCH v6 00/13] large atomic writes for xfs with CoW
2025-03-16 13:40 UTC (5+ messages)
` [PATCH v6 01/13] iomap: inline iomap_dio_bio_opflags()
` [PATCH v6 10/13] xfs: iomap COW-based atomic write support
[PATCH v2] ext4: hash: simplify kzalloc(n * 1, ...) to kzalloc(n, ...)
2025-03-16 12:54 UTC (2+ messages)
[PATCH] pidfs: ensure that PIDFS_INFO_EXIT is available
2025-03-16 12:49 UTC
[syzbot] [exfat?] INFO: task hung in __blockdev_direct_IO (4)
2025-03-16 9:28 UTC
[PATCH] ext4: hash: change kzalloc(n * sizeof, ...) to kcalloc(n, sizeof, ...)
2025-03-16 5:27 UTC (3+ messages)
[PATCH RFC 0/6] Allow file-backed or shared device private pages
2025-03-16 4:29 UTC (7+ messages)
` [PATCH RFC 1/6] mm/migrate_device.c: Don't read dirty bit of non-present PTEs
` [PATCH RFC 2/6] mm/migrate: Support file-backed pages with migrate_vma
` [PATCH RFC 3/6] mm: Allow device private pages to exist in page cache
` [PATCH RFC 4/6] mm: Implement writeback for share device private pages
` [PATCH RFC 5/6] selftests/hmm: Add file-backed migration tests
` [PATCH RFC 6/6] nouveau: Add SVM support for migrating file-backed pages to the GPU
[GIT PULL] fsnotify: Revert HSM events on page fault
2025-03-15 18:40 UTC (2+ messages)
[PATCH v3 0/3] xfsprogs: Add support for preadv2() and RWF_DONTCACHE
2025-03-15 12:49 UTC (5+ messages)
` [PATCH v3 1/3] xfs_io: Add support for preadv2
` [PATCH v3 2/3] xfs_io: Add RWF_DONTCACHE support to pwritev2
` [PATCH v3 3/3] xfs_io: Add RWF_DONTCACHE support to preadv2
[PATCH RFC 0/2] Dynamically allocate memory to store task's full name
2025-03-15 7:43 UTC (5+ messages)
` [PATCH RFC 1/2] exec: "
` [PATCH RFC 2/2] fs/proc: Pass 'task->full_name' via 'proc_task_name()'
[PATCH v2 0/4] track memory used by balloon drivers
2025-03-15 4:09 UTC (7+ messages)
` [PATCH v2 1/4] meminfo: add a per node counter for "
` [PATCH v2 2/4] balloon_compaction: update the NR_BALLOON_PAGES state
` [PATCH v2 3/4] hv_balloon: "
` [PATCH v2 4/4] xen: balloon: "
[PATCH v1] fuse: support configurable number of uring queues
2025-03-14 23:11 UTC (2+ messages)
[PATCH v2] fuse: fix uring race condition for null dereference of fc
2025-03-14 22:51 UTC (3+ messages)
[PATCH] fuse: enable larger read buffers for readdir [v2]
2025-03-14 22:16 UTC (4+ messages)
` fuse: increase readdir() buffer size
` [PATCH 1/2] fs: Supply dir_context.count as readdir buffer size hint
` [PATCH 2/2] fuse: Adjust readdir() buffer to requesting buffer size
[RFC PATCH 00/35] ceph, rbd, netfs: Make ceph fully use netfslib
2025-03-14 22:27 UTC (40+ messages)
` [RFC PATCH 01/35] ceph: Fix incorrect flush end position calculation
` [RFC PATCH 02/35] libceph: Rename alignment to offset
` [RFC PATCH 03/35] libceph: Add a new data container type, ceph_databuf
` [RFC PATCH 04/35] ceph: Convert ceph_mds_request::r_pagelist to a databuf
` [RFC PATCH 05/35] libceph: Add functions to add ceph_databufs to requests
` [RFC PATCH 06/35] rbd: Use ceph_databuf for rbd_obj_read_sync()
` [RFC PATCH 07/35] libceph: Change ceph_osdc_call()'s reply to a ceph_databuf
` [RFC PATCH 08/35] libceph: Unexport osd_req_op_cls_request_data_pages()
` [RFC PATCH 09/35] libceph: Remove osd_req_op_cls_response_data_pages()
` [RFC PATCH 10/35] libceph: Convert notify_id_pages to a ceph_databuf
` [RFC PATCH 11/35] ceph: Use ceph_databuf in DIO
` [RFC PATCH 12/35] libceph: Bypass the messenger-v1 Tx loop for databuf/iter data blobs
` [RFC PATCH 13/35] rbd: Switch from using bvec_iter to iov_iter
` [RFC PATCH 14/35] libceph: Remove bvec and bio data container types
` [RFC PATCH 15/35] libceph: Make osd_req_op_cls_init() use a ceph_databuf and map it
` [RFC PATCH 16/35] libceph: Convert req_page of ceph_osdc_call() to ceph_databuf
` [RFC PATCH 17/35] libceph, rbd: Use ceph_databuf encoding start/stop
` [RFC PATCH 18/35] libceph, rbd: Convert some page arrays to ceph_databuf
` [RFC PATCH 19/35] libceph, ceph: Convert users of ceph_pagelist "
` [RFC PATCH 20/35] libceph: Remove ceph_pagelist
` [RFC PATCH 21/35] libceph: Make notify code use ceph_databuf_enc_start/stop
` [RFC PATCH 22/35] libceph, rbd: Convert ceph_osdc_notify() reply to ceph_databuf
` [RFC PATCH 23/35] rbd: Use ceph_databuf_enc_start/stop()
` [RFC PATCH 24/35] ceph: Make ceph_calc_file_object_mapping() return size as size_t
` [RFC PATCH 25/35] ceph: Wrap POSIX_FADV_WILLNEED to get caps
` [RFC PATCH 26/35] ceph: Kill ceph_rw_context
` [RFC PATCH 27/35] netfs: Pass extra write context to write functions
` [RFC PATCH 28/35] netfs: Adjust group handling
` [RFC PATCH 29/35] netfs: Allow fs-private data to be handed through to request alloc
` [RFC PATCH 30/35] netfs: Make netfs_page_mkwrite() use folio_mkwrite_check_truncate()
` [RFC PATCH 31/35] netfs: Fix netfs_unbuffered_read() to return ssize_t rather than int
` [RFC PATCH 32/35] netfs: Add some more RMW support for ceph
` [RFC PATCH 33/35] ceph: Use netfslib [INCOMPLETE]
` [RFC PATCH 34/35] ceph: Enable multipage folios for ceph files
` [RFC PATCH 35/35] ceph: Remove old I/O API bits
[PATCH RESEND v3 0/2] Minimize xa_node allocation during xarry split
2025-03-14 22:21 UTC (3+ messages)
` [PATCH RESEND v3 1/2] mm/filemap: use xas_try_split() in __filemap_add_folio()
` [PATCH RESEND v3 2/2] mm/shmem: use xas_try_split() in shmem_split_large_entry()
[PATCH v12 00/28] riscv control-flow integrity for usermode
2025-03-14 21:39 UTC (29+ messages)
` [PATCH v12 01/28] mm: VM_SHADOW_STACK definition for riscv
` [PATCH v12 02/28] dt-bindings: riscv: zicfilp and zicfiss in dt-bindings (extensions.yaml)
` [PATCH v12 03/28] riscv: zicfiss / zicfilp enumeration
` [PATCH v12 04/28] riscv: zicfiss / zicfilp extension csr and bit definitions
` [PATCH v12 05/28] riscv: usercfi state for task and save/restore of CSR_SSP on trap entry/exit
` [PATCH v12 06/28] riscv/mm : ensure PROT_WRITE leads to VM_READ | VM_WRITE
` [PATCH v12 07/28] riscv mm: manufacture shadow stack pte
` [PATCH v12 08/28] riscv mmu: teach pte_mkwrite to manufacture shadow stack PTEs
` [PATCH v12 09/28] riscv mmu: write protect and shadow stack
` [PATCH v12 10/28] riscv/mm: Implement map_shadow_stack() syscall
` [PATCH v12 11/28] riscv/shstk: If needed allocate a new shadow stack on clone
` [PATCH v12 12/28] riscv: Implements arch agnostic shadow stack prctls
` [PATCH v12 13/28] prctl: arch-agnostic prctl for indirect branch tracking
` [PATCH v12 14/28] riscv: Implements arch agnostic indirect branch tracking prctls
` [PATCH v12 15/28] riscv/traps: Introduce software check exception
` [PATCH v12 16/28] riscv: signal: abstract header saving for setup_sigcontext
` [PATCH v12 17/28] riscv/signal: save and restore of shadow stack for signal
` [PATCH v12 18/28] riscv/kernel: update __show_regs to print shadow stack register
` [PATCH v12 19/28] riscv/ptrace: riscv cfi status and state via ptrace and in core files
` [PATCH v12 20/28] riscv/hwprobe: zicfilp / zicfiss enumeration in hwprobe
` [PATCH v12 21/28] riscv: Add Firmware Feature SBI extensions definitions
` [PATCH v12 22/28] riscv: enable kernel access to shadow stack memory via FWFT sbi call
` [PATCH v12 23/28] riscv: kernel command line option to opt out of user cfi
` [PATCH v12 24/28] arch/riscv: compile vdso with landing pad
` [PATCH v12 25/28] riscv: create a config for shadow stack and landing pad instr support
` [PATCH v12 26/28] riscv: Documentation for landing pad / indirect branch tracking
` [PATCH v12 27/28] riscv: Documentation for shadow stack on riscv
` [PATCH v12 28/28] kselftest/riscv: kselftest for user mode cfi
[PATCH 0/4] f2fs: Remove uses of writepage
2025-03-14 21:38 UTC (6+ messages)
` [f2fs-dev] "
[PATCH 0/4] netfs: Miscellaneous fixes
2025-03-14 20:44 UTC (6+ messages)
` [PATCH 1/4] netfs: Fix collection of results during pause when collection offloaded
` [PATCH 2/4] netfs: Call `invalidate_cache` only if implemented
` [PATCH 3/4] netfs: Fix rolling_buffer_load_from_ra() to not clear mark bits
` [PATCH 4/4] netfs: Fix netfs_unbuffered_read() to return ssize_t rather than int
[PATCH] fuse: fix uring race condition for null dereference of fc
2025-03-14 19:56 UTC (3+ messages)
PI and data checksumming for XFS
2025-03-14 16:53 UTC (4+ messages)
` [PATCH 3/7] iomap: add bioset in iomap_read_folio_ops for filesystems to use own bioset
[PATCH v11 00/27] riscv control-flow integrity for usermode
2025-03-14 16:19 UTC (40+ messages)
` [PATCH v11 01/27] mm: VM_SHADOW_STACK definition for riscv
` [PATCH v11 03/27] riscv: zicfiss / zicfilp enumeration
` [PATCH v11 05/27] riscv: usercfi state for task and save/restore of CSR_SSP on trap entry/exit
` [PATCH v11 06/27] riscv/mm : ensure PROT_WRITE leads to VM_READ | VM_WRITE
` [PATCH v11 07/27] riscv mm: manufacture shadow stack pte
` [PATCH v11 08/27] riscv mmu: teach pte_mkwrite to manufacture shadow stack PTEs
` [PATCH v11 09/27] riscv mmu: write protect and shadow stack
` [PATCH v11 10/27] riscv/mm: Implement map_shadow_stack() syscall
` [PATCH v11 11/27] riscv/shstk: If needed allocate a new shadow stack on clone
` [PATCH v11 13/27] prctl: arch-agnostic prctl for indirect branch tracking
` [PATCH v11 14/27] riscv/traps: Introduce software check exception
` [PATCH v11 19/27] riscv/hwprobe: zicfilp / zicfiss enumeration in hwprobe
` [PATCH v11 20/27] riscv: Add Firmware Feature SBI extensions definitions
` [PATCH v11 21/27] riscv: enable kernel access to shadow stack memory via FWFT sbi call
` [PATCH v11 23/27] arch/riscv: compile vdso with landing pad
` [PATCH v11 24/27] riscv: create a config for shadow stack and landing pad instr support
` [PATCH v11 25/27] riscv: Documentation for landing pad / indirect branch tracking
` [PATCH v11 26/27] riscv: Documentation for shadow stack on riscv
` [PATCH v11 27/27] kselftest/riscv: kselftest for user mode cfi
[PATCH] fs: dedup handling of struct filename init and refcounts bumps
2025-03-14 15:44 UTC (2+ messages)
[RFC PATCH v1] landlock: Allow signals between threads of the same process
2025-03-14 15:42 UTC (2+ messages)
[PATCH v2] fs: consistently deref the files table with rcu_dereference_raw()
2025-03-14 15:40 UTC (2+ messages)
[PATCH v2] drop_caches: re-enable message after disabling
2025-03-14 12:28 UTC (2+ messages)
[PATCH] drop_caches: Allow re-enabling message after disabling
2025-03-14 10:48 UTC (2+ messages)
[PATCH] VFS/autofs: try_lookup_one_len() does not need any locks
2025-03-14 10:45 UTC (2+ messages)
[PATCH] exportfs: remove locking around ->get_parent() call
2025-03-14 10:40 UTC (2+ messages)
[PATCH 0/8 RFC] tidy up various VFS lookup functions
2025-03-14 10:38 UTC (10+ messages)
` [PATCH 1/8] VFS: improve interface for lookup_one functions
` [PATCH 2/8] nfsd: Use lookup_one() rather than lookup_one_len()
` [PATCH 3/8] nfsd: use correct idmap for all accesses
` [PATCH 4/8] cachefiles: Use lookup_one() rather than lookup_one_len()
` [PATCH 5/8] cachefiles: use correct mnt_idmap
` [PATCH 6/8] VFS: rename lookup_one_len() family to lookup_noperm() and remove permission check
` [PATCH 7/8] Use try_lookup_noperm() instead of d_hash_and_lookup() outside of VFS
` [PATCH 8/8] VFS: change lookup_one_common and lookup_noperm_common to take a qstr
[GIT PULL] bcachefs fixes for 6.14-rc7
2025-03-14 1:38 UTC (2+ messages)
[RFC PATCH 0/6] fs, lsm: mediate O_PATH fd creation in file_open hook
2025-03-14 1:28 UTC (5+ messages)
` [RFC PATCH 1/6] fs: invoke LSM file_open hook in do_dentry_open for O_PATH fds as well
Does ceph_fill_inode() mishandle I_NEW?
2025-03-13 23:47 UTC (7+ messages)
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox