messages from 2025-06-12 13:25:44 to 2025-06-14 14:23:30 UTC [more...]
[PATCH v1 0/8] fuse: use iomap for buffered writes + writeback
2025-06-14 14:22 UTC (4+ messages)
[PATCH v5] block: support mtd:<name> syntax for block devices
2025-06-14 12:43 UTC (3+ messages)
` [PATCH v6] "
[PATCH] fuse: fix fuse_fill_write_pages() upper bound calculation
2025-06-14 10:58 UTC (2+ messages)
[BUG] fuse/virtiofs: kernel module build fail
2025-06-14 10:55 UTC (7+ messages)
[syzbot] [iomap?] [erofs?] WARNING in iomap_iter (5)
2025-06-14 9:46 UTC (2+ messages)
[PATCHES] ceph d_name race fixes
2025-06-14 6:22 UTC (4+ messages)
` [PATCH 1/3] [ceph] parse_longname(): strrchr() expects NUL-terminated string
` [PATCH 2/3] prep for ceph_encode_encrypted_fname() fixes
` [PATCH 3/3] ceph: fix a race with rename() in ceph_mdsc_build_path()
[PATCHES][RFC][CFT] simple_recursive_removal() work
2025-06-14 6:02 UTC (9+ messages)
` [PATCH 1/8] simple_recursive_removal(): saner interaction with fsnotify
` [PATCH 2/8] add locked_recursive_removal()
` [PATCH 3/8] spufs: switch to locked_recursive_removal()
` [PATCH 4/8] binfmt_misc: "
` [PATCH 5/8] pstore: "
` [PATCH 6/8] fuse_ctl: use simple_recursive_removal()
` [PATCH 7/8] kill binderfs_remove_file()
` [PATCH 8/8] functionfs, gadgetfs: use simple_recursive_removal()
[PATCH 00/10] fallocate: introduce FALLOC_FL_WRITE_ZEROES flag
2025-06-14 4:48 UTC (11+ messages)
` [PATCH 01/10] block: introduce BLK_FEAT_WRITE_ZEROES_UNMAP to queue limits features
[PATCH v3 RESEND] selftests: filesystems: Add functional test for the abort file in fusectl
2025-06-14 2:29 UTC (3+ messages)
[PATCH 0/3] Folio conversions in extent-io-tests
2025-06-14 0:04 UTC (6+ messages)
` [PATCH 1/3] btrfs: Convert test_find_delalloc() to use a folio
` [PATCH 2/3] btrfs: Convert test_find_delalloc() to use a folio, part two
` [PATCH 3/3] btrfs: Simplify dump_eb_and_memory_contents()
[PATCHES][RFC][CFT] rpc_pipefs cleanups
2025-06-13 23:46 UTC (24+ messages)
` [PATCH 01/17] simple_recursive_removal(): saner interaction with fsnotify
` [PATCH 02/17] new helper: simple_start_creating()
` [PATCH 03/17] rpc_pipe: clean failure exits in fill_super
` [PATCH 04/17] rpc_{rmdir_,}depopulate(): use simple_recursive_removal() instead
` [PATCH 05/17] rpc_unlink(): use simple_recursive_removal()
` [PATCH 06/17] rpc_populate(): lift cleanup into callers
` [PATCH 07/17] rpc_unlink(): saner calling conventions
` [PATCH 08/17] rpc_mkpipe_dentry(): "
` [PATCH 09/17] rpc_pipe: don't overdo directory locking
` [PATCH 10/17] rpc_pipe: saner primitive for creating subdirectories
` [PATCH 11/17] rpc_pipe: saner primitive for creating regular files
` [PATCH 12/17] rpc_mkpipe_dentry(): switch to start_creating()
` [PATCH 13/17] rpc_gssd_dummy_populate(): don't bother with rpc_populate()
` [PATCH 14/17] rpc_pipe: expand the calls of rpc_mkdir_populate()
` [PATCH 15/17] rpc_new_dir(): the last argument is always NULL
` [PATCH 16/17] rpc_create_client_dir(): don't bother with rpc_populate()
` [PATCH 17/17] rpc_create_client_dir(): return 0 or -E
[PATCH v4 bpf-next 0/5] bpf path iterator
2025-06-13 22:27 UTC (6+ messages)
` [PATCH v4 bpf-next 1/5] namei: Introduce new helper function path_walk_parent()
` [PATCH v4 bpf-next 3/5] bpf: Introduce path iterator
[RFC PATCH v2 23/51] mm: hugetlb: Refactor out hugetlb_alloc_folio()
2025-06-13 22:07 UTC (2+ messages)
[RFC PATCH v2 22/51] mm: hugetlb: Refactor hugetlb allocation functions
2025-06-13 22:03 UTC (2+ messages)
[PATCH v2 00/16] fuse: use iomap for buffered writes + writeback
2025-06-13 21:46 UTC (17+ messages)
` [PATCH v2 01/16] iomap: move buffered io CONFIG_BLOCK dependent logic into separate file
` [PATCH v2 02/16] iomap: iomap_read_folio_sync() -> iomap_bio_read_folio_sync()
` [PATCH v2 03/16] iomap: iomap_add_to_ioend() -> iomap_bio_add_to_ioend()
` [PATCH v2 04/16] iomap: add wrapper function iomap_bio_readpage()
` [PATCH v2 05/16] iomap: add wrapper function iomap_bio_ioend_error()
` [PATCH v2 06/16] iomap: add wrapper function iomap_submit_bio()
` [PATCH v2 07/16] iomap: decouple buffered-io.o from CONFIG_BLOCK
` [PATCH v2 08/16] iomap: add read_folio_sync() handler for buffered writes
` [PATCH v2 09/16] iomap: change 'count' to 'async_writeback'
` [PATCH v2 10/16] iomap: replace ->map_blocks() with generic ->writeback_folio() for writeback
` [PATCH v2 11/16] iomap: replace ->submit_ioend() with generic ->writeback_complete() "
` [PATCH v2 12/16] iomap: support more customized writeback handling
` [PATCH v2 13/16] iomap: add iomap_writeback_dirty_folio()
` [PATCH v2 14/16] fuse: use iomap for buffered writes
` [PATCH v2 15/16] fuse: use iomap for writeback
` [PATCH v2 16/16] fuse: use iomap for folio laundering
[PATCH v4 0/7] use per-vma locks for /proc/pid/maps reads and PROCMAP_QUERY
2025-06-13 20:36 UTC (6+ messages)
` [PATCH v4 7/7] mm/maps: execute PROCMAP_QUERY ioctl under per-vma locks
[PATCH 0/2] Use folios for fuse readdir cache
2025-06-13 20:31 UTC (6+ messages)
` [PATCH 1/2] fuse: Use a folio in fuse_add_dirent_to_cache()
` [PATCH 2/2] fuse: Use a folio in fuse_readdir_cached()
[PATCH 0/5] Remove zero_user()
2025-06-13 20:04 UTC (10+ messages)
` [PATCH 1/5] bio: Use memzero_page() in bio_truncate()
` [PATCH 2/5] null_blk: Use memzero_page()
` [PATCH 3/5] direct-io: "
` [PATCH 4/5] ceph: Convert ceph_zero_partial_page() to use a folio
` [PATCH 5/5] mm: Remove zero_user()
[PATCH] virtio_fs: Remove redundant spinlock in virtio_fs_request_complete()
2025-06-13 19:51 UTC (2+ messages)
[PATCH v5] ceph: fix slab-use-after-free in have_mon_and_osd_map()
2025-06-13 18:44 UTC (6+ messages)
[PATCH] ceph: fix potential race condition in ceph_ioctl_lazyio()
2025-06-13 18:34 UTC
[GIT PULL] bcachefs fixes for 6.16-rc2
2025-06-13 18:04 UTC (2+ messages)
[RFC[RAP]] fuse: use fs-iomap for better performance so we can containerize ext4
2025-06-13 17:44 UTC (13+ messages)
` [RFC[RAP] V2] "
[PATCH v3] fuse: new workqueue to periodically invalidate expired dentries
2025-06-13 15:53 UTC (2+ messages)
[RFC] Keyrings: How to make them more useful
2025-06-13 15:40 UTC (5+ messages)
Getting Unexpected Lookup entries calls after Readdirplus
2025-06-13 13:34 UTC (4+ messages)
` [fuse] "
[PATCH 0/6] NFSD: add enable-dontcache and initially use it to add DIO support
2025-06-13 13:02 UTC (27+ messages)
` [PATCH 1/6] NFSD: add the ability to enable use of RWF_DONTCACHE for all IO
` need SUNRPC TCP to receive into aligned pages [was: Re: [PATCH 1/6] NFSD: add the ability to enable use of RWF_DONTCACHE for all IO]
[syzbot] [hfs?] INFO: task hung in hfs_mdb_commit (3)
2025-06-13 11:04 UTC
[PATCH v1] exfat: add cluster chain loop check for dir
2025-06-13 10:38 UTC
[PATCH] fs: don't needlessly acquire f_lock
2025-06-13 10:35 UTC (10+ messages)
` [PATCH] fs: drop assert in file_seek_cur_needs_f_lock
` [PATCH v2] "
[PATCH] exfat: fdatasync flag should be same like generic_write_sync()
2025-06-13 10:13 UTC (2+ messages)
[PATCH v4 0/4] Implement dmabuf direct I/O via copy_file_range
2025-06-13 9:43 UTC (13+ messages)
[PATCHv2 1/2] sched/wait: Add wait_event_state_exclusive()
2025-06-13 9:17 UTC (2+ messages)
[PATCH 0/5] add STATIC_PMD_ZERO_PAGE config option
2025-06-13 8:58 UTC (8+ messages)
` [PATCH 4/5] mm: add mm_get_static_huge_zero_folio() routine
[PATCH] zonefs: use ZONEFS_SUPER_SIZE instead of PAGE_SIZE
2025-06-13 8:07 UTC (2+ messages)
[PATCH 1/2] VFS: change old_dir and new_dir in struct renamedata to dentrys
2025-06-13 7:08 UTC (2+ messages)
[PATCH 0/7] Some random fixes and cleanups to shmem
2025-06-13 6:56 UTC (7+ messages)
` [PATCH 2/7] mm: shmem: avoid setting error on splited entries in shmem_set_folio_swapin_error()
[PATCH] proc_sysctl: Fix up ->is_seen() handling
2025-06-13 3:14 UTC (7+ messages)
[PATCH] proc_sysctl: remove RCU annotations for accessing ->sysctl
2025-06-13 3:04 UTC (2+ messages)
[PATCH v4 0/7] Add managed SOFT RESERVE resource handling
2025-06-13 2:12 UTC (3+ messages)
` [PATCH v4 7/7] cxl/dax: Defer DAX consumption of SOFT RESERVED resources until after CXL region creation
[PATCH for-next v3 0/2] add ioctl to query metadata and protection info capabilities
2025-06-13 1:51 UTC (3+ messages)
` [PATCH for-next v3 1/2] block: introduce pi_size field in blk_integrity
[PATCH v2] VFS: change old_dir and new_dir in struct renamedata to dentrys
2025-06-12 23:28 UTC
[PATCH 1/2] VFS: change old_dir and new_dir in struct renamedata to dentrys
2025-06-12 23:22 UTC (2+ messages)
[PATCH 0/2] Minor VFS-related cleanups
2025-06-12 22:52 UTC (3+ messages)
` [PATCH 1/2] VFS: change old_dir and new_dir in struct renamedata to dentrys
[PATCH 00/12] mm: Remove pXX_devmap page table bit and pfn_t type
2025-06-12 22:50 UTC (4+ messages)
` [PATCH 03/12] mm/pagewalk: Skip dax pages in pagewalk
[REGRESSION] 9pfs issues on 6.12-rc1
2025-06-12 22:24 UTC (8+ messages)
[PATCHES][CFR][CFT] securityfs cleanups and fixes
2025-06-12 17:43 UTC (4+ messages)
` [PATCH 01/10] securityfs: don't pin dentries twice, once is enough
` [PATCH 09/10] ipe: don't bother with removal of files in directory we'll be removing
[PATCH 0/2] squashfs: Remove page->mapping references
2025-06-12 14:39 UTC (3+ messages)
` [PATCH 1/2] squashfs: Pass the inode to squashfs_readahead_fragment()
` [PATCH 2/2] squashfs: Use folios in squashfs_bio_read_cached()
[PATCH 00/24] coredump: further cleanups
2025-06-12 13:25 UTC (19+ messages)
` [PATCH 07/24] coredump: validate socket path in coredump_parse()
` [PATCH 08/24] selftests/coredump: make sure invalid paths are rejected
` [PATCH 09/24] coredump: rename do_coredump() to vfs_coredump()
` [PATCH 10/24] coredump: split file coredumping into coredump_file()
` [PATCH 11/24] coredump: prepare to simplify exit paths
` [PATCH 12/24] coredump: move core_pipe_count to global variable
` [PATCH 13/24] coredump: split pipe coredumping into coredump_pipe()
` [PATCH 14/24] coredump: move pipe specific file check "
` [PATCH 15/24] coredump: use a single helper for the socket
` [PATCH 16/24] coredump: add coredump_write()
` [PATCH 17/24] coredump: auto cleanup argv
` [PATCH 18/24] coredump: directly return
` [PATCH 19/24] cred: add auto cleanup method
` [PATCH 20/24] coredump: auto cleanup prepare_creds()
` [PATCH 21/24] coredump: add coredump_cleanup()
` [PATCH 22/24] coredump: order auto cleanup variables at the top
` [PATCH 23/24] coredump: avoid pointless variable
` [PATCH 24/24] coredump: add coredump_skip() helper
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox