Linux filesystem development
 help / color / mirror / Atom feed
 messages from 2025-09-10 20:24:05 to 2025-09-12 11:53:00 UTC [more...]

[PATCH v2 00/33] ns: support file handles
 2025-09-12 11:52 UTC 

[RFC] Another take at restarting FUSE servers
 2025-09-12 11:41 UTC  (7+ messages)

[PATCHES] nfsctl fix and cleanups
 2025-09-12 11:38 UTC  (9+ messages)
` [PATCH 1/5] nfsctl: symlink has no business bumping link count of parent directory
  ` [PATCH 2/5] nfsd_mkdir(): switch to simple_start_creating()
  ` [PATCH 3/5] _nfsd_symlink(): "
  ` [PATCH 4/5] nfsdfs_create_files(): "
  ` [PATCH 5/5] nfsd_get_inode(): lift setting ->i_{,f}op to callers

[PATCH] ext4: fix an off-by-one issue during moving extents
 2025-09-12 10:58 UTC 

[PATCH] initrd: Use str_plural() in rd_load_image()
 2025-09-12 10:50 UTC  (2+ messages)

[PATCH v6 00/11] Direct Map Removal Support for guest_memfd
 2025-09-12 10:48 UTC  (13+ messages)
` [PATCH v6 01/11] filemap: Pass address_space mapping to ->free_folio()
` [PATCH v6 02/11] arch: export set_direct_map_valid_noflush to KVM module
` [PATCH v6 03/11] mm: introduce AS_NO_DIRECT_MAP
` [PATCH v6 04/11] KVM: guest_memfd: Add stub for kvm_arch_gmem_invalidate
` [PATCH v6 05/11] KVM: guest_memfd: Add flag to remove from direct map
` [PATCH v6 06/11] KVM: selftests: load elf via bounce buffer
` [PATCH v6 07/11] KVM: selftests: set KVM_MEM_GUEST_MEMFD in vm_mem_add() if guest_memfd != -1
` [PATCH v6 08/11] KVM: selftests: Add guest_memfd based vm_mem_backing_src_types
` [PATCH v6 09/11] KVM: selftests: stuff vm_mem_backing_src_type into vm_shape
` [PATCH v6 10/11] KVM: selftests: cover GUEST_MEMFD_FLAG_NO_DIRECT_MAP in existing selftests
` [PATCH v6 11/11] KVM: selftests: Test guest execution from direct map removed gmem

[PATCH 0/4] writeback: Avoid lockups when switching inodes
 2025-09-12 10:39 UTC  (8+ messages)
` [PATCH 1/4] writeback: Avoid contention on wb->list_lock "

[PATCH v2 0/4] writeback: Avoid lockups when switching inodes
 2025-09-12 10:38 UTC  (5+ messages)
` [PATCH v2 1/4] writeback: Avoid contention on wb->list_lock "
` [PATCH v2 2/4] writeback: Avoid softlockup when switching many inodes
` [PATCH v2 3/4] writeback: Avoid excessively long inode switching times
` [PATCH v2 4/4] writeback: Add tracepoint to track pending inode switches

[PATCH v2 00/16] expand mmap_prepare functionality, port more users
 2025-09-12 10:25 UTC  (29+ messages)
` [PATCH v2 01/16] mm/shmem: update shmem to use mmap_prepare
` [PATCH v2 02/16] device/dax: update devdax "
` [PATCH v2 03/16] mm: add vma_desc_size(), vma_desc_pages() helpers
` [PATCH v2 04/16] relay: update relay to use mmap_prepare
` [PATCH v2 07/16] mm: introduce io_remap_pfn_range_[prepare, complete]()
` [PATCH v2 08/16] mm: add ability to take further action in vm_area_desc
` [PATCH v2 09/16] doc: update porting, vfs documentation for mmap_prepare actions
` [PATCH v2 10/16] mm/hugetlbfs: update hugetlbfs to use mmap_prepare
` [PATCH v2 11/16] mm: update mem char driver "
` [PATCH v2 12/16] mm: update resctl "
` [PATCH v2 13/16] mm: update cramfs "
` [PATCH v2 15/16] fs/proc: update vmcore to use .proc_mmap_prepare
` [PATCH v2 16/16] kcov: update kcov to use mmap_prepare

[PATCH v11 0/5] riscv: mm: Add soft-dirty and uffd-wp support
 2025-09-12  9:21 UTC  (11+ messages)
` [PATCH v11 1/5] mm: softdirty: Add pgtable_soft_dirty_supported()
` [PATCH v11 2/5] mm: userfaultfd: Add pgtable_uffd_wp_supported()
` [PATCH v11 3/5] riscv: Add RISC-V Svrsw60t59b extension support
` [PATCH v11 4/5] riscv: mm: Add soft-dirty page tracking support
` [PATCH v11 5/5] riscv: mm: Add userfaultfd write-protect support

[PATCH 00/32] ns: support file handles
 2025-09-12  9:12 UTC  (23+ messages)
` [PATCH 14/32] net: use ns_common_init()
` [PATCH 27/32] nsfs: support file handles
` [PATCH 29/32] nsfs: add missing id retrieval support
` [PATCH 32/32] selftests/namespaces: add file handle selftests
` [syzbot ci] Re: ns: support file handles

[RFC] a possible way of reducing the PITA of ->d_name audits
 2025-09-12  8:23 UTC  (6+ messages)
    ` ->atomic_open() fun (was Re: [RFC] a possible way of reducing the PITA of ->d_name audits)

[PATCHSET RFC v2 00/10] add support for name_to, open_by_handle_at() to io_uring
 2025-09-12  8:21 UTC  (25+ messages)
` [PATCH 01/10] fhandle: create helper for name_to_handle_at(2)
` [PATCH 02/10] io_uring: add support for IORING_OP_NAME_TO_HANDLE_AT
` [PATCH 03/10] fhandle: helper for allocating, reading struct file_handle
` [PATCH 04/10] fhandle: create do_filp_path_open() helper
` [PATCH 05/10] fhandle: make do_filp_path_open() take struct open_flags
` [PATCH 06/10] exportfs: allow VFS flags in struct file_handle
` [PATCH 07/10] exportfs: new FILEID_CACHED flag for non-blocking fh lookup
` [PATCH 08/10] io_uring: add __io_open_prep() helper
` [PATCH 09/10] io_uring: add support for IORING_OP_OPEN_BY_HANDLE_AT
` [PATCH 10/10] xfs: add support for non-blocking fh_to_dentry()

[linux-next20250911]Kernel OOPs while running generic/256 on Pmem device
 2025-09-12  7:21 UTC  (3+ messages)

[PATCH RFC 00/29] fs-verity support for XFS with post EOF merkle tree
 2025-09-12  7:19 UTC  (8+ messages)
` [PATCH RFC 02/29] iomap: introduce iomap_read/write_region interface

[PATCH 0/2] iomap: ->iomap_end() error handling fixes
 2025-09-12  7:14 UTC  (3+ messages)
` [PATCH 2/2] iomap: revert the iomap_iter pos on ->iomap_end() error

[PATCH v3 0/4] allow partial folio write with iomap_folio_state
 2025-09-12  7:13 UTC  (3+ messages)

[PATCH] initramfs: Use struct_size() helper to improve dir_add()
 2025-09-12  6:52 UTC 

[PATCH] rcu: Remove redundant rcu_read_lock/unlock() in spin_lock critical sections
 2025-09-12  6:50 UTC 

[PATCH] initramfs: Replace strcpy() with strscpy() in find_link()
 2025-09-12  6:47 UTC 

[PATCH v2 0/2] Fix the initialization of max_hw_wzeroes_unmap_sectors for stacking drivers
 2025-09-12  6:16 UTC  (2+ messages)

[RFC PATCH 2/2] cifs: Clean up declarations
 2025-09-12  5:34 UTC  (2+ messages)

[PATCH v2] hfs: introduce KUnit tests for HFS string operations
 2025-09-12  3:28 UTC  (2+ messages)

[PATCH v7 0/1] exfat: Add support for FS_IOC_{GET,SET}FSLABEL
 2025-09-12  3:26 UTC  (2+ messages)
` [PATCH v7 1/1] "

[PATCH v2 00/16] fuse: use iomap for buffered reads + readahead
 2025-09-12  1:10 UTC  (41+ messages)
` [PATCH v2 01/16] iomap: move async bio read logic into helper function
` [PATCH v2 02/16] iomap: move read/readahead bio submission "
` [PATCH v2 03/16] iomap: rename cur_folio_in_bio to folio_owned
` [PATCH v2 04/16] iomap: store read/readahead bio generically
` [PATCH v2 05/16] iomap: propagate iomap_read_folio() error to caller
` [PATCH v2 06/16] iomap: iterate over entire folio in iomap_readpage_iter()
` [PATCH v2 07/16] iomap: rename iomap_readpage_iter() to iomap_read_folio_iter()
` [PATCH v2 08/16] iomap: rename iomap_readpage_ctx struct to iomap_read_folio_ctx
` [PATCH v2 09/16] iomap: add public start/finish folio read helpers
` [PATCH v2 10/16] iomap: make iomap_read_folio_ctx->folio_owned internal
` [PATCH v2 11/16] iomap: add caller-provided callbacks for read and readahead
` [PATCH v2 12/16] iomap: add bias for async read requests
` [PATCH v2 13/16] iomap: move read/readahead logic out of CONFIG_BLOCK guard

[PATCH v2 0/8] VFS: more prep for change to directory locking
 2025-09-11 23:02 UTC  (4+ messages)
` [PATCH v2 1/7] VFS/ovl: add lookup_one_positive_killable()

[PATCH] fs/netfs: fix reference leak
 2025-09-11 22:24 UTC 

[PATCHSET RFC v4 2/4] fuse: allow servers to use iomap for better file IO performance
 2025-09-11 21:45 UTC  (7+ messages)
` [PATCH 02/23] fuse: implement the basic iomap mechanisms

[PATCHES] simple part of ->d_name stuff
 2025-09-11 20:54 UTC  (12+ messages)
` [PATCH 1/6] security_dentry_init_security(): constify qstr argument
  ` [PATCH 2/6] exfat_find(): "
  ` [PATCH 3/6] afs_edit_dir_{add,remove}(): "
  ` [PATCH 4/6] afs_dir_search: "
  ` [PATCH 5/6] generic_ci_validate_strict_name(): constify name argument
  ` [PATCH 6/6] make it easier to catch those who try to modify ->d_name

[PATCH 0/6] dax/hmem, cxl: Coordinate Soft Reserved handling with CXL
 2025-09-11 19:39 UTC  (4+ messages)
` [PATCH 1/6] dax/hmem, e820, resource: Defer Soft Reserved registration until hmem is ready

[PATCH] ceph: cleanup in check_new_map() method
 2025-09-11 18:56 UTC 

LInux NFSv4.1 client and server- case insensitive filesystems supported?
 2025-09-11 16:08 UTC  (17+ messages)
          ` NFSv4.x export options to mark export as case-insensitive, case-preserving? "
                      ` fattr4_archive "deprecated" ? "

buggered I_CREATING implementation?
 2025-09-11 16:05 UTC  (2+ messages)

[PATCH v5] ext4: increase i_disksize to offset + len in ext4_update_disksize_before_punch()
 2025-09-11 13:30 UTC 

[PATCH v4] ext4: increase i_disksize to offset + len in ext4_update_disksize_before_punch()
 2025-09-11 11:29 UTC  (4+ messages)

[PATCH v2] fanotify: add watchdog for permission events
 2025-09-11 11:25 UTC  (4+ messages)

[PATCH v2] initrd: Fix unused variable warning in rd_load_image() on s390
 2025-09-11  9:49 UTC 

[PATCH v1] exfat: support modifying mount options via remount
 2025-09-11  8:54 UTC 

[RFC PATCH v3 0/4] ->i_state accessors
 2025-09-11  9:00 UTC  (8+ messages)
` [PATCH v3 1/4] fs: expand dump_inode()
` [PATCH v3 2/4] fs: hide ->i_state handling behind accessors
` [PATCH v3 3/4] convert all filesystems to use the new ->i_state accessors
` [PATCH v3 4/4] type switch

[PATCH v2] fs/fuse: fix potential memory leak from fuse_uring_cancel
 2025-09-11  7:37 UTC  (2+ messages)

[PATCH v2] fs: expand dump_inode()
 2025-09-11  6:56 UTC 

[PATCH V10 0/5] riscv: mm: Add soft-dirty and uffd-wp support
 2025-09-11  2:51 UTC  (6+ messages)
` [PATCH V10 1/5] mm: softdirty: Add pte_soft_dirty_available()

[PATCH v3] ext4: increase i_disksize to offset + len in ext4_update_disksize_before_punch()
 2025-09-11  1:10 UTC  (3+ messages)

[PATCH v2 7/7] Use simple_start_creating() in various places
 2025-09-10 23:13 UTC  (2+ messages)

[PATCH] hfs: introduce KUnit tests for HFS string operations
 2025-09-10 22:01 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox